xper

IPB Update July 2013 (to version 3.4.5) - BUGS Only

268 posts in this topic

Unless something was fixed in the non-existing time between Today, 12:14 AM and Today, 10:20 AM, there is still something "queer" going on.

I'm not sure what you mean by non-existing time. Isn't that referring to 14 minutes after midnight and 10:20 AM the same morning, ie a 10 hour and 6 minute time period? :)

EDIT: I had 1 new conversation in my inbox just now, ie your response, so for me at least, it seems to working correctly. But apparently from your experience, not consistently.

Cheers and Regards

Edited by bphlpt
0

Share this post


Link to post
Share on other sites

Everything works just fine here. Remember to clear temp files, browser cache and try Ctrl+F5 because I still do some site changes.

0

Share this post


Link to post
Share on other sites

Unless something was fixed in the non-existing time between Today, 12:14 AM and Today, 10:20 AM, there is still something "queer" going on.

I'm not sure what you mean by non-existing time. Isn't that referring to 14 minutes after midnight and 10:20 AM the same morning, ie a 10 hour and 6 minute time period? :)

EDIT: I had 1 new conversation in my inbox just now, ie your response, so for me at least, it seems to working correctly. But apparently from your experience, not consistently.

Cheers and Regards

Ooops, sorry, I thought you sent the two messages within a short delay (one or two hours at the most) and that there were issues with times. My bad :blushing: .

I take it back.

Maybe this only happens if you get TWO messages by the SAME person (and thus going into the same "conversation")?

I will try to send you TWO messages in short succession, please check if you get a notification with "2" or just 1.

jaclaz

0

Share this post


Link to post
Share on other sites

Just 1.

Now you'll need to get two different people to both send you messages and see what happens.

Cheers and Regards

0

Share this post


Link to post
Share on other sites

Just 1.

Now you'll need to get two different people to both send you messages and see what happens.

Cheers and Regards

Ah well, no.

Now that my "gut feeling" is confirmed (partially) the bug is described and Xper (when he has time as this is a very-non-relevant issue) may have a look abiut it.

As well the "View new Content" automagically going to "new members" is only a nuisance.

The botched post numbering/referencing (post #2 in this thread) has IMHO a much greater priority.

jaclaz

0

Share this post


Link to post
Share on other sites

Size tags don't work properly, or at least they don't work like they used to, the old size 4 was a bit larger than the new size 5.

Size 1 Size 2 Size 3 Size 4

Size 5 Size 6 Size 7 Size 8

Size 9 Size 10 Size 11 Size 12

Size 13 Size 14 Size 15 Size 16

0

Share this post


Link to post
Share on other sites

Size tags don't work properly, or at least they don't work like they used to, the old size 4 was a bit larger than the new size 5.

Size 1 Size 2 Size 3 Size 4

Size 5 Size 6 Size 7 Size 8

Size 9 Size 10 Size 11 Size 12

Size 13 Size 14 Size 15 Size 16

I mentioned this bug and many others back in the original IPB Update thread. Since it is locked I cannot properly quote it, but I'll try to re-create it ...

I'll focus on this later when Xper is done tweaking. But for now there is still a problem with font sizes, and it appears as a rendering difference between the old boardware and the upgrade. The old method, e.g., SIZE=5 is now rendered at just a bit larger than SIZE=3 used to be. SIZE=7 is just a tad larger than what SIZE=5 used to be. In summary, SIZE=5 is too small, etc.

Secondarily, the editor now uses PT size in the dialog and then inserts a translated BBcode into the post. I'm not sure why they are using PT size in the dialog, but it is a disconnect from the old way so three mental calculations now must be done. First decide on the PT size, then use a table to decide what it will be inserted as in BB, and finally what it will look like in today's style.

Here is the Editor to BBcode Translation ...

Font Dialog - BBcode... 08 pt ... size=1... 10 pt ... size=2... 12 pt ... size=3... 14 pt ... size=4... 18 pt ... size=5... 24 pt ... size=6... 36 pt ... size=7... 48 pt ... size=8

Now this is hard to determine. Using a non-Scientific first glance it looks like an old SIZE=5 ( pre-upgrade ) would require a SIZE=6.5 today to appear the same. I already tried and that fractional will not work. This will need more research I'm afraid.

0

Share this post


Link to post
Share on other sites

Sorry to post a question in a bug submission thread but any idea when emails will be fixed xper?

0

Share this post


Link to post
Share on other sites
As well the "View new Content" automagically going to "new members" is only a nuisance.

jaclaz

View New Content operates within the section you are currently located in. If you do this from your profile (being in the user section) you see new users. If you use it on the forum index (the topic section) you see new topic/replies. I'm not certain that it is a bug. In fact, all the IP.Boards I visit do this same thing, for example Reboot.pro and Tformers.com. ;)

0

Share this post


Link to post
Share on other sites

View New Content operates within the section you are currently located in. If you do this from your profile (being in the user section) you see new users. If you use it on the forum index (the topic section) you see new topic/replies. I'm not certain that it is a bug. In fact, all the IP.Boards I visit do this same thing, for example Reboot.pro and Tformers.com. ;)

Look, I don't want to be grumpier then usual, but if I am in my User (or member) view, or Control Panel, then I may be interested to new members :unsure:, but if I am in my §@ç#ing "My conversation" and click on "View New Content" it means that I went there to either write a new PM or read a received one, and once finished I want to see View what happened on the Board in the meantime, like if somethng New was posted to it (please read as added Content) hence I click on the "View New Content".

When you are in "My Conversations", you are in:

MSFN Forum ->Messenger->My Converstions

Now, if clicking on it would lead to New Content of the Inbox My Conversations, it would make (some) sense, but "members" and "PM's" have nothing in common.

In my day if I wanted to know what new members had joined, I would press a button labeled "View New Members" :whistle:.

This is like Rule #1 of ergonomics, NEVER have the same command do different things!

Please consider how this is also politically incorrect as it likens a human being (the new member) to Contents of the board. :ph34r:

I can say nothing about Tformers.com, but about reboot.pro it is OBVIOUSLY the SAME, WRONG, SENSELESS behaviour as that board uses the same software as this one with the further handicap of being managed by (IMHO) less expert Board Admins than Xper is.

At least, with the exception of a new little nuisances and a few bugs, each move on msfn.org to new software releases has - in some time - gone well, notwithstanding the stupidity of the Board Software programmers.

The same changes on Reboot.pro have EVERY TIME caused serious problems, some of which were NEVER fixed/repaired.

Maybe it is not a bug, it is just a senseless setting propagated by the IPB guys, i.e. it is "by (flawed) design"

BTW, if I am in:

MSFN Forum ->jaclaz's content

or:

MSFN Forum->My control panel->Settings->Profile Settings

The "View New Content" lists Board threads "normally".

jaclaz

0

Share this post


Link to post
Share on other sites

xper, please, do give this issue a look... I'm positive it didn't exist in the previous versions of IP.Board

We have a member who decided to use an username written in Katakana: viz. ハイドン (strangely enough it means "Hydn", a European name).
There's no way to cause the forum to show his profile now (the error is different in FF and in Opera, but certainly is due to the strange characters used.).
Before the upgrade it used to work. Also some of the other members with odd names one can see in the 1st page one gets after clicking in the "Members" tab on the top row of the forum UI also do show the same issue... in fact, all usernames containing the hash (or sharp) character, as well as those containing "bigger than" and "less than", fail to be displayed. So, in other words, up to now I know that, besides Katakana characters, the presence of the following characters in the username do cause the issue I'm reporting here:

 # > < 
0

Share this post


Link to post
Share on other sites

xper, please, do give this issue a look... I'm positive it didn't exist in the previous versions of IP.Board

I presume it is to be intended as a "high priority" fix :unsure:, l can imagine the tens, hundreds, thousands of people that vainly attempt to view the profiles of members that use a Katakana nick :yes:.

I do feel for their huge delusion :(, and can understand how this needs to be fixed ASAP :unsure:, before the few trifling issues like links not working, CODE parser that parses "whatever it sees fit when it sees it fit" (and behaves differently if you are in "quick reply" or in "More reply options"), with line feeds inserted (or removed) on a totally random basis, external urls often parsed incorrectly, PM notifications "casual", etc.

jaclaz

0

Share this post


Link to post
Share on other sites

I presume it is to be intended as a "high priority" fix :unsure:, l can imagine the [...] thousands of people that vainly attempt to view the profiles of members that use a Katakana nick :yes:.

I do feel for their huge delusion :(, and can understand how this needs to be fixed ASAP :unsure:, before the few trifling issues like <snikt>

No. Not high-priority. But simplicity. The point is Extended Unicode characters and special characters "<" ">" "#" are not being parsed correctly because a pair of quote marks (or maybe double-quote marks) is missing in presumably *one* script. So it should be terribly easy to fix. OTOH, the really high-priority fixes you're requesting appear to me to be much more complex to fix.

Then again, you shouldn't be so sure you'll never change yout nick to ヤクラツ :P

デ ン コ ル ソ

0

Share this post


Link to post
Share on other sites

So let's fix first something that causes no problems in not for anyone that needs/wants to see the profile of a single user out of what? 100,000 members profiles, just because it is "easy"?
Interesting approach. :yes:

If technology evolved like that we would be using a very nicely decorated set of

http://en.wikipedia.org/wiki/Tin_can_telephone

Tr%C3%A5dtelefon-illustration.png

which are much easier to make when compared to the communications devices we use today.

jaclaz

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.