• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
Sign in to follow this  
Followers 0
Guest

Editing Controls do not appear CKEditor

8 posts in this topic

I noticed when you go to post a new topic there is no editing controls. Same thing at Neowin. Pretty silly.

Is there a hack we can add to give us the RTE or any kind of editor?

0

Share this post


Link to post
Share on other sites

I noticed when you go to post a new topic there is no editing controls.

What exactly do you mean by this? If we are using the same words, I see editing controls when I create a new topic.

0

Share this post


Link to post
Share on other sites

As I previously mentioned, in Firefox 2 the toolbars don't work anymore. The old board worked much better in FF2 in all respects.

Like -X-, I don't see edit controls/tool buttons either--just a bare editbox. No Expand/Collapse Toolbar buttons or Resize thumb; no JS or CSS errors, either. :(

In Opera 10.63 and K-Meleon 1.6b2, however, the two rows of toolbars do appear as expected if javascript is enabled.

Same in QtWeb 3.7.5 after dismissing five scripting error warnings.

Win98se with KernelEx 4.5.2 and Kexstubs. Ad/element blocking disabled.

0

Share this post


Link to post
Share on other sites

I noticed when you go to post a new topic there is no editing controls.

What exactly do you mean by this? If we are using the same words, I see editing controls when I create a new topic.

Edit: nm,it's my ad blocker on FF. I'll figure out what script it is later.

Edited by -X-
0

Share this post


Link to post
Share on other sites

Like -X-, I don't see edit controls/tool buttons either--just a bare editbox. No Expand/Collapse Toolbar buttons or Resize thumb; no JS or CSS errors, either. :(

Does it look like this?

msfnquickreply_zps9a93ddd9.jpg

Do you have this problem with both the Quick Reply (the reply at the bottom of a thread page) and also the regular Reply (or the More Reply Options button)?

There is a button that makes the toolbar turn into that. It looks like a gear. The purpose of that button, I do not know. Anyways, if you click it, maybe the labels show up. I found the gear picture:

ips_options.png?t=3dd166d83264b9d7b7755b

Also, speaking of the labels. The GUI uses that method of having all the images in one physical PNG file and using coordinates to determine which to display. I do not know the name of this method as I've never learned it! But whatever this method is, maybe it is not supported by your browser as it is a fairly recent "development" I've seen on Websites. The images for the Reply Editor are used from one of these links:

http://www.msfn.org/board/public/js/3rd_party/ckeditor/skins/ips/icons.png

http://www.msfn.org/board/public/style_images/shift/editor/icons.png

:unsure:

0

Share this post


Link to post
Share on other sites

As I previously mentioned, in Firefox 2 the toolbars don't work anymore. The old board worked much better in FF2 in all respects.

Like -X-, I don't see edit controls/tool buttons either--just a bare editbox. No Expand/Collapse Toolbar buttons or Resize thumb; no JS or CSS errors, either. :(

Hey I just remembered. You couldn't see the PNG files I had put in the alignment thread... I think maybe that's where the problem is!

http://www.msfn.org/board/topic/163491-align-bbcodes-modification-installed/

0

Share this post


Link to post
Share on other sites

> Does it look like this?

No. Just a thin-frame editbox directly under the page-section header. In FF2, Quick Reply looks something like this:



[ Reply to this topic ]

jumper's Photo
......

[ Post ] [ More Reply Options ]


[ t ]
[digg]
[ / ]
[ R ]
[ sv ]
[ M ]
{#}
/ V \
[ 1 user(s) are reading this topic ]




Opera 10.63 is the same, but with social buttons on one line.

In full edit mode it is the same: no toolbars, no gear button. Also, previewing the post causes the source to get mangled and content lost. :crazy:

In Opera 10.63 today, toolbars do not appear in any reply mode. Also, previewing the post in full edit mode causes the editbox to disappear entirely. :angrym:

PNG graphic sheets have been used by Google for years and work fine in FF2 (also in Netscape 4.7!). PNG files are not the problem, missing toolbars are.

Edit: And when editing in-line, clicking "Save Change" does save the changes but doesn't reload the page or appear to respond in any way. Error console reports:


CKEDITOR is not defined
Source File: http://www.msfn.org/board/public/min/index.php?ipbv=84e6bd1b24bca89cbc1c926a47159e30&charset=iso-8859-1&f=public/js/ipb.js,cache/lang_cache/1/ipb.lang.js,public/js/ips.hovercard.js,public/js/ips.quickpm.js,public/js/ips.textEditor.bbcode.js,public/js/ips.sharelinks.js,public/js/ips.textEditor.js,public/js/ips.topic.js,public/js/ips.rating.js,public/js/ips.like.js

Line: 1187

Edit 2: And in-line editing also mangles the post, in this case removing the empty "code" and surrounding "indent" tags. :(

"Preview post" is now worthless, because what it displays is (too) often not what get posted!

Edit 3: K-Meleon 1.6b2 to the rescue (if I can Save Changes successfully)--inline editing appears to be fully functional with two toolbars that pop up other dialogs as needed.

Edit 4: The gear brings up an Options dialog:

Editor Options                                 x------------------------------------------------[ ] Paste as plain text by default[ ] Clear my saved content                                          [ Ok ]
Edited by jumper
0

Share this post


Link to post
Share on other sites

I split these posts out of the suggestion thread.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.