buckeyeXP

Office Shrinker [reduce source of o2k3/xp/2k]

679 posts in this topic

When you have got the setup ending up with a 7.x MB install, you KNOW that it was not successful. What has happened actually, is that just the root of your CD got copied over, and the installer files are still where they were. Here's a few things to check when you have that problem:

1. Have you properly made an admin-install point.

2. Was your source-CD scratched or damaged in any way.

3. What is the language of the MS-Office you are trying to shrink, and is it supported by Office Shrinker.

4. Are you running the shrinker itself properly (un-install Office, and then run the shrinker).

If you want any more trouble-shooting suggestions, please have a good read of this thread - all those problems have been discussed and solved. :)

Hoping this helps....

0

Share this post


Link to post
Share on other sites

@prathapml: Thanks for taking over in my absence. :thumbup

Here's a few things to check when you have that problem:

1. Have you properly made an admin-install point.

2. Was your source-CD scratched or damaged in any way.

3. What is the language of the MS-Office you are trying to shrink, and is it supported by Office Shrinker.

4. Are you running the shrinker itself properly (un-install Office, and then run the shrinker).

i concure with the above statements.

Chances are that the language that you are trying to run is not supported by default.

neither of you were very specific with your post so i have no way of knowing for sure.

0

Share this post


Link to post
Share on other sites
Thanks for taking over in my absence.  :thumbup
you're welcome. ;) I've been closely following the development of the shrinker since the beginning, and it works well for me (LOL, took me some experimenting before I learnt how it works). Anyways, I figured now's a good time as any to help those coming to this topic.

@Moderators

Maybe this thread belongs in Application Switches forum? (despite the fact that it is related to Unattended Windows?) :o

0

Share this post


Link to post
Share on other sites

My probs with shrink are now solved, I'll explain my fixes, which may only work for me. I hope it helps someone.

For months I was a 7MBiter, I tried everything in all 19 pages, including prathapml's summary. I ended up copying the office2003 files to a CD which made my source a single letter, eg F:\ (with \ for sure after F:}. Now it worked. I made an install of word, powerpoint & publisher, it worked a treat on an unattended CD.

I then re-installed Windows & made a new shrink with excel added, bummer, kept doing the "retreat" of office install during unattended, where it starts & suddenly the progress bar goes backwards.

Finally I ran setup.exe manually & chose the same choices as my MST file & copied every missing file during install, not many, from source to my shrink office folder & made a new CD- perfect.

I now have a winrar SFX of the first shrink=85MB

+Excel=105MB

One of the missing files was office.dll. looks important, LOL.

Hope someone sees something in here that helps.

0

Share this post


Link to post
Share on other sites

Okay, I tried it with O2k3 in german, slipstreamed to SP1. (On a newly created VMWare XPpro+SP2 and my not-so-newly-installed original comp with XPpro and SP2)

It didn't work, but I hope my logs will help you to get rid of this problem :)

1) I had to change the INI to the following values to make it start:

(perhaps add these to the default german settings?)

[Language]

lang=German

dir=1031

retry=&Wiederholen

title=Microsoft Office Professional Edition 2003

error=Fehler

2) anyhow, starting up then and looking promising, after some time working it suddenly stopped with the following error: (text translated to english, screenshot shows original message)

Error 2337. An internal error has occured. () Consult the support personnel of your organization.

All three log files, a screenshot of the error message and my ini are attached.

(BTW, in this INI there is a UNC path to the source, I have tried it with local source, too)

P.S.: As I cannot attach "this type of file" (tried .zip and .rar) I put it on my own server. Please see http://ccs-dzn.net/mylogs.rar

0

Share this post


Link to post
Share on other sites

@C.RAZY: I checked out your error message. are you sure you sent me the log files from when the error occured. because that error message dosent not exsist within your log file.

i also did some reshearch on the error message itself. it turns out that it is a result of a Terminal Server Error. The message means that "There are no shared communication devices." so it would see to me that you lost your connection midway through the shrinking process.

my question to you is. you said that you had a problem even with a local source. i was wondering if it was the same error message or if it was different.

as of right now i dont think that it has anything to do with the shrinking process.

maybe someone else could shed some more light on that particular error message.

0

Share this post


Link to post
Share on other sites

Well, here's a suggestion for all those having problems with Office Shrinker:

1. Check that it installs fine BEFORE using the shrinker.

2. Analyse the situation, and see that you have understood how the shrinker works. (only then is trouble-shooting possible)

3. If there are missing files problems, either run the shrinker again on that source to get the missing files, or copy them manually.

This is because we keep coming across posts that describe problems not-at-all related to the shrinker.

0

Share this post


Link to post
Share on other sites

I am just setting up another fresh vmware installation of winxpsp2 and I will test it again there, just to be sure (using local source).

My AIP is installing fine, tested it before, with exactly that intention, to be sure that it will not be my source if anything fails :)

I will report back if I come across anything new...

0

Share this post


Link to post
Share on other sites

I'm trying Office Shrinker with Office XP slipstreamed with SP3.

I'm getting "Windows Installer: Error opening installation log file."

/Fizban_Jr

0

Share this post


Link to post
Share on other sites

The error I experience could be quite close to C.CRAZY's one.

The shrink process starts fully normal and copies the setup stuff. When it should begin to copy the real office it searches in the destination directory for the files to copy. Changing the Source and dest directory doesn't work.

German O2003 with SP1 XPSP2

ED: My Admin point installs perfectly and unattended but not shrinked :}

office2_Task_0001_.txt

0

Share this post


Link to post
Share on other sites

I get this error:

Error 25003. Microsoft Office Setup cannot continue because the installation source has been corrupted.

I`ve made an admin point for the office install and has been slipstreamed with office sp1. It installs fine with the Unattended.MST.

The problem occurs after installing a fresh copy of XP SP2 on vmware.

BTW im using English version of Office Small Buisness Edition 2003

UPDATE. Got it working. I had to copy the SKU0CA.XML to here.

C:\office\FILES\PFILES\MSOFFICE\OFFICE11\1033\0CA

After that it worked ok.

:)

Logs.rar

0

Share this post


Link to post
Share on other sites

anyone know how to combine office2003 and frontpage together from an all in 1 cd?

0

Share this post


Link to post
Share on other sites

Please search in the forums - its already been discussed before. Also, this question is slightly off-topic for this thread. So you might like to start a new thread regarding it. Anyway, since it is just the reverse of combining, you should see the threads that discuss how to combine all 5 CDs.

0

Share this post


Link to post
Share on other sites

sorry if this has been posted before, but when i try it, it says shrink is already complete when i never ran this before. (Fresh install of xp, no office2003 installed yet)

0

Share this post


Link to post
Share on other sites

This looks like something which has been fixed for many people while trouble-shooting. Some small things which need to be noted.... Please try reading all the pages of this thread. Hoping you'd find what caused that error.

Do post back on how it goes. :)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.