Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



buckeyeXP

Office Shrinker [reduce source of o2k3/xp/2k]

Recommended Posts


qwerty009    0

(Sorry about my bad english but here goes..)

I slipstreamed, made admin install point and shrinked my office 2003 but thing is that it doesnt work 100%. When i try to install it with WPI the installer starts, but after some time the progress bar goes back and install is aborted. BUT when i restart my computer it installs fine. So basically one restart is needed from first logon. Anyone knows what the problem may be?

-edit-

I made my shrinked office in Virtual machine on my winXP Pro SP2 (modded with nlite).

Just tried to install it to win witch isnt modded with nlite and it still doesnt install. In fact it doest even install after restart :huh:

-edit2-

Ok, i removed "qb-" and thing was, that installer did not wind some of the files. I'm tring to built shrinked office again in clean instelled windows...

-edit3-

Shrinked it again but still it didnt find some of the files when i tried to install it on newly installed windows. But i managed to fix the problem by manually copy'ing the missing files to installation directory later.

Edited by qwerty009

Share this post


Link to post
Share on other sites
ForPete    0

Hi all,

i tried the shrinkage tool several times now, but i can´t get a good shrinked source of Office 2003.

I used it on clean nLited WinXP Pro SP2 machines.

When i try to install Office 2003 from the shrinked source the installer starts, but after some time the progress bar goes back and the install is aborted.

It seems other people have the same problem too.

Maybe someone can check the attached logfiles in the archive below and/or give the solution to this problem?

ForPete.7z

Thanks in advance!

Edited by ForPete

Share this post


Link to post
Share on other sites
renzo    0

I don't understand the proces.

I've followed the guide but then?!

I have done the office config wizard and i have a mst file.

1: If I start office shrink on a clean machine I get error's because of files don't exist in the target folder (only option is retry/cancel) and office shrink is paused.

2: When I install office first and than do office shrink it tells me office is allready shrinked (and copy's the serupfiles to the target folder).

I don't know what to do. Did I do something wrong? I can't imagen that 2 is right. If I copy the files as a new setup source it will miss file which are stored in the common file map.

Anybody can help me?

Share this post


Link to post
Share on other sites
maybeme    0

Hi

Why do you have to use a clean install to run the script? In the guide, they don't say a word about a clean OS. I know you can make an administrative install (or something) without a clean OS.

grtz

Share this post


Link to post
Share on other sites
ForPete    0
Hi all,

i tried the shrinkage tool several times now, but i can´t get a good shrinked source of Office 2003.

I used it on clean nLited WinXP Pro SP2 machines.

When i try to install Office 2003 from the shrinked source the installer starts, but after some time the progress bar goes back and the install is aborted.

It seems other people have the same problem too.

Maybe someone can check the attached logfiles in the archive below and/or give the solution to this problem?

ForPete.7z

Thanks in advance!

I finally managed to make a working shrinked source with the shrinkage tool.

I first had to install the dotnet framework before using the tool.

Share this post


Link to post
Share on other sites
Drawde    0

I had the same problem with the install rolling back and not installing. Here's how I fixed it:

I ran the setup with the "TRANSFORMS=Unattended.mst" tag but I left off the "/qb-"

This will allow you to see what is goin on. Click next on everything using whatever the default settings are (This is basically all that the "/qb-" command does since the user can't see the dialogs).

Sometime during the installation you will get an error. Most likely it's a missing file, take note of the file the setup can't find and click "Ignore." Keep doing this until setup is finished and you have your list of files (only two for me).

Then just copy those files into the right places in your setup files and now you should be able to run the silent install with no problems!

Share this post


Link to post
Share on other sites
ZileXa    2

OK this is like magic or something:

my slipstreamed, shrinked and 7z compressed silent Office2003 (dutch) install works fine... until I use it with my UWXPCD and run it from RUNONCEEX.CMD

It does extract, even see a quick black window (the cmd command)... thats it... RunOnceEx jumps to the next item in the list.

.Net Framework is installed first (first item in the list!).

anyone any idea how this could happen?

Share this post


Link to post
Share on other sites
newnick    0

If you are using a vmware setup to create the shrunk files, COPY THE FILES TO THE VMWARE HARD DRIVE. DO NOT DO THE SHRINKING WITH THE FILES IN SHARED FOLDERS.

I was getting errors like corrupt setup.ini, and corrupt installation source error 25003) because I was sharing the folders from the host pc. When I copied the source to the hard drive of the VMWARE install, it worked!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×