Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Office Shrinker [reduce source of o2k3/xp/2k]

* * * * * 2 votes

  • Please log in to reply
678 replies to this topic

#451
Astalavista

Astalavista

    MSFN loyalist

  • Member
  • PipPipPipPipPipPipPipPipPip
  • 3,338 posts
Hello

I updated the guide already... sorry slight flaw in the coding.

Edited by Astalavista, 23 June 2005 - 07:21 PM.



How to remove advertisement from MSFN

#452
kal2005

kal2005
  • Member
  • 8 posts
Dear sir
How can I get the guide???

#453
Astalavista

Astalavista

    MSFN loyalist

  • Member
  • PipPipPipPipPipPipPipPipPip
  • 3,338 posts
Dear Sir

pls use the search engine

here are the guides

http://www.msfn.org/...topic=48780&hl=
http://www.msfn.org/...topic=49034&hl=
http://www.msfn.org/...topic=48861&hl=
http://www.msfn.org/...topic=48407&hl=

#454
maniaq

maniaq

    Advanced Member

  • Member
  • PipPipPip
  • 378 posts
  • OS:none specified
  • Country: Country Flag
finally i have sliptreamed my office 2003.

Edited by maniaq, 30 June 2005 - 04:03 AM.


#455
qwerty009

qwerty009

    Newbie

  • Member
  • 12 posts
(Sorry about my bad english but here goes..)
I slipstreamed, made admin install point and shrinked my office 2003 but thing is that it doesnt work 100%. When i try to install it with WPI the installer starts, but after some time the progress bar goes back and install is aborted. BUT when i restart my computer it installs fine. So basically one restart is needed from first logon. Anyone knows what the problem may be?
-edit-
I made my shrinked office in Virtual machine on my winXP Pro SP2 (modded with nlite).
Just tried to install it to win witch isnt modded with nlite and it still doesnt install. In fact it doest even install after restart :huh:
-edit2-
Ok, i removed "qb-" and thing was, that installer did not wind some of the files. I'm tring to built shrinked office again in clean instelled windows...
-edit3-
Shrinked it again but still it didnt find some of the files when i tried to install it on newly installed windows. But i managed to fix the problem by manually copy'ing the missing files to installation directory later.

Edited by qwerty009, 27 June 2005 - 12:39 AM.


#456
maniaq

maniaq

    Advanced Member

  • Member
  • PipPipPip
  • 378 posts
  • OS:none specified
  • Country: Country Flag
thanks for great script and thanks who help of slipstreaming office

Edited by maniaq, 30 June 2005 - 04:04 AM.


#457
ForPete

ForPete
  • Member
  • 3 posts
Hi all,

i tried the shrinkage tool several times now, but i can´t get a good shrinked source of Office 2003.
I used it on clean nLited WinXP Pro SP2 machines.

When i try to install Office 2003 from the shrinked source the installer starts, but after some time the progress bar goes back and the install is aborted.

It seems other people have the same problem too.

Maybe someone can check the attached logfiles in the archive below and/or give the solution to this problem?
Attached File  ForPete.7z   28.06KB   114 downloads

Thanks in advance!

Edited by ForPete, 30 June 2005 - 03:57 AM.


#458
renzo

renzo
  • Member
  • 1 posts
I don't understand the proces.
I've followed the guide but then?!

I have done the office config wizard and i have a mst file.

1: If I start office shrink on a clean machine I get error's because of files don't exist in the target folder (only option is retry/cancel) and office shrink is paused.

2: When I install office first and than do office shrink it tells me office is allready shrinked (and copy's the serupfiles to the target folder).

I don't know what to do. Did I do something wrong? I can't imagen that 2 is right. If I copy the files as a new setup source it will miss file which are stored in the common file map.

Anybody can help me?

#459
maybeme

maybeme

    Newbie

  • Member
  • 27 posts
Hi
Why do you have to use a clean install to run the script? In the guide, they don't say a word about a clean OS. I know you can make an administrative install (or something) without a clean OS.

grtz

#460
zey57

zey57
  • Member
  • 2 posts
Can you make it work for the swedish version?

#461
zey57

zey57
  • Member
  • 2 posts
already fixed it

#462
ForPete

ForPete
  • Member
  • 3 posts

Hi all,

i tried the shrinkage tool several times now, but i can´t get a good shrinked source of Office 2003.
I used it on clean nLited WinXP Pro SP2 machines.

When i try to install Office 2003 from the shrinked source the installer starts, but after some time the progress bar goes back and the install is aborted.

It seems other people have the same problem too.

Maybe someone can check the attached logfiles in the archive below and/or give the solution to this problem?
Attached File  ForPete.7z   28.06KB   114 downloads

Thanks in advance!

<{POST_SNAPBACK}>


I finally managed to make a working shrinked source with the shrinkage tool.
I first had to install the dotnet framework before using the tool.

#463
Drawde

Drawde
  • Member
  • 1 posts
I had the same problem with the install rolling back and not installing. Here's how I fixed it:

I ran the setup with the "TRANSFORMS=Unattended.mst" tag but I left off the "/qb-"
This will allow you to see what is goin on. Click next on everything using whatever the default settings are (This is basically all that the "/qb-" command does since the user can't see the dialogs).

Sometime during the installation you will get an error. Most likely it's a missing file, take note of the file the setup can't find and click "Ignore." Keep doing this until setup is finished and you have your list of files (only two for me).

Then just copy those files into the right places in your setup files and now you should be able to run the silent install with no problems!

#464
ZileXa

ZileXa

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 767 posts
OK this is like magic or something:

my slipstreamed, shrinked and 7z compressed silent Office2003 (dutch) install works fine... until I use it with my UWXPCD and run it from RUNONCEEX.CMD

It does extract, even see a quick black window (the cmd command)... thats it... RunOnceEx jumps to the next item in the list.

.Net Framework is installed first (first item in the list!).

anyone any idea how this could happen?

#465
newnick

newnick
  • Member
  • 4 posts
If you are using a vmware setup to create the shrunk files, COPY THE FILES TO THE VMWARE HARD DRIVE. DO NOT DO THE SHRINKING WITH THE FILES IN SHARED FOLDERS.

I was getting errors like corrupt setup.ini, and corrupt installation source error 25003) because I was sharing the folders from the host pc. When I copied the source to the hard drive of the VMWARE install, it worked!

#466
ZileXa

ZileXa

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 767 posts
@drawde, did you had the rollback problem ONLY when installing with RunOnceEx?
Because now I have a new problem: it rolls back, only when I install with RunOnceEx, if I test it myself it installs perfectly!

OK this is like magic or something:

my slipstreamed, shrinked and 7z compressed silent Office2003 (dutch) install works fine... until I use it with my UWXPCD and run it from RUNONCEEX.CMD

It does extract, even see a quick black window (the cmd command)... thats it... RunOnceEx jumps to the next item in the list.

.Net Framework is installed first (first item in the list!).

anyone any idea how this could happen?

<{POST_SNAPBACK}>



OK I found out why above was happening to me, I execute RunOnceEx a bit sooner then most people, just to speed things up, I use this line in my cmdlines.txt, so that RunOnceEx will be executed:
"rundll32.exe iernonce.dll,RunOnceExProcess"

Office wont install (will not even start to install, see quote above) it will only extract.

So I now tried to install it by RunOnceEx normally... now I got the rollback problem!
Very strange, it works perfectly if I do it manually...

Edited by ZileXa, 11 July 2005 - 01:53 PM.


#467
Bluff

Bluff
  • Member
  • 3 posts
in the pdf guide, it refers to installer.exe and finish.exe...where do i get these files?

#468
Jibreil

Jibreil
  • Member
  • 1 posts
I followed the method which involved installing without the /qb- swtich and noted the following missing files:
FILES\WINDOWS\IME\SOFTKBD.DLL
FILES\WINDOWS\IME\MSCANDUI.DLL
FILES\WINDOWS\IME\SPTIP.DLL

Where can I find these files? Please help!

#469
Svens

Svens
  • Member
  • 3 posts

OK this is like magic or something:

my slipstreamed, shrinked and 7z compressed silent Office2003 (dutch) install works fine... until I use it with my UWXPCD and run it from RUNONCEEX.CMD

It does extract, even see a quick black window (the cmd command)... thats it... RunOnceEx jumps to the next item in the list.

.Net Framework is installed first (first item in the list!).

anyone any idea how this could happen?

<{POST_SNAPBACK}>


Sounds exactly the same as the problem I described here:
http://www.msfn.org/...ndpost&p=356399

Haven't found a solution yet. Any suggestions?

#470
maybeme

maybeme

    Newbie

  • Member
  • 27 posts
I have a problem: I made an administrative install of office 2003, slipstreamed sp1, made an mst (install everything except outlook, infopath, and publisher, i also inserted my serial) and copied everything via a virtual network to a clean (even without sp2 or something) virtual xp professional os made with vmware. I tried it 2 times (I did everything 2 times, incl copy cd) I always get the erro shown on the screenshot. In English:
Error 1308
Setup can't find the needed file
[you can see wich file]
See
[path of setup.chm]
for other possible solutions for this problem

If anyone needs another file, please ask

anyone an idea?

thanks in advance

EDIT: I also tried to change retry=&Nogmaals to retry=&Opnieuw, but it didn't help. I'm now going to try without sp1

EDIT2: I just saw I used an image of windows xp pro with sp2 slipstreamed, i'm now installing the normal xp pro (dutch)... I'll try these configs:
* sp1 ==> can't find file
* sp1 + changing nogmaals to opnieuw ==> can't find file
* without sp1 ==> Shrinkage complete (6MB hmmm) + can't find file
* without sp1 + changing nogmaals to opnieuw ==> can't find file

EDIT3: I'm now gonna try with dot net installed

EDIT4: with dot net installer same problem, but now i see that, when i click manually on "nogmaals" or when i use sp1 "opnieuw", I always get 1 file copied. So when I run the script a 1000 times, I maybe get everything working... But maybe that should be a waste of time...

Attached Files


Edited by maybeme, 23 July 2005 - 10:29 AM.


#471
ZileXa

ZileXa

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 767 posts
After shrinking, how to create a silent installer uA_Office2003nl.exe?
____________________________________________________________________________________
  • download and install 7-zip
  • - select all files and directories of the folder c:\officeshrinker (the folder containing all files+folders of your shrinked office!).
    - right-click and select "add to archive".
    - in the option window,choose "Ultra" compression (you need at least 512MB ram, otherwise select "Maximum").
    - after a few minutes,you get your officeshrinker.7z

  • put in another directory
    --> officeshrinker.7z
    +
    --> 7zS.sfx (download "Extra Modules" here: http://www.7-zip.org/download.html)
    +
    --> a config.txt with that in this config.txt:
    ;!@Install@!UTF-8!
    RunProgram="setup.exe transforms=unAttended.mst /qb" 
    ;!@InstallEnd@!
  • => Now run this command (Start > Run.. type CMD and press ENTER)
    copy /b 7zS.sfx + config.txt + office2003.7z uA_office2003.exe
uA_Office2003nl.exe is your final file!
if you want to test,just execute (double click) on this officeshrinker.exe,everything should be :thumbup

i hope i have helped you. It is updated from

<{POST_SNAPBACK}>



_____________________________________________________________________________________




2 PROBLEMS THAT MIGHT OCCUR:
  • If during Office Setup, you get errors that files are missing:
    write down the path+name of all the missing files (press ignore!).
    Get your original OfficeCD, and run Setup /a (admin install). All files will be extracted to a folder (lets call this folder OFFICE).
    Go to this folder and use the path+filenames you have written down to copy these files.
    Extract uA_Office2003.exe, paste the files with correct paths in the office 'Files' folder.
    Go to step 2 to create uA_Office2003.exe again!
  • ------------------------------------------------------------------------------------------------------------------------
    if you have the rollback problem, remove /qb-, click through the setup. You will see some files are missing, google and download (or from original source) them put them in the right folders and test again.
    ------------------------------------------------------------------------------------------------------------------------

    If you want to install at T12 like me, it won't work, so check this:
    [solution] Installing Office 2k3 On T-12
    --> you won't need setup.cmd, won't need startX.exe, just create the config.txt like this:
    config.txt
    ;!@Install@!UTF-8!
    RunProgram="officeexecNLpro.exe"
    ;!@InstallEnd@!
just wanted to have all the important info in one place :)

Edited by ZileXa, 23 April 2006 - 10:39 AM.


#472
PoloDude

PoloDude

    Junior

  • Member
  • Pip
  • 57 posts

I have a problem: I made an administrative install of office 2003, slipstreamed sp1, made an mst (install everything except outlook, infopath, and publisher, i also inserted my serial) and copied everything via a virtual network to a clean (even without sp2 or something) virtual xp professional os made with vmware. I tried it 2 times (I did everything 2 times, incl copy cd) I always get the erro shown on the screenshot. In English:
Error 1308
Setup can't find the needed file
[you can see wich file]
See
[path of setup.chm]
for other possible solutions for this problem
...


Edit:
I (have) had the same problem, seems a problem in the shrink.ini file, you need to change something => retry=&Opnieuw (for dutch versions anyway :) )
Everything works just fine then :thumbup

btw, solution was in one of the previous posts :whistle:

Edited by PoloDude, 30 July 2005 - 06:37 PM.

poloplayers do it always 4 times, 7 minutes ^^

#473
Wesmosis

Wesmosis

    Just Call Me Doctor Just Call Me Pain!

  • Member
  • PipPipPipPipPip
  • 787 posts
Astalavista Quote:

Notes: If your planning to install NetFrameWork 1.1 on your system. Pls make sure that you install NetFrameWork prior to doing your office shrink by BuckEye.
Reasons: The way office shrink works is to save only the files you need to install your particular Office package. It is very very picky about how it is installed and such. So pls take note.
Here is an example of a problem that was encountered in my last guide. People did a clean install of xp either real or virtual. Ran the office Shrink program by buckeye. Created their custom installer. But when they tried to install NetFrameWork 1.1 before their Office Shrunk Installer it would fail. Solution was to install the Office Shrunk Installer prior to Installing Netframework 1.1.
In conclusion, if your planning to use Netframework pls install it first before running office Shrink by Buckeye. Then when you use RunonceEX or WPI you can keep the order of NetFramework 1.1 then Office 2003

this is strange, although I made the .Net FW is the first thing to be installed in ExRunOnce.cmd and then the Shrunk Office 2003 SP1 , still got the funny horrible problem ..........Reverse of the Progress bar and everything disappear from the Program files
any idea what's happening?


[Edit]
I found this on this topic

If you are using a vmware setup to create the shrunk files, COPY THE FILES TO THE VMWARE HARD DRIVE. DO NOT DO THE SHRINKING WITH THE FILES IN SHARED FOLDERS.

I was getting errors like corrupt setup.ini, and corrupt installation source error 25003) because I was sharing the folders from the host pc. When I copied the source to the hard drive of the VMWARE install, it worked!

Any body has experienced the same prob? is that possible?
Coz I think I made my Shrinking via Shared folder of Vmware to save time!? Ahhhh

[Edit] 2
I copied an older version of Shrun Office.exe which I'm a 100% it's working
and when I tried it on VMware , it did the same problem!
so I'll post what new have I add after this WORKING Office.exe:

1- I made an Account named XP (I was using only the Adminstrator Account when Office was Ok)
2- Here is my ExRunOnce.cmd (maybe you will find something incompatible or I donno something wrong)

cmdow @ /HID
@echo off

IF EXIST D:\CD.txt set CDROM=D:
IF EXIST E:\CD.txt set CDROM=E:
IF EXIST F:\CD.txt set CDROM=F:
IF EXIST G:\CD.txt set CDROM=G:
IF EXIST H:\CD.txt set CDROM=H:
IF EXIST I:\CD.txt set CDROM=I:
IF EXIST J:\CD.txt set CDROM=J:

SET KEY=HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx

REG ADD %KEY% /V TITLE /D "Installing Applications" /f

REG ADD %KEY%\001 /VE /D "Microsoft Office 2003 SP1" /f
REG ADD %KEY%\001 /V 1 /D "%CDROM%\Softwares\office2003\office2003.exe" /f

REG ADD %KEY%\050 /VE /D ".NET Framework 1.1 SP1" /f
REG ADD %KEY%\050 /V 1 /D "%CDROM%\Softwares\NetFramework\netfxsp1.exe" /f

REG ADD %KEY%\002 /VE /D "ACDess PowerPack v7.0 " /f
REG ADD %KEY%\002 /V 1 /D "%CDROM%\Softwares\ACDsee\Acdsee.cmd" /f

REG ADD %KEY%\004 /VE /D "Adobe Reader v7.0.2" /f
REG ADD %KEY%\004 /V 1 /D "%CDROM%\Softwares\adobe\Adobe.Reader.7.01.Lite.exe" /f

REG ADD %KEY%\005 /VE /D "AVG Antivirus v7.0.323 Free" /f
REG ADD %KEY%\005 /V 1 /D "%CDROM%\softwares\AVG7\AVG.exe /HIDE /DONT_START_APPS /NO_WELCOME /NO_AVGW_STARTUP /QUIT_IF_INSTALLED" /f

REG ADD %KEY%\008 /VE /D "Calculator Powertoy" /f
REG ADD %KEY%\008 /v 1 /D "%CDROM%\Softwares\PowerCalc\PowerCalc.exe /s /v/qb" /f

REG ADD %KEY%\009 /VE /D "CCleaner v1.21" /f
REG ADD %KEY%\009 /v 1 /D "%CDROM%\Softwares\CCleaner\CCleanerv1.21.exe /S /NCRC" /f 

REG ADD %KEY%\012 /VE /D "Flash v7 And Shockwave v10.1" /f
REG ADD %KEY%\012 /v 1 /D "%CDROM%\Softwares\Flashplayer\mm_fl_sw_installer.msi /qb" /f 

REG ADD %KEY%\013 /VE /D "FlashGet v1.65" /f
REG ADD %KEY%\013 /v 1 /D "%CDROM%\Softwares\Flashget\FlashGet1.65.exe /S" /f 

REG ADD %KEY%\016 /VE /D "K-Lite Mega Codec Pack v1.34" /f
REG ADD %KEY%\016 /v 1 /D "%CDROM%\Softwares\klcodec\klmcodec134.exe /verysilent /LoadInf=".\klmcp.ini"" /f

REG ADD %KEY%\018 /VE /D "Maxthon v1.3.3" /f
REG ADD %KEY%\018 /V 1 /D "%CDROM%\Softwares\Maxthon\mcombo.exe /S /NCRC" /f

REG ADD %KEY%\020 /VE /D "MSN 7.5.244" /f
REG ADD %KEY%\020 /v 1 /D "%CDROM%\Softwares\MSN\MsnMsgs.msi /qb" /f

REG ADD %KEY%\022 /VE /D "Messenger Plus! v3.52." /f

REG ADD %KEY%\026 /VE /D "Sun Java RE v5.0.4" /f
REG ADD %KEY%\026 /V 1 /D "%CDROM%\Softwares\JavaVM\jre504.exe" /f

REG ADD %KEY%\028 /VE /D "Taskswitch Pro v2.0.7" /f
REG ADD %KEY%\028 /v 1 /D "%CDROM%\Softwares\Taskswitch\TaskSwitchXP_2.0.7.exe /S" /f 

REG ADD %KEY%\030 /VE /D "TweakUI Powertoy" /f
REG ADD %KEY%\030 /v 1 /D "%CDROM%\Softwares\TweakUI\TweakUI.msi /qb" /f

REG ADD %KEY%\034 /VE /D "Winamp 5 Pro v5.093" /f
REG ADD %KEY%\034 /V 1 /D "%CDROM%\Softwares\Winamp\Winamp5093.msi INI=%CDROM%\Softwares\winamp\winamp.ini /qb" /f

REG ADD %KEY%\036 /VE /D "Windows Media Player v10" /f
REG ADD %KEY%\036 /V 1 /D "%CDROM%\Softwares\WMP10\MP10Setup.exe /q:A /c:\"setup_wm.exe /Q /R:N /DisallowSystemRestore\"" /f

REG ADD %KEY%\038 /VE /D "Windows Script v5.6" /f
REG ADD %KEY%\038 /V 1 /D "%CDROM%\Softwares\Script\scripten.exe /Q:A /R:N" /f

REG ADD %KEY%\040 /VE /D "WinRAR v3.5 Corp" /f
REG ADD %KEY%\040 /V 1 /D "%CDROM%\Softwares\WinRAR\wrar35b6corp.exe /s" /f

REG ADD %KEY%\042 /VE /D "Yahoo! Messenger v7.0.247" /f
REG ADD %KEY%\042 /V 1 /D "%CDROM%\Softwares\Yahoo\ymsgr7us.exe /S" /f 
REG ADD %KEY%\042 /V 2 /D "taskkill.exe /F /IM YPager.exe" /f

REG ADD %KEY%\085 /VE /D "Reboot..." /f
REG ADD %KEY%\085 /V 1 /D "%CDROM%\Softwares\reboot.cmd" /f

REG ADD %KEY%\046 /V 1 /D "REGEDIT /S %CDROM%\Softwares\regtweaks.reg" /f

EXIT              

Edited by Wesmosis, 05 August 2005 - 05:40 PM.

@I dont know how the third World War will be fought, but I`m sure the fourth will be fought with sticks and stones
@Like What You Do, If You Can't Do What You Like
@Reality.Sys Corrupted. Universe Halted. Reboot Y/N

#474
Kalps

Kalps
  • Member
  • 8 posts
Hey I have Downloaded Lang Shirnk2.exe ,

Wen I double click it , it asks for Source Folder and Target Folder ,

So did it meaned Source Folder > Xp Cd Path

and Target Folder C:\XPCD\$OEM$\$1\install\Applications\OfficeXP

Correct me if I m wrong....:(


#475
maybeme

maybeme

    Newbie

  • Member
  • 27 posts

Edit:
I (have) had the same problem, seems a problem in the shrink.ini file, you need to change something => retry=&Opnieuw (for dutch versions anyway  :) )
Everything works just fine then  :thumbup

btw, solution was in one of the previous posts  :whistle:

<{POST_SNAPBACK}>


I know, but it didn't help. I'll try again in a couple of days....

@Kalps:
source=path of your administrative install
target=path where you wan't your shrinked files

grtz




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN