Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


SKARDAVNELNATE

Looking for Intel D875PBZ drivers

4 posts in this topic

Hello, according to http://www.intel.com/support/motherboards/desktop/sb/CS-008326.htm

The D875PBZ board is suppose to fully support Windows 98. However the wrong chipset driver is provided.

INF_AllOS_8.3.1.1009_PV_Intel.exe claims to be for Windows 98 SE and Intel® Desktop Board D875PBZ.

But attempting to run the file in Windows 98 SE results in this.
The INF_AllOS_8.3.1.1009_PV_Intel.exe file is linked to missing export SHELL32.DLL:SHCreateDirectoryExA.

Some searching revealed that there was an -A flag to extract the files it would install. Including a readme.txt which says:

2. One of the following operating systems must be
fully installed and running on the system
before installing this software:

Microsoft Windows* Server 2003
Microsoft Windows Server 2003 x64 Edition*
Microsoft Windows XP Professional x64 Edition*
Microsoft Windows XP
Microsoft Windows 2000
Microsoft windows Vista

Also "* Target Chipset#: X38 & 3200/3210 Chipset" but according to a manual PDF the Intel D875PBZ uses 875P Chipset.

In device manager there are 2 items that have question marks.

PCI System Management Bus
Unknown Device

0

Share this post


Link to post
Share on other sites

I tried that one as well. it did remove the question marks on the two devices, however it also went through 2 dozen or so other New Hardware Found boxes and froze on the Windows is shutting down screen. Is there a way to install the drivers seperately for just the two devices?

0

Share this post


Link to post
Share on other sites

I tried that one as well. it did remove the question marks on the two devices, however it also went through 2 dozen or so other New Hardware Found boxes and froze on the Windows is shutting down screen. Is there a way to install the drivers seperately for just the two devices?

I'm sure there is, but that's not the right way to do it, and I have never tried to do so. Besides, once those devices are identified, it triggers the detection of others. That's what is supposed to happen.

I suggest you start from the beginning. Install Windows 98SE, then install the Intel INF package I linked before doing anything else. If 98SE hangs on shutdown, give it a minute or so and press RESET and allow everything to continue.

Sometimes you will see shutdown problems under 9x on newer systems. Once the drivers are installed, it should not be a problem, but if it still is I suggest you download and install the 98SE Shutdown HotFix.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.