Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


jks1976

Autounattend.xml keeps asking to choose an operating system

6 posts in this topic

I am attempting to create an image for silent installation of Windows 7 Professional x64. I have created the answer file as instructed from Step-by-Step: Basic Windows Deployment for IT Professionals page. I have placed the Autounattend.xml file in the root directory of the iso installation file. On installation the answer file is being detected but no matter what I try it keeps asking me to choose an operating system. Am I missing something? I am about to tear my hair out. Can anyone please help?

<?xml version="1.0" encoding="utf-8"?><unattend xmlns="urn:schemas-microsoft-com:unattend">    <settings pass="windowsPE">        <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <SetupUILanguage>                <UILanguage>en-US</UILanguage>            </SetupUILanguage>            <InputLocale>en-US</InputLocale>            <SystemLocale>en-AU</SystemLocale>            <UILanguage>en-US</UILanguage>            <UserLocale>en-AU</UserLocale>        </component>        <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <DiskConfiguration>                <Disk wcm:action="add">                    <DiskID>0</DiskID>                    <WillWipeDisk>true</WillWipeDisk>                    <CreatePartitions>                        <CreatePartition wcm:action="add">                            <Order>1</Order>                            <Size>100</Size>                            <Type>Primary</Type>                        </CreatePartition>                        <CreatePartition wcm:action="add">                            <Extend>true</Extend>                            <Order>2</Order>                            <Type>Primary</Type>                        </CreatePartition>                    </CreatePartitions>                    <ModifyPartitions>                        <ModifyPartition wcm:action="add">                            <Active>true</Active>                            <Format>NTFS</Format>                            <Label>System</Label>                            <Order>1</Order>                            <PartitionID>1</PartitionID>                        </ModifyPartition>                        <ModifyPartition wcm:action="add">                            <Format>NTFS</Format>                            <Order>2</Order>                            <PartitionID>2</PartitionID>                            <Letter>C</Letter>                        </ModifyPartition>                    </ModifyPartitions>                </Disk>                <WillShowUI>OnError</WillShowUI>            </DiskConfiguration>            <ImageInstall>                <OSImage>                    <InstallFrom>                        <Path>install.wim</Path>                        <MetaData wcm:action="add">                            <Key>/image/index</Key>                            <Value>1</Value>                        </MetaData>                    </InstallFrom>                    <InstallTo>                        <DiskID>0</DiskID>                        <PartitionID>2</PartitionID>                    </InstallTo>                    <InstallToAvailablePartition>false</InstallToAvailablePartition>                    <WillShowUI>OnError</WillShowUI>                </OSImage>            </ImageInstall>            <UserData>                <AcceptEula>true</AcceptEula>            </UserData>        </component>    </settings>    <settings pass="oobeSystem">        <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <Reseal>                <Mode>Audit</Mode>            </Reseal>        </component>        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <OOBE>                <HideEULAPage>true</HideEULAPage>                <ProtectYourPC>1</ProtectYourPC>            </OOBE>            <TimeZone>AUS Eastern Standard Time</TimeZone>        </component>    </settings>    <cpi:offlineImage cpi:source="wim:c:/windows7professional/sources/install.wim#Windows 7 Professional" xmlns:cpi="urn:schemas-microsoft-com:cpi" /></unattend>

post-383037-0-34731200-1382258132_thumb.

0

Share this post


Link to post
Share on other sites

You don't need "path" either unless it's on a network share. On first glance that's all I could see.

Delete this line: <cpi:offlineImage cpi:source="wim:c:/windows7professional/sources/install.wim#Windows 7 Professional" xmlns:cpi="urn:schemas-microsoft-com:cpi" />

0

Share this post


Link to post
Share on other sites

Thanks guys! I tried both your suggestions but the problem persists.

0

Share this post


Link to post
Share on other sites

Are you using WDS to deploy? or You put them into a CD?

I have everything automatic with WDS setup with following in xml. If you are doing WDS, you need 2 xml files. I have never tried to put the image into the dvd.

<WindowsDeploymentServices><ImageSelection>                    <InstallImage>                        <Filename>Windows 7 SP1 Ultimate Post Update.wim</Filename>                        <ImageName>Windows 7 SP1 ULTIMATE x64 Post Update</ImageName>                        <ImageGroup>Windows 7 SP1 Deployment x64 Post Update</ImageGroup>                    </InstallImage></InstallImage>
Edited by bbmak
0

Share this post


Link to post
Share on other sites

what does your ei.cfg fie in sources say? for Ultimate it would be like this for a Retail

[EditionID]
Ultimate
[Channel]
Retail
[VL]
0

You can delete that file and remake iso if it contains anything but the Professional if that is a Pro dvd copy

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.