• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
AnX

Windows 2000 on Haswell?

103 posts in this topic

Posted (edited)

I got it to install on my Gigabyte Z87X-OC Force mobo with a 4790K in ACPI-MP mode by disabling the serial port in the BIOS but there is another problem: the mobo has a PLX chip that is used for all the red PCI-E slots, the (re)installation of the chipset drivers doesn't fix the error which is found in device manager: the device cannot start because it cannot find resources for it to use, have to disable other device to enable it

this error is shown on the "Intel(R) Xeon E3-....PCI Express x16..." "device"

but it doesn't say what other device - so I search manually the IRQ/MEM/IO addresses of each of the devices in the system category in device manager: found only one device that has overlapping addresses with it is the "PCI Bus", so I try to disable "PCI Bus", try to install the "Intel(R) Xeon E3-....PCI Express x16..." driver on the "PCI bus" device, try to use alternate driver on "Intel(R) Xeon E3-....PCI Express x16..." device

later I find that "Intel(R) Xeon E3-....PCI Express x16..." is sitting on top of "PCI Bus" so the addresses are supposed to overlap ?

my video card and network card are on the PLX chip and I don't see them in device manager, it's funny that there is no "VGA compatible comtroller" in device manager and the system works fine otherwise

--------------------------------------------------------------------------------------------------------------------------------------------

I looked into my XP x64 installation and found out I have conflict between the PCI-E PLX chip and VgaSave driver

here is what I tried:

1. switch to IGPU as display device while the cards are connected and use the IGPU as boot display device

2. install drivers (nvw2k35306.cab) for both other cards (successful)

(tried also nvw2k35906.zip, nvw2k35560.cab - they both give error "cannot load driver for device")

3. switch back to the card as display device (780 Ti) and use it as boot display device

4. it's still conflicts and all the devices connected to the PLX chip are gone from device manager

any way to dodge this problem ?

I tried to look into the registry see if I could change those conflicting addresses, could not find what I was hoping for (load VgaSave into a different MMIO range).

I tried to uninstall VgaSave a couple of times, it screwed 2 installations by BSOD with a followed reboot and no safe mode, I guess no point trying it again :x

--------------------------------------------------------------------------------------------------------------------------------------------

I tried everything, moving the card to another slot, replacing vga.sys with version from windows xp SP0,SP3, a version from windows 2003 SP0, a version from 2000 SP0, tried to replace HKLM\SYSTEM\CurrentControlSet\Services\nv to VgaSave and VgaSave renamed with VgaCompatible set to 0 and 1, tried to change VgaSave Start mode from 1 to 2,3 and 0, tried to enable more devices in BIOS to force it to move MMIO address to another range with no luck here either, tried updated VGA driver videoprt.sys still no luck

--------------------------------------------------------------------------------------------------------------------------------------------

ok so the story of this problem is that when the system is installed as Standard-PC the conflict does not exist and the system detects the devices but if installed as any of the ACPI options the conflict exists, I tried to change it after installation but this consistently causes INACCESSIBLE_BOOT_DEVICE 0x0000007B BSOD, however before switching from Standard-PC to ACPI-MP and backup the hal.dll of the Standard-PC configuration and rename it to for example hal-std.dll then add a boot.ini option for it as /HAL=hal-std.dll - it becomes possible to enter the system in safe mode, in addition it turns out the problem is not with the PLX chip - the conflict exists also when the cards are connected directly to PCI-E bus that is in the CPU, I tried many different combinations of /HAL and /KERNEL to boot the ACPI-MP mode but all of them failed mostly on the 7B BSOD, I also tried to uninstall and change the "fancy" IDE controller drivers to windows standard drivers but that failed as well, also tried to install the system without integrated chipset drivers but the problem was the same only the name of the conflicting device changed (instead of PCI-E x16 controller it's called PCI-PCI bridge)

Edited by monohouse
0

Share this post


Link to post
Share on other sites

It appears that the error, at least on Vista and Server 2008, is that (https://support.microsoft.com/en-us/kb/942959)

"By default, when you start or reset PCI Express bridge devices, the initial values of the limit register for the bridge resource window are less than the initial values of the base register for the bridge resource window. Windows Vista and Windows Server 2008 interpret this behavior as an indication that the bridge resource window is disabled.

and

Additionally, Windows Vista and Windows Server 2008 do not generate any bridge resource window requirements for the PCI Express bridge device. Therefore, any PCI Express bridge device that requires resources from the bridge resource window will fail enumeration. In this situation, a Code 12 error is generated."

There are workarounds, but I don't know if they would work on Windows 2000, or even XP.

0

Share this post


Link to post
Share on other sites

Posted (edited)

On 4/29/2016 at 1:36 PM, monohouse said:

--quote snip--

:\

I had this issue with my motherboard(ASUS Z87-A), I can't really do anything about it and I need a DVI output, so I quit when I got this.

Edited by agrecascino
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.