Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Windows 2000 on Haswell?

- - - - -

  • Please log in to reply
61 replies to this topic

#51
blackwingcat

blackwingcat

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 772 posts
  • OS:Windows 2000 Professional
  • Country: Country Flag

Hi.

 

I see usually that w2k hangs up on "Setup is starting Windows 2000" without SP4 RP1 Integrated.

What did you integrated your DVD ?

 

I think the Intel 11.2 driver has not relation.

 

 

I checked your iso file.

It may be come from USB compatibility problem.

 

I will restart to create deutsch extended kernel hfslip image soon.

 

 

Hi, The error "iastor.sys is corrupted" was solved by copying the whole STORAGE Folder from exkernel hfslip DVD. Perhaps my download of Intel 89c driver from your website got really corrupted somehow. Now the Image installs flawlessly on vm. But on real install, w2k hangs up on "Setup is starting Windows 2000" again. without bsod like with original CD. From this I have to follow sadly, that w2k, will not install on haswell Notebook, although Intel ahci 89c and exkernel v16 are used. Nevertheless I have uploaded the iso on google drive (it is 16h21m.iso), perhaps I have missed something.

I also tried using Intel 11.2. ahci Driver modded by Fernando which worked fine with Windows xp. In this case, the Installation of w2k stops with the message "insufficiant (memory?/harddisk?) space for ntfs.sys" (in german original: "unzureichender Speicherplatz für ntfs.sys"). From this I followed, that perhaps this driver could work, but w2k txtmode setup  cannot detect the hardware components properly. I have uploaded this iso,too, for further experiments.(20h49m.iso). If you will not find any mistake in the isos, my next step will be edit txtsetup.sif to tell w2k the hardware components. Perhaps also using some components of xp txtmode setup with kernelex could be a solution.


Edited by blackwingcat, 20 August 2014 - 10:25 PM.

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
BlackWingCat =^^=
http://blog.livedoor.jp/blackwingcat/
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+


How to remove advertisement from MSFN

#52
JosefReisinger

JosefReisinger

    Newbie

  • Member
  • 12 posts
  • OS:Windows 2000 Professional
  • Country: Country Flag

Hi.

Of course SP4 RP1 was integrated, also all possible official updates and official hotfixes (SP5). I am not sure if USB is the problem, because also english exkernel DVD hangs up on "Setup is starting Windows 2000". I have two USB devices PCI\VEN_8086&DEV_9C26 which is Intel 8 USB 2.0 and PCI\VEN_8086&DEV_9C31 for USB 3.0 Intel eXtensible which can be set in compat mode with BIOS. Also there is USB Webcam which I cannot disable on installation. I will try to add the ID´s according to your ADDSIF.ini in my storage.ini. Perhaps w2k gets confused with PCMCIA card reader, so I will add it too; I will post the results here.

THANK YOU SO MUCH for creating exkernel german DVD!


Edited by JosefReisinger, 22 August 2014 - 02:10 AM.


#53
JosefReisinger

JosefReisinger

    Newbie

  • Member
  • 12 posts
  • OS:Windows 2000 Professional
  • Country: Country Flag

Hi. This is what I added to storage.ini:

 

[HardwareIdsDatabase]

USB\VID_0781&PID_5572 = "usbstor"
USB\VID_054C&PID_0010 = "usbstor"
USB\VID_054C&PID_0025 = "usbstor"
USB\VID_054C&PID_002D = "usbstor"
USB\VID_054C&PID_002E = "usbstor"

 

PCI\VEN_8086&DEV_9C10&SUBSYS_15AD1043 = "pci"
PCI\VEN_8086&DEV_9C14&SUBSYS_15AD1043 = "pci"
PCI\VEN_8086&DEV_9C16&SUBSYS_15AD1043 = "pci"
PCI\VEN_8086&DEV_9C18&SUBSYS_15AD1043 = "pci"
PCI\VEN_8086&DEV_9C43&SUBSYS_15AD1043 = "isapnp"
PCI\CC0320 = "usbehci"
PCI\VEN_8086&DEV_9C26&SUBSYS_201F1043 = "usbehci"
PCI\VEN_8086&DEV_9C31&SUBSYS_201F1043 = "usbehci"

 

[InputDevicesSupport.Load]
usbehci  = usbehci.sys
 
[files.usbehci]
hid.dll,2
hccoin.dll,2
hidclass.sys,4
hidparse.sys,4
usbd.sys,4
usbport.sys,4
usbehci.sys,4
 
[InputDevicesSupport]
usbehci  = "Erweiterter Hostcontroller",files.usbehci,usbehci

 

Unfortunally this did not change w2k refusing to install. I also tried to use usb*hci.sys and usbccgp.sys from english exkernel dvd which caused bsod after "setup is starting windows 2000". I also compared txtsetup.sif from xp with w2k. Besides USB there are no hardware ID's missing which are relevant for my notebook and are present in xp. So I list up my hardware ID's (taken from w8.1), perhaps the experts here can see from this why w2k exkernel refuses to install while xp installs perfectly:

 

Microsoft ACPI-Kontrollmethodenkompatibler Akku    ACPI\PNP0C0A\0    battc.sys, CmBatt.sys
Microsoft Netzteil    ACPI\ACPI0003\3&11583659&1    battc.sys, CmBatt.sys
AUDIO, VIDEO und GAMECONTROLLER
Realtek High Definition Audio    HDAUDIO\FUNC_01&VEN_10EC&DEV_0233&SUBSYS_104315AD&REV_1000\4&345388FF&0&0001    
BILDVERARBEITUNGSGERÄTE
USB2.0 HD UVC WebCam    USB\VID_04F2&PID_B409&MI_00\6&23D3F2DB&0&0000    ksthunk.sys, usbvideo.sys
COMPUTER
ACPI x64-basierter Computer    ROOT\ACPI_HAL\0000     (keine)
EINGABEGERÄTE (HID)
HID-kompatible Funkempfängersteuerelemente    HID\ATK4001\3&2B9532E0&0&0000 (keine)    
GRAFIKKARTE
Intel ® HD Graphics Family    PCI\VEN_8086&DEV_0A16&SUBSYS_15AD1043&REV_09\3&11583659&1&10
NVIDIA GeForce 820M    PCI\VEN_10DE&DEV_1140&SUBSYS_15AD1043&REV_A1\4&AD8C3AC&0&00E4
IDE ATA/ATAPI-Controller
Intel ® 8 Series Chipset Family SATA AHCI Controller    PCI\VEN_8086&DEV_9C03&SUBSYS_15AD1043&REV_04\3&11583659&1&FA    iaStorA.sys
MÄUSE
Microsoft PS/2 Maus    ACPI\ETD0108\4&28464D9B&0    i8042.sys, mouclass.sys
MONITORE
PnP Monitor (Standard)    DISPLAY\CMN1728\4&4C498D8&0&UID68092928    monitor.sys
NETZWERKADAPTER
Qualcomm Atheros AR9485 Wireless Network Adapter    PCI\VEN_168C&DEV_0032&SUBSYS_11861A3B&REV_01\4&1A70240C&0&00E3    athwbx.sys vwifibus.sys
Realtek PCIe GBE Family Controller    PCI\VEN_10EC&DEV_8168&SUBSYS_200F1043&REV_12\05243812684CE00001    Rt630x64.sys RtNicProp64.dll
POZESSOREN 4xIntel ACPI\GENUINEINTEL_-_INTEL64_FAMILY_6_MODEL_69_-_INTEL®_CORE™_I7-4500U_CPU_@_1.80GHZ\_1, \2, \3, \4
SPEICHERCONTROLLER
Microsoft VHD-Loopbackcontoller     vhdmp.sys vhdmp.inf        {8e7bd593-6e6c-4c52-86a6-77175494dd8e}\MsCompatibleVhdHba
Microsoft Controller für Speicherplätze    ROOT\SPACEPORT\0000    spaceport.sys spaceport.inf        
SPEICHERTECHNOLOGIEGERÄTE
Realtek PCI CardReader    PCI\VEN_10EC&DEV_5287&SUBSYS_202F1043&REV_01\4&23281D7F&0&00E2; cp: PCI\CC_FF00    RtsPer.sys;RtlPerlcon.dll
SYSTEMGERÄTE
ACPI Deckel    ACPI\PNP0C0D\2&DABA3FF&2
ACPI Energiezustandknopf    ACPI\PNP0C0E\2&DABA3FF&2
ACPI-Schalter    ACPI\FIXEDBUTTON\2&DABA3FF&2
ACPI-Thermozone    ACPI\THERMALZONE\THRM   
ASUS Wireless Radio Control    ACPI\ATK4001\2&DABA3FF&2    sys32\Drivers\AsHIDSwitch64.sys
Busenumerator für Verbundgeräte    ROOT\COMPOSITEBUS\0000   
DMA-Controller    ACPI\PNP0200\4&28464D9B&0   
Eingebetteter, Microsoft ACPI-konformer Controller    ACPI\VEN_PNP&DEV_0C09 PNP0C09\4&28464D9B&0 (keine)
Enumerator für virtuelle NDIS-Netzwerkadapter    ROOT\NDISVIRTUALBUS\0000        NdisVirtualBus.sys
Geräte-Redirectorbus für Remotedesktop    ROOT\RDPBUS\0000        rdpbus.sys, rdpbus.inf
Hauptplatinenressourcen    ACPI\PNP0C02\1        (keine)
Hauptplatinenressourcen    ACPI\PNP0C02\2        (keine)
Hauptplatinenressourcen    ACPI\PNP0C02\4        (keine)
Hauptplatinenressourcen    ACPI\PNP0C02\9        (keine)
Hauptplatinenressourcen    ACPI\PNP0C02\10        (keine)
Hauptplatinenressourcen    ACPI\PNP0C02\13        (keine)
Hauptplatinenressourcen    ACPI\INT340E\2&DABA3FF&2        (keine)
Hauptplatinenressourcen    ACPI\INT3F0D\4&28464D9B&0        (keine)
High Definition Audio-Controller    PCI\VEN_8086&DEV_0A0C&SUBSYS_15AD1043&REV_09\3&11583659&1&18  hdaudbus.sys,hdaudbus.inf
High Definition Audio-Controller    PCI\VEN_8086&DEV_9C20&SUBSYS_15AD1043&REV_04\3&11583659&1&D8  (not present)  hdaudbus.sys hdaudbus.inf
Hochpräzisionsereigniszeitgeber    ACPI\PNP0103\0        
Intel® 8 Series LPC Controller (Pr. SKU)-9C43    PCI\VEN_8086&DEV_9C43&SUBSYS_15AD1043&REV_04\3&11583659&1&F8        msiadrv.sys, oem4.inf
Intel® 8 Series PCI Express Root Port #1- 9C10    PCI\VEN_8086&DEV_9C10&SUBSYS_15AD1043&REV_E4\3&11583659&1&E0        pci.sys, oem4.inf
Intel® 8 Series PCI Express Root Port #3- 9C14    PCI\VEN_8086&DEV_9C14&SUBSYS_15AD1043&REV_E4\3&11583659&1&E2        pci.sys, oem4.inf
Intel® 8 Series PCI Express Root Port #4- 9C16    PCI\VEN_8086&DEV_9C16&SUBSYS_15AD1043&REV_E4\3&11583659&1&E3        pci.sys, oem4.inf
Intel® 8 Series PCI Express Root Port #5- 9C18    PCI\VEN_8086&DEV_9C18&SUBSYS_15AD1043&REV_E4\3&11583659&1&E4        pci.sys, oem4.inf
Intel® 8 Series SMBus Controller - 9C22    PCI\VEN_8086&DEV_9C22&SUBSYS_15AD1043&REV_04\3&11583659&1&FB        (keine), oem5.inf
Intel® 82802 Firmwarehub    ACPI\INT0800\4&28464D9B&0        (keine)
Intel® Dynamic Platform and Thermal Framework Driver   ACPI\INT3400\2&DABA3FF&2 Oem16.inf    \DRIVERS\DptfManager.sys
\SYSWOW64\DptfInvalidPolicyRemover.exe SYSWOW64\DptfInvalidPolicyRemover.ini    \system32: \DptfCoInstaller.exe, \DptfEventLogMessage.dll, \DptfPolicyConfigTDPDll.dll,
\DptfPolicyConfigTDPService.exe, \DptfPolicyCriticalService.exe, \DptfPolicyLpmDll.dll, \DptfPolicyLpmService.exe, \DptfPolicyLpmServiceHelper.exe
Intel® Dynamic Platform and Thermal Framework Memory Participant Driver    ACPI\INT3402\0    oem16.inf    \system32\DRIVERS\DptfDevDram.sys
Intel® Dynamic Platform and Thermal Framework PCH Patricipant Driver    PCI\VEN_8086&DEV_9C24&SUBSYS_15AD1043&REV_04\3&11583659&1&FE    oem16.inf    \system32\DRIVERS\DptfDevPch.sys
Intel® Dynamic Platform and Thermal Framework Processor Participant Driver    PCI\VEN_8086&DEV_0A03&SUBSYS_20108086&REV_09\3&11583659&1&20    oem16.inf    system32: \DptfParticipantProcessorService.exe, \system32\DRIVERS\DptfDevProc.sys
Intel® Management Engine Interface  PCI\VEN_8086&DEV_9C3A&SUBSYS_15AD1043&REV_04\3&11583659&1&B0  

C:\ProgramData\Microsoft\Windows\DeviceMetadataStore\EN\3f3ca95b-3978-4168-b47b-5444f42d6c89.devicemetadata-ms
C:\ProgramData\Microsoft\Windows\DeviceMetadataStore\EN\46a6fdbe-c823-4579-bab6-35f67e01f793.devicemetadata-ms
\system32\DRIVERS\TeeDriver64.sys
IWD Bus Enumerator ROOT\SYSTEM\0001    oem10.inf    \sys32\DRIVERS\iwdbus.sys \sys32\WdfConinstaller01009.dll
Microsoft ACPI-konformes System    ACPI_HAL\PNP0C08\0        \sys32\DRIVERS\acpi.sys
Microsoft Basic Display Driver    ROOT\BASICDISPLAY\0000    basicdisplay.inf    \sys32\DRIVERS\BasicDisplay.sys
Microsoft Basic Render Driver    ROOT\BASICRENDER\0000    basicrender.inf    \sys32\DRIVERS\BasicRender.sys
Microsoft virtueller Daenträgerenumerator    ROOT\VDRVROOT\0000 vdrvroot.inf    \sys32\DRIVERS\vdrvroot.sys
Microsoft Windows-Verwaltungsschnittstelle für ACPI    ACPI\PNP0C14\ATK    wmiacpi.inf    \sys32\DRIVERS\wmiacpi.sys
Microsoft-Systemverwaltungs-BIOS-Treiber    ROOT\MSSMBIOS\0000    mssmbios.inf    \sys32\DRIVERS\mssmbios.sys
PCI Standard-Host-CPU-Brücke    PCI\VEN_8086&DEV_0A04&SUBSYS_15AD1043&REV_09\3&11583659&1&00    machine.inf    (keine)
PnP-Softwaregeräte-Enumerator    ROOT\SYSTEM\0000    swenum.inf    \sys32\DRIVERS\swenum.sys, \sys32\stremci.dll
Programmierbarer Interruptcontroller    ACPI\PNP0000\4&28464D9B&0    machine.inf    (keine)
Stammkomplex für PCI-Express    ACPI\PNP0A08\0    machine.inf    \system32\DRIVERS\pci.sys
System CMOS/Echtzeituhr    ACPI\PNP0800\4&28464D9B&0    machine.inf    (keine)
Systemplatine    ACPI\PNP0C01\1    machine.inf    (keine)
Systemzeitgeber    ACPI\PNP0100\4&28464D9B&0    machine.inf    (keine) hängt an SKU
UMBus-Stamm-Busenumerator    ROOT\UMBUS\0000    umbus.inf    \system32\DRIVERS\umbus.sys
VMware VMCI Host Device            
Volume-Manager    ROOT\VOLMGR\0000    volmgr.inf    \system32\DRIVERS\volmgr.sys
USB CONTROLLER
Generic USB Hub    USB\VID_8087&PID_8000\5&262C90AC&0&1 Kompatible ID: USB\Class_09    usbd.sys, usbhub.sys    
Intel 8 Series/C216-Chipsatzfamilie - USB erweiterter Hostcontroller Nr.1 -9C26    PCI\VEN_8086&DEV_9C26&SUBSYS_201F1043&REV_04\3&11583659&1&E8
Kompatible ID: PCI\CC_0C0320    usbport.inf    \system32\drivers\usbehci.sys \system32\drivers\usbhub.sys \system32\drivers\usbport.sys
Intel ® USB3.0 eXtensible Hostcontroller -0100 (Microsoft)    PCI\VEN_8086&DEV_9C31&SUBSYS_201F1043&REV_04\3&11583659&1&A0
Kompatible ID: PCI\CC_0C0330    usbxhci.inf    \system32\drivers\UCX0100.SYS \system32\drivers\USBXHCI.SYS
USB Massenspeicher (Stick)    USB\VID_0781&PID_5572\4C532000060909112414    usbstor.sys    
USB-Root-HUB    USB\ROOT_HUB20\4&1A821DE9&0        
USB-Root-Hub(xHCI)    USB\ROOT_HUB30\4&37BCF05C&0&0        
USB-Verbundgerät    USB\VID_04F2&PID_B409\0X0001    usbccgp.sys    


 



#54
bearwindows

bearwindows

    Newbie

  • Member
  • 33 posts

JFUI, for some Haswell 8-series motherboards, f.e. Intel DB85FL there is no official Intel LAN driver for Windows XP/2003 (in this case it is Intel I217V).

 

Latest LAN package (below) does not contain them.

Network Adapter Drivers for Windows XP*, Final Release
File name: PRO2K3XP_32.exe 
Version: 18.3 (Latest)
Date: 05/15/2013

https://downloadcent...Y&DwnldID=18717

 

However in this package (below) it exists (for I217V forcible choose I217-LM)

Intel® Ethernet Drivers for Microsoft* Embedded Operating Systems

Version: 11.5 (Current)
Date: 09/01/2013

PROEmbSw11.exe

https://downloadcent...x?DwnldID=22928

 

Hope this helps also with Windows 2000. :)


Developer quote:
If its good, I am responsible. If its bad, its all your fault. ;)
Suggestions and bug-reports are always welcome.
Well ... bug-reports are perhaps not *that* welcome ... ;)
© Daniela Engert.

#55
blackwingcat

blackwingcat

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 772 posts
  • OS:Windows 2000 Professional
  • Country: Country Flag

JFUI, for some Haswell 8-series motherboards, f.e. Intel DB85FL there is no official Intel LAN driver for Windows XP/2003 (in this case it is Intel I217V).

 

Latest LAN package (below) does not contain them.

Network Adapter Drivers for Windows XP*, Final Release
File name: PRO2K3XP_32.exe 
Version: 18.3 (Latest)
Date: 05/15/2013

https://downloadcent...Y&DwnldID=18717

 

However in this package (below) it exists (for I217V forcible choose I217-LM)

Intel® Ethernet Drivers for Microsoft* Embedded Operating Systems

Version: 11.5 (Current)
Date: 09/01/2013

PROEmbSw11.exe

https://downloadcent...x?DwnldID=22928

 

Hope this helps also with Windows 2000. :)

 

Hi.

I fail to install this with Windows XP on Intel NUC D54250WYK before.

So, I use Wireless LAN on Windows 2000.


Edited by blackwingcat, 27 August 2014 - 06:10 PM.

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
BlackWingCat =^^=
http://blog.livedoor.jp/blackwingcat/
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

#56
JosefReisinger

JosefReisinger

    Newbie

  • Member
  • 12 posts
  • OS:Windows 2000 Professional
  • Country: Country Flag

Hi.

FIRST SUCCESS! I could install w2k on Haswell 4th generation notebook ASUS R752LD by hitting F5 and choosing "Standard PC". AHCI Driver 8.9 modded by blackwingcat worked perfectly with extended core v16 german and showed the  harddisk. Furthermore, the whole installation was done in 4 minutes without error, many times faster than XP.

Resumee: There are no problems with AHCI driver or USB. The main problem seems to be ACPI (unfortunally, no ACPI Bios settings are present). I tried to change "Standard PC" after successful installation into "ACPI Multiprocessor PC " in device manager, but this makes the system unbootable. With protected mode the system stops to boot at mup.sys. With "last good known configuration", the system hangs, too.

@blackwingcat: can you give advice how to go on? Should I add something to acpi.inf? Or should I try to add some ACPI files from XP (first I thought of acpi.sys, but it is modded yet in excore v16!)?


Edited by JosefReisinger, 02 September 2014 - 04:11 PM.


#57
blackwingcat

blackwingcat

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 772 posts
  • OS:Windows 2000 Professional
  • Country: Country Flag

Hi.

 

When ACPI problem occured, I always gave up the mother board.

 

It caused from BIOS problem, so If you update  BIOS version or change other BIOS, it may work wit no problem .

 

Although the message shows it comes from ACPI.sys problem, when I customized from XP's ACPI.sys, it shows same message.

So I think it comes from other problem.

 

Hi.

FIRST SUCCESS! I could install w2k on Haswell 4th generation notebook ASUS R752LD by hitting F5 and choosing "Standard PC". AHCI Driver 8.9 modded by blackwingcat worked perfectly with extended core v16 german and showed the  harddisk. Furthermore, the whole installation was done in 4 minutes without error, many times faster than XP.

Resumee: There are no problems with AHCI driver or USB. The main problem seems to be ACPI (unfortunally, no ACPI Bios settings are present). I tried to change "Standard PC" after successful installation into "ACPI Multiprocessor PC " in device manager, but this makes the system unbootable. With protected mode the system stops to boot at mup.sys. With "last good known configuration", the system hangs, too.

@blackwingcat: can you give advice how to go on? Should I add something to acpi.inf? Or should I try to add some ACPI files from XP (first I thought of acpi.sys, but it is modded yet in excore v16!)?


+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
BlackWingCat =^^=
http://blog.livedoor.jp/blackwingcat/
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

#58
JosefReisinger

JosefReisinger

    Newbie

  • Member
  • 12 posts
  • OS:Windows 2000 Professional
  • Country: Country Flag

Hi.

Thank you for your answer. Could you explain the difference between XP and 2kExkernel how BIOS is managed? Remember, there is no problem in txtmode setup with XP, ACPI is detected correctly. So there should be a way to get w2k through txtmode setup, too. I have latest BIOS version on this notebook.



#59
JosefReisinger

JosefReisinger

    Newbie

  • Member
  • 12 posts
  • OS:Windows 2000 Professional
  • Country: Country Flag

@blackwingcat:

Of course you were right with BIOS and W2k incompatibility on haswell notebook. Windows setup gives message with BSOD about it, if I choose "ACPI-PC". If I choose "ACPI-Multiprocessor-PC" or "ACPI-Uniprocessor", it will not show this message, but will not find starting device and hangs on "setup is starting windows 2000". Please could you comment the following if I am right or wrong?

I found out that NTDETECT and NTLDR in combination with ntoskrnl read out bios on startup on installed and running system. On every startup, windows loads ACPI table from bios to see if it changed since last startup. In txtmode setup, things are more complicated. There is a "mini kernel" loaded and usetup.exe in combination with ntdetect and ntldr do the decision about ACPI. Usetup makes two directories and copies files into it. The first directory is used for loading hal and drivers (phase 1 of txtmode setup), then, when "setup is starting windows 2000" message is shown, protected mode is entered (phase 2 of txtmode setup). I don´t know exactly, if in phase 2 the mini kernel is used again or if ntoskrnl does it yet.
Phase 1 cannot be the problem, because setup will decide that the system supports ACPI. But when entering phase 2, setup doesn´t find the startup device any more in ACPI mode. The same effect occurs if I want to change HAL from Standard-PC to ACPI-PC on up and running system. Since this works fine in XP, I follow:
NTDETECT.COM cannot be the problem, because XP original file is used.
NTLDR cannot be the problem, because XP original file is used.
Problem files could be HAL.DLL and NTOSKRNL.EXE, or this mini kernel file from which I did not find out the name.
What could I try to let w2k find the start device after changing the HAL on up and running system? The system hangs on acpitabl.dat. Perhaps there are some registry or other tricks to get it solved after installation?

 

@all

So, hitting "F5" when setup is showing "F6" can be a kind of "diagnostic tool", if you want to install w2k on haswell:

* Hit "F5" when Setup shows to hit "F6"

* W2k will show a list. On some modern hardware you will only see a few possibilities with the option "Standard PC", "MPS" and "other".

* Don´t choose "Standard PC" first. Scroll up to see the other possibilities. Don´t choose "ACPI Multiprocessor" or "ACPI Uniprocessor". Choose "ACPI-PC".

A. W2k will tell you if your BIOS is not compatible with ACPI with a BSOD message (this is only shown when choosing ACPI-PC, not shown with ACPI Multi- or Uniprocessor-PC) OR

B. Setup will show the harddisk for installation.

Now, A.: Shut down the computer or B. : Hit F3 to shut down the computer.

* Repeat setup with "F5".

* If you had A. before, choose "Standard PC" for installation.

* If you had B. before, choose "ACPI-Multiprocessor-PC"

 

Greetings, Joe


Edited by JosefReisinger, 15 September 2014 - 04:08 AM.


#60
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,383 posts
  • OS:none specified
  • Country: Country Flag

Maybe the issue is just with SETUPLDR.BIN (or more generally with "installing") whilst the installed system can possibly be later switched to a different HAL/KERNEL?

 

jaclaz



#61
JosefReisinger

JosefReisinger

    Newbie

  • Member
  • 12 posts
  • OS:Windows 2000 Professional
  • Country: Country Flag

Jaclaz, thank you for your answer and suggestion.

I tried to switch w2k "standard pc" to "acpi-multiprocessor-pc" yet, but perhaps I did it wrong, because I am a beginner.

First I tried with device manager and changed "Standard-PC" there (but I did not change anything else), which ended with hang-up (in protected mode, it stopped at loading mup). Then I reserched and found microsoft kb237556. According to this, I renamed halmacpi.dll -> hal.dll, ntkrnlmp.exe -> ntoskrnl.exe, ntkrpamp.exe -> ntkrnlpa.exe and copied the 3 files into system32. This ended with hang-up, too (in protected mode, now the system stopped at acpitabl.dat). Is this yet a proof, that the installed system cannot be switched to a different HAL, or did I miss something?



#62
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,383 posts
  • OS:none specified
  • Country: Country Flag

Cannot say, but the "traditional" way to test HAL/Kernels has been through BOOT.INI switches.

See:

http://support.micro...kb/833722/en-us

and links provided here:

http://www.msfn.org/...-down/?p=980575

 

Mind you it is entirely possible that *something else*  is *somehow*  "botched" during install and that the above won't work at all.

 

jaclaz






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN