Sign in to follow this  
Followers 0
go98

safe mode fix

15 posts in this topic

If you use safe mode more than a few times a year, you may not want to see the information dialog that pops up on every boot. I didn't see it in my resource editor, but you can get rid of it by hex-editing the file explorer.exe.

 

at address (offset) 3289: 0F 85 E6 74 00 00

 

change each of those six bytes to 90.

 

 

Note: This is for my own localized (secret language :whistle: , courtesy of Submix8c) version. If you find the above bytes, you have it...if not, check posts #11 and #14 for more options...

 

(if you place a copy of explorer.exe on for example c:\ to work with, you need to delete it when done, or Windows might use it instead of the one in the windows directory)

Edited by go98
0

Share this post


Link to post
Share on other sites

Would you mind explaining what the heck you're talking about?

Inquiring minds want to know...

edot - OHHHH!!!!! Ye olde "Safe Mode" stuff on your screen. O-key-doke...

Edited by submix8c
0

Share this post


Link to post
Share on other sites

I would like to see screenshots, before and after, showing what this does.

Cheers and Regards

0

Share this post


Link to post
Share on other sites

Followup - WHICH Win9x? Neither the Win98SE nor WindowsME EXPLORER.EXE (English) contain this Hex string.

0

Share this post


Link to post
Share on other sites

bphlpt: The fix removes the dialog that pops up everytime you boot into safe mode

submix8c: This is for 98SE, but there must be differences between the language-versions if you can't find the bytes...OR...your version is updated with other fixes that have moved code & pointers...

0

Share this post


Link to post
Share on other sites

I finally got that (about the pop-up).

I might point out your "fix" is useless unless you indicate exactly how to find it in -any- language and -any- version. You gave an Offset, but is it in Decimal or Hex? I find at at Hex Offset x77A1 the following Hexadecimal String - x0F85E6400000 - ENTIRELY different and I found that by searching for x0F85E6, so why bother? :unsure:

P.S. That string does NOT exist in WinMe and MANY users use the SE2ME on their 98SE's... :huh:

x0F85 = JUMP instruction, many of which exist within. You're changing a specific "set" into a series of "NOP" for a "drop-through". ;)

Edited by submix8c
0

Share this post


Link to post
Share on other sites

I might point out your "fix" is useless unless you indicate exactly how to find it in -any- language and -any- version.

You might :yes:, while I might point out that if at the very least the EXACT explorer.exe version is provided AND the EXACT language/locale is provided, this example could be possibly extended by other members to other versions/languages/locales, or at worst the - presumably few - users using that same particular version and language/locale may benefit from go98's findings.

Now, an interesting point IMHO is why actually one should need to access Safe Mode more frequently than "a few times a year", and why exactly removing the warning popup is a good idea, even in that case. :unsure:

What about, after for several years no car crashed in a given place, the curve warning signs:

http://techtransfer.berkeley.edu/newsletter/08-2/signs-for-curves-and-turns.php

are removed (and re-used on new roads) ? :w00t:

It is evident to everyone how this practice will allow for consistent savings in the new road signs procurement budget and is overall more environment friendly.

jaclaz

0

Share this post


Link to post
Share on other sites

SoftIce is nice.
A hackers paradise!
Don't like the mode?
Follow the code!
Change it all in a thrice.

It appears that the code is ( after checking for "something" :unsure: ) branching to a "subroutine" to display a specific String in the "box" having a simple "OK" button. It's kind of pointless to chase this down (seeing as how the addresses have been relocated). Kind of the same thing as that "localized Notepad" trick the OP had provided.

"I did it in my (secret language) localized module thusly, so surely this will work for you." :w00t:

0

Share this post


Link to post
Share on other sites

ok, in the english version contained in servicepack 3.28 by problemchild, it's at address 2853 (hex): 0F 85 56 6A 00 00

But I can't verify it...

0

Share this post


Link to post
Share on other sites

ok, in the english version contained in servicepack 3.28 by problemchild, it's at address 2853 (hex): 0F 85 56 6A 00 00

But I can't verify it...

If I were you, I would update to SP 3.30, which was release yesterday. Always use the latest version. I will give your fix a test run. Thanks

0

Share this post


Link to post
Share on other sites

If you use safe mode more than a few times a year, you may not want to see the information dialog that pops up on every boot.

If you mean the Booting in Safe Mode warning, that is best diabled in MSDOS.SYS with:

[Options]BootWarn=0
Edited by jumper
0

Share this post


Link to post
Share on other sites

How about:

[Options]

CheckWithJumperFirst=1

Very good, Jumper, I searched but couldn't find this setting myself, no trace in the file calling for this either. I may keep my own solution though to make it set already on install, unless there's a setting for that too? haha

0

Share this post


Link to post
Share on other sites

That switch, just for the record, is documented here (for Windows 95):

http://www.tiplord.com/

http://www.tiplord.com/customizing/MSDOSSYS.HTM

(which has a few nice tips/docs/whatevr about 9x)

And (about hex editing to do other things):

http://www.msfn.org/board/topic/118073-disable-f8-win98-boot-disk-startup-menu/

http://reboot.pro/topic/4754-disable-the-f8-startup-menu-on-win98-boot-disk/

jaclaz

0

Share this post


Link to post
Share on other sites

The MSDOS.SYS approach did NOT work for me, but patching explorer did.

 

[Options]
BootWarn=0

 

Anything helps when the number of clicks are minimize.
Correct address 2853 (hex): 0F 85 56 6A 00 00 and replace with 90 90 90 90 90 90

0

Share this post


Link to post
Share on other sites

Thanks for the clarification...and welcome back to this forum again after a long holiday, Problemchyld  :w00t:

Edited by go98
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.