Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Win 8.1 Problems with USB 3


  • Please log in to reply
6 replies to this topic

#1
LeicaIIIf

LeicaIIIf
  • Member
  • 5 posts
  • Joined 25-March 14
  • OS:Windows 8.1 x64
  • Country: Country Flag

Computer is HP 1037cb desktop with AMD 4 core processor (2011 vintage) with upgraded 16GB memory, graphics card, power supply and Cavalry 2 port USB 3 PCIe card.  Original hard disk is a 1 TB Seagate with Windows 7 Home Premium installed.  I added 2 external USB 3 hard drives - a 2 TB Iomega, and a 2 TB Seagate Free Agent GoFlex.  This setup ran well with no problems.  When Win 8 was released I added a second internal Western Digital 1 TB hard drive and installed the Win 8, then upgraded to Win 8.1 when it was released so I could boot to either Win 7 or Win 8.1.  When I boot to Win 8.1 there is a problem with both USB 3 external disk drives.  The external USB 3 Seagate drive goes into sleep mode about every 20 seconds, then wakes up again about 20 seconds later and keeps repeating this until shutdown.  The external USB 3 Iomega does not go to sleep, but there is a series of audible beeps and disk activity every 20 seconds that repeats until shutdown.  When I installed Win 8.1 the OS recognized the USB 3 card and installed Microsoft drivers.  The Win 7 disk has drivers supplied by NEC Electronics and there are no USB 3 problems when running Win 7, only when running Win 8.1.  I suspect the USB 3 card is incompatible with Win 8.1, but the Win 8 upgrade wizard did not detect any hardware incompatibility before installation.  USB 3 cards are fairly inexpensive so I plan to try a different card.  Has anyone else had any USB 3 problems in Win 8.1?  Also if anyone has added a USB 3 card to an older computer and has no problems I would appreciate knowing what brand of card works.  Thanks in advance.

 

LeicaIIIf

 

P. S. - Sorry for double post - Don't see how to delete a post.


Edited by LeicaIIIf, 09 April 2014 - 02:05 PM.



How to remove advertisement from MSFN

#2
helmutcheese

helmutcheese

    Junior

  • Member
  • Pip
  • 74 posts
  • Joined 17-September 13
  • OS:Windows 8 x64
  • Country: Country Flag

Some reported issues but after initial Firmware/Drivers update on a Asus Z68 ROG with NEC/Renesas USB 3.0 I was solid and now on Asus Z87 ROG with Intel USB 3.0 also solid only its using MS drivers as Intel have not pulled their finger out yet and the early driver will not even install for many or do install and act up.

 

I would expect it to be Firmware/Drivers causing issue.

 

I still cannot paste here with IE11 (think it worked once) go to station-drivers.com and see what is there to update.

 

My issues were fixed during Win 8 before .1 update and I have none since.


Edited by helmutcheese, 10 April 2014 - 09:34 AM.


#3
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,133 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

this is a known bug with 8.1 and when you install the large 8.1 update the USB stack is reverted back to 8.0 behavior and this fixes the sleep issue


Posted Image

#4
LeicaIIIf

LeicaIIIf
  • Member
  • 5 posts
  • Joined 25-March 14
  • OS:Windows 8.1 x64
  • Country: Country Flag

Thanks Helmut and Magic Andre for your suggestions - If only I could install the large 8.1 update (KB2919355) I might get the use of my USB ports back, but the install from Windows Update fails on my machine.  The Windows Troubleshooter and all the Microsoft suggestions for the failure to install is to start from scratch with Win 8, then reinstall Win 8.1, but that would result in the loss of all my desktop applications.  I don't really want to do that because I don't have the installation files for many of my applications.  The failure of the new 8.1 update seems to be widespread as there are many complaints around the internet, and nothing but silence from Microsoft.  I think I'll give up on 8 and 8.1 for now - maybe Microsoft will have a fix for this failure soon.

 

LeicaIIf



#5
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,133 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

copy the folder C:\Windows\logs\CBS to the desktop, zip the folder and upload the zip to a cloud service, create a new topic about the setup failure and post a link to the zip. I'll take a look at it.


Posted Image

#6
LeicaIIIf

LeicaIIIf
  • Member
  • 5 posts
  • Joined 25-March 14
  • OS:Windows 8.1 x64
  • Country: Country Flag

Thanks Andre, but I did finally get the 8.1 update to install, and my USB 3 external hard drives work fine now.



#7
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,133 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

nice to hear this.


Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users