Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Can't install IE11


  • Please log in to reply
16 replies to this topic

#1
doveman

doveman

    Advanced Member

  • Member
  • PipPipPip
  • 375 posts
  • Joined 22-August 05

When my brother tries to install IE11 via Windows Update, it apparently reboots a couple of time and then says it's rolling back the changes as it's failed, so WU is stuck on that and doesn't show any recent updates.

 

I told him to try downloading IE11 manually and installing it that way but he reports that it did exactly the same thing.

 

He also has a problem with Foxit PDF reader not working in IE. It works fine in Iron Portable but in IE it just shows  a black cross top-left and the Addons don't even show anything for Foxit. Maybe this is related to his inability to update to IE11. I tried uninstalling and reinstalling Foxit but it didn't help.

 

I did a SFC /scannow and that reported 100% OK.

 

So does anyone know how I can fix this for him so that he can update to IE11?




How to remove advertisement from MSFN

#2
submix8c

submix8c

    Inconceivable!

  • Patrons
  • 4,547 posts
  • Joined 14-September 05
  • OS:none specified
  • Country: Country Flag

May or may not have something to do with it. Five Prerequisites?

http://www.msfn.org/...dated-12082014/

Google

"ie11" site:msfn.org
indicates some probs w/IE11.

Edited by submix8c, 13 August 2014 - 02:57 PM.

Someday the tyrants will be unthroned... Jason "Jay" Chasteen; RIP, bro!

Posted Image


#3
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,216 posts
  • Joined 28-August 05
  • OS:Windows 8 x64
  • Country: Country Flag

Donator

upload the folder C:\Windows\logs\CBS and the IE11Main.log from C:\Windows


Posted Image

#4
doveman

doveman

    Advanced Member

  • Member
  • PipPipPip
  • 375 posts
  • Joined 22-August 05

 

May or may not have something to do with it. Five Prerequisites?

http://www.msfn.org/...dated-12082014/

Google

"ie11" site:msfn.org
indicates some probs w/IE11.

 

I would have thought WU would take care of installing anything that's needed before installing IE11 but maybe it got in a bad state somehow.



#5
doveman

doveman

    Advanced Member

  • Member
  • PipPipPip
  • 375 posts
  • Joined 22-August 05

upload the folder C:\Windows\logs\CBS and the IE11Main.log from C:\Windows

OK, I'll grab them off his machine ASAP.



#6
doveman

doveman

    Advanced Member

  • Member
  • PipPipPip
  • 375 posts
  • Joined 22-August 05

Here's the files requested https://drive.google...dit?usp=sharing



#7
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,216 posts
  • Joined 28-August 05
  • OS:Windows 8 x64
  • Country: Country Flag

Donator

the servicing stack is busy  [HRESULT = 0x800f0902 - CBS_E_BUSY]:

2014-08-15 10:32:35, Info                  CBS    Cannot perform concurrent read operation while CSI transaction is on the way. [HRESULT = 0x800f0902 - CBS_E_BUSY]
2014-08-15 10:32:35, Info                  CBS    Failed to get inventory. [HRESULT = 0x800f0902 - CBS_E_BUSY]
2014-08-15 10:32:35, Info                  CSI    00000649@2014/8/15:09:32:35.065 CSI Transaction @0x12a4f0f0 destroyed
2014-08-15 10:32:35, Info                  CBS    Failed to get CSI Inventory [HRESULT = 0x800f0902 - CBS_E_BUSY]
2014-08-15 10:32:35, Info                  CBS    Failed to get component state. [HRESULT = 0x800f0902 - CBS_E_BUSY]
2014-08-15 10:32:35, Info                  CBS    Failed to get current state of the deployment [HRESULT = 0x800f0902 - CBS_E_BUSY]
2014-08-15 10:32:35, Info                  CBS    Failed to get Transaction State for package: Package_1_for_KB2978742~31bf3856ad364e35~amd64~~6.1.1.0, update: 2978742-1_neutral_LDR [HRESULT = 0x800f0902 - CBS_E_BUSY]
2014-08-15 10:32:35, Info                  CBS    Failed to get current state. [HRESULT = 0x800f0902 - CBS_E_BUSY]
2014-08-15 10:32:35, Info                  CBS    Failed to populate updates for package: Package_1_for_KB2978742~31bf3856ad364e35~amd64~~6.1.1.0 [HRESULT = 0x800f0902 - CBS_E_BUSY]
2014-08-15 10:32:35, Info                  CBS    Failed to add child package to the strategy [HRESULT = 0x800f0902 - CBS_E_BUSY]
2014-08-15 10:32:35, Info                  CBS    Failed to add child package to the strategy [HRESULT = 0x800f0902 - CBS_E_BUSY]
2014-08-15 10:32:35, Info                  CBS    Failed to add package: Package_for_KB2978742~31bf3856ad364e35~amd64~~6.1.1.0 [HRESULT = 0x800f0902 - CBS_E_BUSY]
2014-08-15 10:32:35, Info                  CBS    Failed to prepare starting packages [HRESULT = 0x800f0902 - CBS_E_BUSY]
2014-08-15 10:32:35, Error                 CBS    Failed to process single phase execution. [HRESULT = 0x800f0902 - CBS_E_BUSY]

cleanup WinSxS with disk cleanup and try again to install the IE11.


Posted Image

#8
doveman

doveman

    Advanced Member

  • Member
  • PipPipPip
  • 375 posts
  • Joined 22-August 05

Thanks. My brother is coming to visit for a week or so but I'll try that when he returns home and let you know how it goes.



#9
doveman

doveman

    Advanced Member

  • Member
  • PipPipPip
  • 375 posts
  • Joined 22-August 05

Sorry, only just had a chance to try this.

 

Well it cleaned up a lot of Windows Update files (about 3.75GB I think) and then I rebooted, even though it didn't tell me to. Trying to install IE11 failed again though. I forgot to collect the logs, so I'll do that next time I connect to his PC. I believe when he tried it before, it made him reboot and then went through the "Rolling back updates" procedure before booting and saying that the IE11 install had failed, whereas this time it just failed within Windows and didn't ask to reboot, so perhaps we're getting somewhere!



#10
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,216 posts
  • Joined 28-August 05
  • OS:Windows 8 x64
  • Country: Country Flag

Donator

I need the logs, other wise I can't see what is wrong this time.


Posted Image

#11
doveman

doveman

    Advanced Member

  • Member
  • PipPipPip
  • 375 posts
  • Joined 22-August 05

I need the logs, other wise I can't see what is wrong this time.

OK, got them now. https://drive.google...iew?usp=sharing

 

I thought I should hide IE11 in case it was preventing any subsequent non-IE related updates from installing but after hiding it and checking for updates, it didn't show anything so I guess it's already up-to-date apart from IE11.



#12
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,216 posts
  • Joined 28-August 05
  • OS:Windows 8 x64
  • Country: Country Flag

Donator

Windows tries to remove a component which is not installed:

2014-10-12 09:52:03, Error                 CBS    Failed. Attempted to uninstall a version of a non-driver component that is not installed, version: 0Xa000223f040c0, component: wow64_microsoft-windows-scripting-jscript_31bf3856ad364e35_10.2.9200.16576_none_0b12bc079bf4b5a3, owner: Microsoft-Windows-InternetExplorer-VistaPlus-Update~31bf3856ad364e35~amd64~~10.2.9200.16521.Internet-Explorer-amd64 [HRESULT = 0x80004005 - E_FAIL]

Run the checksur tool and look inside the checksur.log is everything was fixed:

 

http://technet.micro...779(WS.10).aspx

http://support.microsoft.com/kb/947821


Posted Image

#13
doveman

doveman

    Advanced Member

  • Member
  • PipPipPip
  • 375 posts
  • Joined 22-August 05

Run the checksur tool and look inside the checksur.log is everything was fixed:
 
http://technet.micro...779(WS.10).aspx
http://support.microsoft.com/kb/947821


Thanks, I'll try that later.



#14
doveman

doveman

    Advanced Member

  • Member
  • PipPipPip
  • 375 posts
  • Joined 22-August 05

Still not working I'm afraid. The checksur.log doesn't identify any errors: https://drive.google...iew?usp=sharing

 

(I had to copy the CBS.log file as it was locked and wouldn't let me add it to the ZIP otherwise, hence why it's CBS - Copy.log).



#15
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,216 posts
  • Joined 28-August 05
  • OS:Windows 8 x64
  • Country: Country Flag

Donator

the same file is missing. Download this update (http://support.micro...b/2829530/en-us), extract the MSU so that you get the CAB and install this CAB with DISM /Online /Add-Package.

 

Now the file should be there.


Posted Image

#16
doveman

doveman

    Advanced Member

  • Member
  • PipPipPip
  • 375 posts
  • Joined 22-August 05

the same file is missing. Download this update (http://support.micro...b/2829530/en-us), extract the MSU so that you get the CAB and install this CAB with DISM /Online /Add-Package.

 

Now the file should be there.

Awesome, thanks. That sorted it out. Nice to finally put that issue to bed :)

 

He still has an issue where PDFs don't open in IE11 and it just shows a black cross in the upper-left corner but I just uninstalled and reinstalled Foxit Reader and unticked the option "Open PDFs in Browser" so that they open in Foxit Reader when he clicks a link instead, so I'm not too bothered about that.



#17
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,216 posts
  • Joined 28-August 05
  • OS:Windows 8 x64
  • Country: Country Flag

Donator

nice to hear that it is fixed now :)


Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users