Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Windows/Microsoft Update Not Working on Windows 2000/XP/2003

- - - - - windows microsoft update not working

  • Please log in to reply
57 replies to this topic

#51
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,675 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag


Hello -- I can't find the file 
 
MicrosoftUpdateCatalogWebControl.dll
 
on my xp system -- do I need it to in addition to the downgrade of 
 

muweb.dll
 
Thanks
I wonder :unsure: which was the difficult part in:

But we now know it isn't necessary to downgrade MicrosoftUpdateCatalogWebControl.dll at all.
So, you can totally forget about it and just replace muweb.dll, OK?

:whistle:

jaclaz


Edited by jaclaz, Yesterday, 10:17 AM.



How to remove advertisement from MSFN

#52
fpefpe

fpefpe
  • Member
  • 4 posts
  • Joined 24-November 14
  • OS:XP Pro x86
  • Country: Country Flag

Thanks -- replace muweb.dll works !!



#53
dencorso

dencorso

    Iuvat plus qui nihil obstat

  • Supervisor
  • 6,026 posts
  • Joined 07-April 07
  • OS:98SE
  • Country: Country Flag

Donator

Sure it does!
 

to solve the problem temporarily, please downgrade muweb.dll to -> 7.6.7600.256


X86
http://download.wind...Other/muweb.cab

X64
http://download.wind...Other/muweb.cab



#54
b3270791

b3270791
  • Member
  • 5 posts
  • Joined 20-November 14
  • OS:XP Pro x86
  • Country: Country Flag

Hi^^

Restore the original dll!!1! The problem has been fixed!!1!

however, it seems works without a muauth.cab !!1!

bye ^^



#55
Dave-H

Dave-H

    Friend of MSFN

  • MSFN Sponsor
  • 854 posts
  • Joined 04-January 06
  • OS:98SE
  • Country: Country Flag

Confirmed!

:thumbup

Let's hope it lasts...............

:)


  • b3270791 likes this

Dual boot Windows 98SE SP2.1a and Windows XP Professional SP3.
Dual 3.16GHz X5460 Quad Core Xeons with 8GB RAM. ATI Radeon X850 Graphics 1920x1080 32 Bit Colour with Large Fonts.


#56
MrMaguire

MrMaguire

    Official User of Unofficial Updates

  • Member
  • Pip
  • 80 posts
  • Joined 30-April 14
  • OS:XP Pro x64
  • Country: Country Flag

I can also confirm that the issue has been resolved on both Windows XP and 2000

 

XP:

Microsoft_Update_Working_Again_26_11_14.

 

2000:

 

Microsoft_Update_Working_Again_2_26_11_1



#57
submix8c

submix8c

    Inconceivable!

  • Patrons
  • 4,383 posts
  • Joined 14-September 05
  • OS:none specified
  • Country: Country Flag

Well! Looks like MS probably got an earful from their customers, more than likely those businesses still using Server2k3. You could see they were hot under the collar for horking their WSUS Servers and Client Workstations. $ talks. ;)

 

Just for funsies, first chance I get I'll retest a "clean install" and see what happens.

 

Note: haven't tried putting the v257 one back yet but I trust that all is well as reported. :unsure:


Someday the tyrants will be unthroned... Jason "Jay" Chasteen; RIP, bro!

Posted Image


#58
b3270791

b3270791
  • Member
  • 5 posts
  • Joined 20-November 14
  • OS:XP Pro x86
  • Country: Country Flag
[CUT]

 

Note: haven't tried putting the v257 one back yet but I trust that all is well as reported. :unsure:

 

now, the WU service ad registred as new flag {2}, please read your log file "%windir%\WindowsUpdate.log"

2014-11-27	01:51:02:812	2276	a1c	COMAPI	-----------  COMAPI: IUpdateServiceManager::AddService2  -----------
2014-11-27	01:51:02:812	2276	a1c	COMAPI	  - Service ID = {7971f918-a847-4430-9279-4a52d1efe18d}
2014-11-27	01:51:02:812	2276	a1c	COMAPI	  - Allow pending registration = Yes; Allow online registration = Yes; Register service with AU = Yes
2014-11-27	01:51:02:812	2276	a1c	COMAPI	  - Authorization cab path = <NULL>

and read this -> http://msdn.microsof...9(v=vs.85).aspx

 

<cite>

AddService2

Registers a service with WUA without requiring an authorization cabinet file (.cab), and returns a pointer to an IUpdateServiceRegistration interface.

...

If you specify asfAllowPendingRegistration and asfAllowOnlineRegistration together, the update agent immediately attempts to go online to register the service. AddService2 returns S_OK if the registration succeeds. AddService2 returns a failure HRESULT value if the registration fails, but the update agent still attempts to register the service at a later time.

</cite>

 

and read into log file:

WU client internal API CClientCallRecorder::Register succeeds!!1!

 

before, when the service was down, the flag asfAllowPendingRegistration and asfAllowOnlineRegistration is not set

 

<cite>

If you specify neither asfAllowPendingRegistration nor asfAllowOnlineRegistration (in other words, if flags is either zero or asfRegisterServiceWithAU), you must specify a non-NULL path in the authorizationCabPath parameter. In this mode, AddService2 processes the cabinet file (.cab) and registers the service in the same way as IUpdateServiceManager::AddService.

</cite>

 

I think that: Microsoft update run fine until the COM server side subrutine have this flag value!!1!

PS... you can delete the file muauth.cabyou do not need, and will not be created

 

 

Let's hope it lasts...............

 

bye ^^


Edited by b3270791, Today, 08:10 PM.






Also tagged with one or more of these keywords: windows, microsoft, update, not, working

3 user(s) are reading this topic

1 members, 2 guests, 0 anonymous users


    ND22