Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Windows 2000 Professional on the Z97 Platform

- - - - -

  • Please log in to reply
2 replies to this topic

#1
bluebolt

bluebolt

  • Member
  • Pip
  • 90 posts
  • Joined 11-March 13
  • OS:Windows 2000 Professional
  • Country: Country Flag

I tested W2k Pro installation using an MSI Z97 PC Mate (LGA 1150) motherboard with an Intel i7-4790K CPU in the socket, and 4 x 2GB G.SKILL DDR3 1600 RAM (F3-12800CL9Q-8GBZL).

 

I ran the HFSLIP package provided by tomasz86.  Then I used nLite to integrate Intel’s August 2013 chipset installation INF and blackwingcat’s 8.9d AHCI SATA drivers (for the Series 9 processor), and to create the OS ISO, which I burned to CD.

 

As an experiment, I left the onboard serial port at its default setting (enabled); as expected, installation stalled at the message, “Setup is starting Windows 2000,” so I disabled the COM port (BIOS / Settings / Advanced / Super IO) and proceeded to a new attempt.

 

This worked, no surprise (based on previous experience with the Z87), and W2k Pro completed the text-mode phase of installation.

 

Next up was “Windows 2000 Professional Setup”: “Installing Devices”: “Setup is detecting and installing devices on your computer,” and a progress bar, which dead-stalled approximately a third of the way there.  I eventually forced off the computer.

 

Returning to the BIOS, I disabled Parallel Port and proceeded to a new attempt.  This time, W2k Pro finished “Installing Devices” and, once again, the game was afoot (evidently many of the problems associated with using W2k Pro on modern hardware can be taken care of by disabling extraneous onboard peripherals).

 

From there, Windows 2000 Professional presented the same problem as on previous Intel motherboard iterations, in that there is no USB function until you use your (PS/2) keyboard and Device Manager to direct the system to other USB drivers.  However, with the Z97 no “Series 9” USB driver presented during this step; instead, the system started out with “Standard Enhanced PCI to USB Host Controller” (but still no USB function), so I tried:

 

          -Generic USB Hub

          -Standard Universal PCI to USB Host Controller

          -USB 2.0 Root Hub

          -USB Root Hub

          -Standard Open HCD PCI to USB

 

Finally I returned to letting Windows Update have its try, and it still wanted Standard Enhanced PCI to USB Host Controller.  It was quite a roundabout process, but by some combination of these, positive USB function was eventually obtained.  Maybe experience will smooth out the sequence, but wow, practically had to beat the thing into submission…

 

Everything seems to work fine.  Remaining Problem Devices don’t amount to much: SM Bus Controller, Universal Serial Bus (USB) Controller, PCI Bus.  I’ll see how things work once the software is installed.

 

Incidentally, I also ran an alternate test without Intel’s Chipset Installation Utility drivers, instead putting BWC’s custom Intel Matrix Storage Manager 7.6 Series 9 and INF chipset cabinet files in the HFCABS folder of HFSLIP, before using nLite to add BWC’s 8.9d AHCI driver.  The resulting OS install turned out the same, except BWC’s doesn’t nag about the problem devices at every boot-up.

 

Attached File  W2k Z97.JPG   187.19KB   3 downloads


Edited by bluebolt, 31 March 2015 - 07:31 PM.



How to remove advertisement from MSFN

#2
AnX

AnX

    Fighting for the right to OS since 2010

  • Member
  • PipPip
  • 193 posts
  • Joined 20-June 12
  • OS:none specified
  • Country: Country Flag

Why not enable HT technology? Won't hurt to try.


Dual boot Windows XP SP3 x86 and Windows Vista SP2 x64.

AMD FX-8320 8-core CPU with Hyper 212 Evo, ASUS M5A99FX PRO R2.0 Motherboard, 8GB 1600 RAM, 60GB SSD (8.1) and 500GB HDD (XP), Sapphire R7 260X 2GB Graphics Card, 620W Seasonic S12II, CM HAF 912 case.


#3
bluebolt

bluebolt

  • Member
  • Pip
  • 90 posts
  • Joined 11-March 13
  • OS:Windows 2000 Professional
  • Country: Country Flag

Tested previously on Z77 and the marks took a nosedive.  Tomasz86 had warned me about that with W2k Pro…though I think BWC did report higher performance with HT however in one of his configurations.

 

The Z97 is just back from service, so I haven’t had the chance to do much else with it yet (of course it konked right in the middle of testing null “drivers” that Fernando was writing for it, so hopefully I can get that back on track, as I would prefer to de-list even the inconsequential “problem” devices). 

 

I would like to see some numbers with and without PAE, and when I test I’ll try HT as well and post those; like you say, won’t hurt to try.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users