Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Windows XP Interface Font Looks Different With nVidia Drivers Installe

- - - - -

  • Please log in to reply
6 replies to this topic

#1
MrMaguire

MrMaguire

    Designed for Microsoft® Windows® XP

  • Member
  • PipPip
  • 144 posts
  • Joined 30-April 14
  • OS:XP Pro x64
  • Country: Country Flag

I've noticed that there is something about the nVidia display drivers that slightly changes the interface font on Windows XP. It's only really noticeable if you use a theme with a visual style, and it only occurs if you're using an nVidia graphics chipset, Intel and ATI/AMD drivers seem to display Windows fonts exactly the way they are without the drivers installed.

 

image.png

 

Notice the "Start" font is thinner. Top is the default, bottown is with nVidia drivers.

I'd like to know what exactly has been implemented to cause this behavior, and if possible, reverse it. Is it antialiasing? This has bugged me for years. I've looked through the nVidia control panel and haven't found a setting that changes it yet.

 

Here's something that's curious: Using more than one monitor with these drivers disables whatever causes this font thinning.

This is definitely not something that has popped up recently, I've noticed this even on a Compaq EVO D500 computer from 2001, that had a period nVidia GPU in it.


Edited by MrMaguire, 21 May 2015 - 06:43 AM.



How to remove advertisement from MSFN

#2
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,925 posts
  • Joined 28-April 06
  • OS:Windows 7 x86
  • Country: Country Flag

Donator

I wonder if your DPI setting has changed.


MSFN RULES | GimageX HTA for PE 3-5 | lol probloms
tpxmsfn1_zps393339c1.jpg


#3
MrMaguire

MrMaguire

    Designed for Microsoft® Windows® XP

  • Member
  • PipPip
  • 144 posts
  • Joined 30-April 14
  • OS:XP Pro x64
  • Country: Country Flag

Nope. Still at 96.



#4
Tommy

Tommy

    Brooke's Tommy honey <3

  • Member
  • PipPipPipPip
  • 563 posts
  • Joined 19-February 10
  • OS:98SE
  • Country: Country Flag

I actually noticed this very same thing years and years ago and with me being a bit OCD on certain things, this really bugged me. nVidia GeForces always did this to me with the drivers installed but if it was just the standard Microsoft driver, it worked just fine. Maybe it's some sort of font smoothing?


Daily running Windows 2000 Pro SP4 and Windows 98 Second Edition

2dtzy51.png
stillwin9xmsfnbt0.png


#5
MrMaguire

MrMaguire

    Designed for Microsoft® Windows® XP

  • Member
  • PipPip
  • 144 posts
  • Joined 30-April 14
  • OS:XP Pro x64
  • Country: Country Flag

I've noticed this with at least GeForce and Quadro drivers. I'm guessing that it affects all nVidia drivers for XP.

 

It must be some kind of font smoothing or antialiasing or something. I've noticed consistently that it gets disabled with more than one monitor connected. So the question is: What changes or is disabled when more than one monitor is connected?

 

I'm hoping that it's not something that's built-in to the actual drivers, because that would probably be much more difficult to remove/disable.

 

It's a pretty useless feature, if you can even call it that. Given that it only seems to thin some of the on-screen fonts, and only on Windows XP/2003, and only with a visual style similar to Luna. Not to mention that XP and up support real font antialiasing that can be enabled with any graphics drivers.

 

Actually I might add that ClearType rendered fonts on XP with nVidia drivers, look exactly the same as they do with Intel/ATi drivers.



#6
Tommy

Tommy

    Brooke's Tommy honey <3

  • Member
  • PipPipPipPip
  • 563 posts
  • Joined 19-February 10
  • OS:98SE
  • Country: Country Flag

I'm thinking maybe antialiasing because the default font looks slightly choppy whereas the nVidia font looks nice and smooth, so that's kinda what I'm guessing.


Daily running Windows 2000 Pro SP4 and Windows 98 Second Edition

2dtzy51.png
stillwin9xmsfnbt0.png


#7
JodyT

JodyT

    Member

  • Member
  • PipPip
  • 283 posts
  • Joined 05-April 11
  • OS:none specified
  • Country: Country Flag

nVidia drivers have the Control Panel tool that can modify 3D and 2D rendering for smoothness at the cost of speed.  If you want better performance, it sets rendering to a slightly more jagged image.


  • Tommy likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users