Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

MultiBoot USB bootloader issues

- - - - - multiboot Bootable USB Bootloader Grub4dos syslinux

  • Please log in to reply
1 reply to this topic

#1
jmonroe0914

jmonroe0914
  • Member
  • 3 posts
  • Joined 09-February 14
  • OS:Windows 8.1 x64
  • Country: Country Flag

I've used WinBuilder (Win8.1SE v82) to build a custom PE/RE multiboot USB and I've added 4 ISOs to it and installed grub4dos (tried with bootice as well as RMPrepUSB), however I cannot get certain ISOs to boot as they hang at:

 

(hd0,0) 

FAT12 BPB found with 0xEB (jmp) leading the boot sector.

 

probed C/H/S = 80/2/18, probed total sectors = 2880

 

I've searched for hours on Google, however I can't find anything that references the cause of this.  I'm getting this error with a custom repair iso, and gparted (most recent amd64) is hanging, eventually kicking back to bootloader command line after ~5min or so.  PartedMagic (most recent from 2015.05.04) boots fine, as does the Comodo Rescue ISO.

 

The Win8.1SE build is setup to boot to BCD with an option for Win8.1SE, WinRE, and grub4dos.  Grub4dos then has several entries, 4 of which are ISOs added during the build.  All menu.lst entries are mapped to (hd32), which would be right for a CD and I was curious if this would be the cause of the issue since it's a flash drive.

 

I've tried partitioning the flash drive every which way, both through Win8.1SE and RMPrepUSB, but I can't seem to get gparted and the custom recovery iso, which contains both dos and linux utilities, to boot. 


Edited by jmonroe0914, 22 May 2015 - 04:48 PM.



How to remove advertisement from MSFN

#2
jaclaz

jaclaz

    The Finder

  • Developer
  • 15,467 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag

Well, you seem like attempting to use grub4dos without having a basic understanding of the mechanism underlying.

The mapping to (hd32) is not a "one-size-fits-all" solution, it may - at the most - be a "one-size-fits-most" one.

 

Right now Reboot.pro (which is the officially unofficial Western support board for grub4dos) is down or having "intermittent access" due to some network/server problem, but you can check temporarily these two via Wayback Machine:

https://web.archive....all-iso-images/

https://web.archive....r-0xff-mapping/

If the access is restored the links are:

http://reboot.pro/topic/8944-

http://reboot.pro/topic/5041-

and the guide here is OK:

http://diddy.boot-la...os/Grub4dos.htm

 

In order to get senceful assistance, you need to post your current menu.lst and the EXACT list of the .iso's you are trying to boot (if they are "standard") and the EXACT, DETAILED way the "custom .iso is built/created.

A number of "common" .iso's are supported but for some less common ones "special" tricks may be needed (or in some cases it could even be impossible to boot them as .iso and you will need to setup their contents "flat" or extract some bootloader, etc.) .

 

Additionally you want to become practical with the guide in the part that explains basic and command line usage in grub4dos.

http://diddy.boot-la...iles/basics.htm

http://diddy.boot-la...s/files/cli.htm

 

A menu.lst is more than anything else a kind of "batch file", just like you would do when putting together a batch script, you NEED to test sequences of commands on the command line and only once you have succeeded make them into the batch (or the menu.lst) as this way you get the grub4dos feedback or error  for each command.

 

Also please state the EXACT version of grub4dos you are using, or get a fairly recent one, if you used RMPREPUSB, the version of grub4dos contained in it, though if I recall correctly it is a slightly modified one, is OK. :)

 

jaclaz


Edited by jaclaz, Yesterday, 04:30 AM.






Also tagged with one or more of these keywords: multiboot, Bootable USB, Bootloader, Grub4dos, syslinux

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users