Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



oscareczek

AOE2 won't start on W98

Recommended Posts

Acer TravelMate 525TE, P3 700 MHz, ATi Rage M1 8 MB VRAM, 256 MB RAM, 98 was 98lited, DX7

When I start the game, intro movies appear and when it should show main menu, I get black screen instead and I need to kill the process via Ctrl+Alt+Del.

Share this post


Link to post
Share on other sites

Tell us more about AOE2: what are its system requirements, is there a demo available for download, etc.

Has it worked for you in the past on this or similar machines?

Check the ATI control panel for DX features that can be disabled or tweaked.

Try upgrading to DX8 or 9.

Share this post


Link to post
Share on other sites

Ok, first I'm sorry if I ask too stupid questions or give too obvious advices, but start from the simplest things?

Did you patch the game with the latest ones?
What are your desktop serrings (resolution, colors)? Some older games required me to turn down to 16 bit color palette to run properly.
Do you have some kind of IS software taht can possibly cause problems? Added AOE to whitelist?
Tried to run the game without the intro (which means moving away intro file from it's folder for a while)?
Does the game have any config.ini file where modify games settings? Maybe some default setting causes problems.

 

And last but not least, you have Win7 stated as your main OS in your profile, Uncle Google says it should work fine under new machines, maybe there's no need to use Win 98? ;)

@ jumper Wikipedia says:

Pentium 166 Mhz CPU, 32 MB RAM, 200 MB HDD

Share this post


Link to post
Share on other sites

Yes, AOE2 works on W7 (if you kill explorer.exe), but that's not a point - when I use W7 laptop, my mother has only that 98 machine.

Well, Kolekcja Klasyki version is already patched, isn't it? .-. Game automatically changes res and depth.

Windows 98 is the best AV - how can I accidentally get a virus for 98 today? So, no, nothing should disturb.

Game hangs after intro appears, I also tried deleting AVI folder - same thing.

None default settings (well, it's only two settings - volume and resolution, 800x600 by default) can causes problems.

Share this post


Link to post
Share on other sites

Well I had a problem with Hearts of Iron II game coming from one of Cenega's* editions, maybe they screwed something up? Maybe try to get some other game's version (eg. demo, as mentioned at beginnig) to check that.

Sorry, nothing else comes to my mind, seems to me like a situation where the game just doesn't like this specified configuration and for unknown reason and refuses to work.

 

*(Kolekcja Klasyki publisher, for rest  of  world information)

Share this post


Link to post
Share on other sites

I don't think it's a problem, but, well, I haven't tried Russian translation yet ;w;

EDIT: Tried, nothing changed.

Edited by oscareczek

Share this post


Link to post
Share on other sites

Not sure what the problem is. Do you have the latest graphics driver for your card? You can see if dxdiag detects any problems with your graphics. It also says 256-color resolution, so you can try playing with the color depth and seeing if it works. Sometimes Alt+Tabbing out of the game and back in causes it to redraw itself. Since the system requirements say that it needs 1024x768, you might try hooking up an external monitor. If all else fails, try reinstalling the game.

 

On an unrelated note, I just got SuperTuxKart 0.8 running smoothly on my Windows 98 machine! :)

Share this post


Link to post
Share on other sites

AOE requires 800x600, not 1024x768 (which I have), latest drivers from 2001, color depth is changed, Alt+Tab doesn't help at all, in dxdiag it's a problem with DirectDraw, but it passes all tests (?).

Share this post


Link to post
Share on other sites

If DxDiag reports an error in DirectDraw, that may very well be the issue. There's also a chance that you may be the proud owner of an incompatible video card. :( One other thing I might try is lowering the graphics hardware acceleration. I believe you can adjust that by going to the Display properties from the Control Panel (or Desktop right-click) and click the "Advanced" button on the "Settings" tab. It should open up another dialog box that has a slider to adjust the level of hardware acceleration. A 2D game like that won't take too much of a performance hit from using software rendering.

Share this post


Link to post
Share on other sites

Hmm... That's strange. There must be a bug in the Windows 98 drivers for that graphics card.

Nice to see that you've got it working, at least.  :thumbup

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×