Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Why I can't get gigabit LAN speed from my secondary PC?

- - - - -

  • Please log in to reply
2 replies to this topic

#1
grancharov

grancharov

    Newbie

  • Member
  • 41 posts
  • Joined 23-November 13
  • OS:Windows 7 x64
  • Country: Country Flag

Router TP-Link 1043 ND with Gargoyle firmware

NAS D-Link DNS-345

PC1: MB Asrock FM2 A88X+; CPU AMD A-10 6700; RAM 8 GB 1600; SSD Intel 520 + HDD Caviar green; OS 7 Home

PC2: MB Asrock ALiveNF7G-HD720p; CPU Athlon LE-1620; RAM 2 GB DDR2; HDD Hitachi

PC2 alternate: MB MSI 880GMA-E45; CPU AMD Phenom II X2 550; RAM 2 GB DDR3 1333; OS XP and Linux Mint

 

Cables are Cat 5E.

 

I have real speed up to 30 MB/s(240 mbit/s) from PC1 to NAS. But from PC2 the speed is not more than 8 MB/s(64 mbit/s) and in the network settings I see 100 mbit/s. On paper all three motherboards should be capable for 1 gbit/s theoretical.

Where is the problem?




How to remove advertisement from MSFN

#2
MHz

MHz

    Just simple

  • Member
  • PipPipPipPipPipPipPip
  • 1,689 posts
  • Joined 02-August 04
  • OS:Windows 7 x64
  • Country: Country Flag
Here are some specs gathered for your PC2 mainboards.

The ASRock mainboard has various versions. Later versions are Gigabyte LAN. If you have version 1.0 or 2.0, then no Gigabyte LAN.

http://www.asrock.co...7G-HD720p R1.0/
- Realtek PHY RTL8201CL
- Speed: 10/100 Ethernet
- Supports Wake-On-LAN
- Supports PXE

http://www.asrock.co...7G-HD720p R2.0/
- Realtek PHY RTL8201CL
- Speed: 10/100 Ethernet
- Supports Wake-On-LAN
- Supports PXE

http://www.asrock.co...7G-HD720p R3.0/
- Gigabit LAN 10/100/1000 Mb/s
- Giga PHY Realtek RTL8211B
- Supports Wake-On-LAN
- Supports PXE

http://www.asrock.co...7G-HD720p R5.0/
- Gigabit LAN 10/100/1000 Mb/s
- Giga PHY RTL8211B
- Supports Wake-On-LAN
- Supports PXE

The MSI mainboard is mentioned as Gigabyte though mentions at the bottom of the page that specs vary depending on area... , so could have different versions.

http://msi.com/produ...o-specification
- Realtek PCI-E GbLAN controller 8111DL
- Integrated Fast Ethernet MAC and PHY in single chip
- Supports 10Mb/s, 100Mb/s and 1000Mb/s
- Compliance with PCI-Express Bus specification v1.0a

These mainboards may have settings for the LAN speed in the Bios though I would expect 1000Mb/s as default.
Cat 5E cables are regarded as good for Gigabyte LAN.
If your Router is saying that the LAN adapter is 100Mb/s and you are sure it is a Gigabyte, then I would check if a Bios update is available. Check for a LAN and chipset updated drivers.

#3
j7n

j7n

    Advanced Member

  • Member
  • PipPipPip
  • 314 posts
  • Joined 18-December 06
  • OS:XP Pro x86
  • Country: Country Flag
Look the actual NIC chip up by its Vendor and Device ID, which you may be able to see on the BIOS POST screen or using AIDA64/Everest. For example, 11ab 4362 -> Marvell Gigabit Ethernet Controller. The modern chips are usually too small to read the markings on them without holding the board up close. The Windows driver might report the device confusingly as a "family controller", but will usually say if it's Fast or Gigabit "family".

Verify that the Speed & Duplex setting in the adapter's Advanced Settings is set to Auto-Sense or Auto-Negotiation to match the setting on the unmanaged switch on the other end. Try disabling Green Ethernet or EEE settings if they are present.

If both of PC2 and PC2-Alternate are verified Gigabit capable, connect them (or another computer) together with a short known-good patch cable to rule out a fault in the cable (a pair that's unused for Fast Ethernet). You didn't give a report on what the Alternate's link speed or throughput were.

A new PCI-E network would only cost around 14 euros. If Gigabit link comes up, test throughout with FileZilla FTP Server/Client instead of Windows file sharing, which is slower.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users