Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Windows 98 crashes if SATA drive is present

- - - - -

  • Please log in to reply
7 replies to this topic

#1
huguia

huguia

    Newbie

  • Member
  • 31 posts
  • Joined 20-March 12
  • OS:98SE
  • Country: Country Flag

I currently have a P4 with two drives: a 10GB IDE for Windows 98, and a 80GB SATA one where I intend to install Windows 2000.

Even though the computer boots normally when I turn it on without the SATA drive, when I connect the SATA drive, Windows 98 detects a new IDE controller (fifo) and then crashes, and I can't proceed as it halts the system and I have to reset.

Is there a way to fix this?




How to remove advertisement from MSFN

#2
jaclaz

jaclaz

    The Finder

  • Developer
  • 15,644 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag
Is the SATA bus/device (in the BIOS) set to "SATA" (or "AHCI") or in "IDE compatibility mode" (or similar)?

jaclaz

#3
huguia

huguia

    Newbie

  • Member
  • 31 posts
  • Joined 20-March 12
  • OS:98SE
  • Country: Country Flag

Is the SATA bus/device (in the BIOS) set to "SATA" (or "AHCI") or in "IDE compatibility mode" (or similar)?

jaclaz

It is set to SATA, not compatible mode. Because the setup is: One IDE drive, one SATA drive, one IDE CD-RW and one IDE DVD. If I set to compatibility mode, I would disable one of those.



#4
jaclaz

jaclaz

    The Finder

  • Developer
  • 15,644 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag

It is set to SATA, not compatible mode. Because the setup is: One IDE drive, one SATA drive, one IDE CD-RW and one IDE DVD. If I set to compatibility mode, I would disable one of those.

And you find it "queer" that Windows 98 has issues with that? :unsure:
As my good friend Mr.Spock would say:
Fascinating...

See if any of these help you:
http://www.msfn.org/...h-windows-98se/
http://www.msfn.org/...a-installation/
http://reboot.pro/to...nt351nt42000xp/

It is entirely possible that a specific "manufacturer" driver for your motherboard exists, you need to post the EXACT details of the hardware involved.

jaclaz

#5
huguia

huguia

    Newbie

  • Member
  • 31 posts
  • Joined 20-March 12
  • OS:98SE
  • Country: Country Flag

 

It is set to SATA, not compatible mode. Because the setup is: One IDE drive, one SATA drive, one IDE CD-RW and one IDE DVD. If I set to compatibility mode, I would disable one of those.

And you find it "queer" that Windows 98 has issues with that? :unsure:
As my good friend Mr.Spock would say:
Fascinating...

See if any of these help you:
http://www.msfn.org/...h-windows-98se/
http://www.msfn.org/...a-installation/
http://reboot.pro/to...nt351nt42000xp/

It is entirely possible that a specific "manufacturer" driver for your motherboard exists, you need to post the EXACT details of the hardware involved.

jaclaz

 

 

no, I am not finding it weird, it is expected. I don't even want to acess the SATA drive. I was just asking if there is a way to disable the SATA drive on Windows 98 so it is not detected and proceed with the normal boot process



#6
MrMateczko

MrMateczko

    Junior

  • Member
  • Pip
  • 57 posts
  • Joined 29-June 13
  • OS:none specified
  • Country: Country Flag

Maybe go into Safe Mode, and try to disable the IDE controller which is the SATA controller.

Or go to registry and try to delete/disable it manually.

Or try the NOIDE stuff.

 

Links for reference:

https://support.micr...en-us/kb/151911

https://msdn.microso...8(v=vs.85).aspx


Edited by MrMateczko, 03 July 2015 - 05:52 AM.


#7
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 10,008 posts
  • Joined 28-April 06
  • OS:Windows 7 x86
  • Country: Country Flag

Donator

Two things. First it is hard to tell exactly from the first post but it is worded as if you are connecting the SATA drive after the computer is turned on. Is this true or do you connect it prior to turning on the PC?

 

Second is that you can get an internal drive enclosure that has the ability to remove or undock a SATA drive. I know this would be more of a manual process but it could work for you. The one I have is this, although there are certainly other ones out there:

http://www.istarusa....hp?model=T-7-SA

If I don't want the drive detected, I just unlock it. The lock mechanism works in such a way that it will push the internal enclosure outwards from the bay itself, which will disconnect the drive from the SATA connection. You don't even need to take the drive out.


MSFN RULES | GimageX HTA for PE 3-5 | lol probloms
tpxmsfn1_zps393339c1.jpg


#8
submix8c

submix8c

    Inconceivable!

  • Patrons
  • 4,556 posts
  • Joined 14-September 05
  • OS:none specified
  • Country: Country Flag

Could you just disable the SATA Drive (set to "None" or something similar)? You may still get the SATA Controller showing.

:unsure: (Shot in the dark...)

 

But it "seems" to be that it's the the SATA Drive that's causing the headache but the fact that you're picking up the SATA Controller.

 

And I fully agree with jaclaz. You're giving no specifics. Some MoBo's require 1+3 / 2+4 SATA in Legacy (PATA) Mode, so it may be you simply have "something" connected wrong.


Someday the tyrants will be unthroned... Jason "Jay" Chasteen; RIP, bro!

Posted Image





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users