PROBLEMCHYLD

Windows 9x SSL Protocol WinSSLWrap 1.17 (Rev 05)

28 posts in this topic

I have revised the installer (Rev 01) to fix the error loading certificate. Enjoy

0

Share this post


Link to post
Share on other sites

Please find yourself another repository that actually allows RESUME and does not TIMEOUT the connections. The guy at htasoft does not care about us having last-century dial-up 14kB/s connections. I can't download that stupid 2.7MB file because there's no resume and my flaky GPRS connection drops randomly.

And please avoid Google and Microsoft at all costs. Maybe try CloudMe for us europeans.

0

Share this post


Link to post
Share on other sites

I have revised the installer (Rev 02) blackwingcat has fixed a bug in the Openssl SSE files. Users with SSE2 instructions can ignore this update. Enjoy.

 

@ Drugwash

 

I will upload to another repository for you.

Don't know if you will have better luck, but hope you do. Thanks

 

Links in first post.

Edited by PROBLEMCHYLD
0

Share this post


Link to post
Share on other sites

What about those of us without SSE at all?

0

Share this post


Link to post
Share on other sites

What about those of us without SSE at all?

I'm not sure if the files will work on Non-SSE machines, I can't test because all of my machines are SSE/2.

Maybe you can ask blackwingcat to patch for non SSE systems.

0

Share this post


Link to post
Share on other sites

@ Drugwash

 

I will upload to another repository for you.

Don't know if you will have better luck, but hope you do. Thanks

 

Links in first post.

Thanks for your efforts but the ge.tt link won't work at all, throws an XML error. Could be some issue with my browser's add-ons, but it doesn't matter - I ultimately managed to download from the primary location.

 

Looking through the main batch file I see the installer forces the installation of MFC70 and MSVCR70 in the %SYSTEM% folder. Some systems may have their own assortment of files that work best and such update may not be beneficial. Have you tested the package with other versions of the aforementioned runtime libraries, would it work correctly? If the current versions are not mandatory then it may be best to skip updating the runtime libraries when existing. Omitting the /Y parameter for EXTRACT.EXE will prompt the user to overwrite.

 

Not promising anything but someday I may try to build a downsized alternative installer.

0

Share this post


Link to post
Share on other sites

Looking through the main batch file I see the installer forces the installation of MFC70 and MSVCR70 in the %SYSTEM% folder.

Yes, the files are needed for proper operation. I haven't found any newer versions that works natively on Win9x. I put them in the system dir so other apps could use them instead of having 50 copies of the same files on a system that lacks hard drive space. The same files are included in SP3 and works on many systems. The files are original Microsoft, not modded etc... As of yet, haven't had any complaints about them causing trouble on systems. These files can also be downloaded from MDGx site, is where I got mines from. Glad you got to download it. Edited by PROBLEMCHYLD
0

Share this post


Link to post
Share on other sites

I didn't say the files would necessarily cause trouble, just that some people may want/need specific versions on their systems and overwriting them without prompt may upset them. Theoretically, anyway.

 

Apparently only WRAP.EXE needs the VC7 runtime. I'll see if it can be compiled with VC6 to avoid these requirements as soon as I figure out how to deal with the openssl code that's linked to. But that may take some time.

1

Share this post


Link to post
Share on other sites
On Wednesday, September 16, 2015 at 0:37 PM, Drugwash said:

 just that some people may want/need specific versions on their systems and overwriting them without prompt may upset them. 

Thanks for all your help

Edited by PROBLEMCHYLD
updated typos
0

Share this post


Link to post
Share on other sites

(Rev 03) Updated openssl 1.0.1t from blackwingcat

Link in the first post. Enjoy

Edited by PROBLEMCHYLD
0

Share this post


Link to post
Share on other sites

Rev 04

Updated OpenSSL v1.0.1u

Download in first post.

Edited by PROBLEMCHYLD
0

Share this post


Link to post
Share on other sites

Rev 05

Updated OpenSSL v1.0.2k

Download in first post

1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.