Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Show system files (explorer) but NOT desktop.ini (on desktop) ?


  • Please log in to reply
11 replies to this topic

#1
Ninho

Ninho

    Member

  • Member
  • PipPip
  • 167 posts
  • Joined 05-March 06
Here is a minor though annoying behaviour of the desktop, courtesy our friends at MS :
when the "show superhidden" folder in Explorer option is chosen, two annoying icons for
"Desktop.ini" are displayed on the windows 7 desktop. ISTM this is an oversight, our 
above mentioned friends should have grasped that while we may wish to see system files
in explorer views, we have no cause or desire for Desktop.ini (x2!) cluttering our desktops !

Is there a known manner of putting an end to this hmmm... feature ?
Manually putting the unwanted out of the view port (by switching to a higher screen resolution and back) did not work as I tried : Windows dutifully replaces the icons in full view ! 

I assume that programmatically positioning the icons out of view (by altering values in the registry)
would have the same (absence of meaningful) effect ? 

Is there a trick to get rid of the bug, like, either some "super-super" hiding flag for the desktop.ini_s,
or does it take hacking Windows dll_s ?

It would surprise me if nobody else saw this as an aggravation (which didn't happen in Win XP, I am sure.)

[Edited : typo in subject title]

Edited by Ninho, Yesterday, 10:48 AM.



How to remove advertisement from MSFN

#2
jaclaz

jaclaz

    The Finder

  • Developer
  • 16,047 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag

System.ini ? :w00t:

 

Desktop.ini :yes:  (twice, one for current user and one for the "public" desktop):

 

http://www.7tutorial...what-do-they-do

 

Unless you use custom icons for the folder you can delete them.

 

jaclaz



#3
Ninho

Ninho

    Member

  • Member
  • PipPip
  • 167 posts
  • Joined 05-March 06

Desktop.ini :yes:  (twice, one for current user and one for the "public" desktop):

 

Unless you use custom icons for the folder you can delete them.

 

 

I didn't write "system.ini" anywhere did I ? In any case yes it is about the files containing Desktop

customisation settings :  desktop.ini.

Yes I am aware their role is little more than cosmetic, but deleting them is but a poor work around

in last recourse for a standing bug (imho).


Edited by Ninho, Yesterday, 10:10 AM.


#4
bphlpt

bphlpt

    MSFN Master

  • Patrons
  • 2,030 posts
  • Joined 12-May 07
  • OS:none specified
  • Country: Country Flag

I didn't write "system.ini" anywhere did I ?


Just in the title of the thread. :)
 

Show system files (explorer) but NOT system.ini (on desktop) ?


Please edit the title to correct this.

And no, I know of no way to selectively display the system files. You either display them or you don't.

Cheers and Regards


Posted Image


#5
Ninho

Ninho

    Member

  • Member
  • PipPip
  • 167 posts
  • Joined 05-March 06
Ninho wrote: " I didn't write "system.ini" anywhere did I ?" ...
Bphlpt : Just in the title of the thread. :)

Please edit the title to correct this.


Done title editing! Duh... I really need some rest.

And no, I know of no way to selectively display the system files. You either display them or you don't.


At least in previous versions of Windows you could put them beyond the limits of the viewport. Is MS
trying to be /useful/ by bringing them back in full view against my will ! Really ?

Cheers and Regards as well///

Edited by Ninho, Yesterday, 10:57 AM.


#6
jaclaz

jaclaz

    The Finder

  • Developer
  • 16,047 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag

Yes I am aware their role is little more than cosmetic, but deleting them is but a poor work around

in last recourse for a standing bug (imho).

 

Sure it is a workaround (poor or not being debatable), the "feature" was implemented by the good MS guys "by design", you can sue them if you don't like it :w00t:.

 

And (still on the workaround) if you want the system to not recreate those files:

http://jamesisin.com...by-desktop-ini/

 

jaclaz



#7
Ninho

Ninho

    Member

  • Member
  • PipPip
  • 167 posts
  • Joined 05-March 06

... (still on the workaround) if you want the system to not recreate those files:
http://jamesisin.com...by-desktop-ini/[/url]

Very informative link, thanks ! How do you find all those ? Jaklaz, you must be aware
the Japanese have a concept of "living treasures", people truly irreplaceable for their
accumulated knowledge and/or experience. Well I vote you for MSFN's "living treasure" ;=)

#8
jaclaz

jaclaz

    The Finder

  • Developer
  • 16,047 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag

Very informative link, thanks ! How do you find all those ?

I am The Finder, there is a reason for that ;).

Jaklaz, you must be aware the Japanese have a concept of "living treasures", people truly irreplaceable for their accumulated knowledge and/or experience. Well I vote you for MSFN's "living treasure" ;=)

Thanks :), though being born modest (not all over but in spots ;)):
http://www.quotes.net/quote/39361
I would be very happy with just the "living" (for a looong time).
 
jaclaz

#9
Mcinwwl

Mcinwwl

    Newbie

  • Member
  • 28 posts
  • Joined 12-April 15
  • OS:XP Home
  • Country: Country Flag

(which didn't happen in Win XP, I am sure.)

 

@Ninho bad luck, just checked my XP Home, after unlocking visibility of both I have a cute little Thumbs.db file on my desktop. Not the double desktop.ini for sure, but still some some unnecessary crap become visible :D

 

UQ1ddcQ.png



#10
Ninho

Ninho

    Member

  • Member
  • PipPip
  • 167 posts
  • Joined 05-March 06

(which didn't happen in Win XP, I am sure.)

 

@Ninho bad luck, just checked my XP Home, after unlocking visibility of both I have a cute little Thumbs.db file on my desktop. Not the double desktop.ini for sure, but still some some unnecessary crap become visible :D

 

Yes but I think you can move the icon outside of the visible area and it'll stay there,

in effect, hidden. Try this experiment ; first check that your settings are not

to "align on grid" nor "reorganize automatically". Increase screen resolution, temporarily;

now frag the offending element to the right border (of larger resolution screen), finally

restore screen to its usual resolution : does thumbs.db not stay off screen ?



#11
submix8c

submix8c

    Inconceivable!

  • Patrons
  • 4,624 posts
  • Joined 14-September 05
  • OS:none specified
  • Country: Country Flag

I have (one, naturally) "DESKTOP.INI" on my Server2k3. With a dual-head Video Card I can' see how I caan move it to an "invisible" area. This is (as said) "by design". Just move it away from other desktop items and... IGNORE it!.

 

BTW - unticking "Align To Grid" does *not* make it totally invisible (in my case). It moves *most* of it but *some* remains (even two monitors).

 

edit - I guess I should mention, I generally use 800x600, occasionally changing to 1024x768, so BOOM! Visible again anyhow (until set back). WOOHOO! Kind of looks like your "solution" isn't even permanent? :unsure:


Edited by submix8c, Yesterday, 06:45 PM.

Someday the tyrants will be unthroned... Jason "Jay" Chasteen; RIP, bro!

Posted Image


#12
bphlpt

bphlpt

    MSFN Master

  • Patrons
  • 2,030 posts
  • Joined 12-May 07
  • OS:none specified
  • Country: Country Flag

 

(which didn't happen in Win XP, I am sure.)
 
@Ninho bad luck, just checked my XP Home, after unlocking visibility of both I have a cute little Thumbs.db file on my desktop. Not the double desktop.ini for sure, but still some some unnecessary crap become visible :D


Yes but I think you can move the icon outside of the visible area and it'll stay there,
in effect, hidden. Try this experiment ; first check that your settings are not
to "align on grid" nor "reorganize automatically". Increase screen resolution, temporarily;
now frag the offending element to the right border (of larger resolution screen), finally
restore screen to its usual resolution : does thumbs.db not stay off screen ?

 

 
 
WOW! And you called simply deleting the files as jaclaz suggested "a poor work around in last recourse for a standing bug (imho)"? I guess we all have our own definition of "work around" or "hack". :)

 

Cheers and Regards


Posted Image





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users