bigmuscle

ModernFrame replacement

117 posts in this topic

2 hours ago, bigmuscle said:

So here we have another experiment. Remove any DLL from AppInit_DLLs, disable LoadAppInit_DLLs, download the following archive, open the command line with admin rights and run this command:


Install:	regsvr32 ModernFrame-x64-Debug.dll
Uninstall:	regsvr32 /u ModernFrame-x64-Debug.dll

Then kill ApplicationFrameHost.exe, restart your computer or whatever :-)

http://glass8.eu/out/ModernFrame-x64dbg-2016-10-28.7z

It is DEBUG 64-bit version!!!!

I like that you are putting dates in the filenames.  Saves me having to do it when I save the file.

1.

InstallMF.png

2.

MFInAction.png

3.  Because SparkMan61 reported a problem after removal I tried unregistering the DLL, then rebooted.  I saw this when I tried to start the Settings App:

MFClassNotRegistered.png

By the way, the only thing I have left in AppInit_DLLs is UxTSB64/32.dll now.  I may have lost track as I've been busy with work lately...  Have you already made a non AppInit_DLLs test version of the UxTSB DLLs?

-Noel

0

Share this post


Link to post
Share on other sites
10 minutes ago, bigmuscle said:

Could you verify that it is fixed now? It will probably need restart after install/uninstall.

Link: http://glass8.eu/out/ModernFrame-x64dbg-2016-10-28a.7z

Tried again with the suffix a updated DLL from this afternoon.  It works as well as shown above, and the Class not registered pop-up is fixed.  After uninstall, Settings runs fine and looks like this:

NoMF.png

-Noel

0

Share this post


Link to post
Share on other sites

I recently installed Aeroglass on my 32 bit machine. Is there a modernframe.dll available for 32 bit? Can't find any info.

0

Share this post


Link to post
Share on other sites

Not that I know of - not yet anyway.  What's available is just what's on the download page.

Out of curiosity, and unrelated to ModernFrame, what makes you prefer a 32 bit system over a 64 bit system?

-Noel

0

Share this post


Link to post
Share on other sites

Thanks for the reply...I didn't think so...wasn't sure if I had missed something.

Not really a preference...just an older machine but it is still quite useful for me for some things. I also have 2 other machines that are 64 bit.

0

Share this post


Link to post
Share on other sites
1 hour ago, NoelC said:

Not that I know of - not yet anyway.  What's available is just what's on the download page.

Out of curiosity, and unrelated to ModernFrame, what makes you prefer a 32 bit system over a 64 bit system?

-Noel

Second sentence off-topic!<--a joke!  Actually, I've never seen modernframe on the download page (am I missing it?).  Always had to look through the thread about it to see what's going on, if anything.

Edited by genecooper
2

Share this post


Link to post
Share on other sites

ModernFrame is not on the download page, because it is not the official part of Aero Glass.

0

Share this post


Link to post
Share on other sites

Correct me if I'm wrong, Big Muscle, and not to be picky :) but I thought you included ModernFrame.dll in one of the Aero Glass releases at some point in the past.  As I recall it was delivered with an installer-based release but not included in the manual download file.

And of course there is the Experimental Versions download page where some things show up sometimes (and sometimes even more once we've logged-in).  That said, there's nothing there now.

Anyway, it's pretty cool that you've found a way to inject the DLL without using AppInit_DLLs.  Are you thinking of trying to go that route with UxTSB as well?  It's already possible to have a system that passes an SFC check (thank you for that), but it would be quite slick if it didn't log any warning at startup about AppInit_DLLs being loaded.

-Noel

Edited by NoelC
0

Share this post


Link to post
Share on other sites

This new ModernFrame.dll does something around using COM interfaces to get the job done, hence the need to register it using regsvr32. There is a new experimental build posted under UxTheme Signature Bypass thread, the aerohost.exe process injects the UxTSB.dll into explorer.exe and winlogon.exe.

Though with the old method, we also had 32-bit UxTSB.dll injected, which supposedly helps some 32-bit theme related applications to work correctly in combination with a custom theme. Personally, I don't know any such app so I have no clue how much of a drawback that fact is.

Edited by UCyborg
0

Share this post


Link to post
Share on other sites

Thanks.  I had an inkling that I may have missed an experimental UxTSB change, which is why I asked.

-Noel

0

Share this post


Link to post
Share on other sites

You're welcome. Must be why you haven't noticed the bug that happens when you log off. My RAM sticks are OK this time so I hope I'm not the only one that gets it. On the other hand, as BM said, the current way is hacky anyway so it'll be removed.

Edited by UCyborg
0

Share this post


Link to post
Share on other sites

It seems that the level of blur of AeroGlass has a direct influence on the covers in the modern app Groove, I have also noticed that when activated AeroGlass and opens the same application, some kind of lag occurs in the Windows animations, including the Start menu and when you minimize and maximize windows, I'm not sure, but I think it only happens with Groove. (build 14393.351):

Edit: after completely uninstall Aeroglass, I realized that the lag in start menu and Windows animation is not caused by the program, it is caused for the new view of the album covers in Groove after a recent update, when I use AeroglassGUI to reduce the blur in the album covers to zero, the lag decreases completely, definitely is a problem of the application and not of Aeroglass.

61a733b0194f2ac3f8e4b780d0b3bed8f9606ceb960c263666888fd5ac1d4a0d764efdd0ad169bf6af2b47efe1f2e6c986249efd18056e2ee1dec7a9

Edited by carlitosoo555
0

Share this post


Link to post
Share on other sites

I don't use Groove app, so I didn't even know that there is some blur effect. But about the performance, I can say that the blurred accent (= the default blur effect available in Win10 without my AG) is very poorly optimized, e.g. if you enable it on the taskbar, it becomes very laggy when you move windows behind it.

0

Share this post


Link to post
Share on other sites

This Version bigmuscle release 1 Weeks ago http://glass8.eu/out/ModernFrame-2016-10-22.7z it works only in build 321 if you will update it will still work on build 351 but if you reinstall a new fresh build 351 it will not work i hope a new version will release soon for 351 ohh btw I get the same issue @raiden89 :)

Edited by ZiyaadMuhammad
0

Share this post


Link to post
Share on other sites

This ModernFrame-2016-10-22.7z Arbeitet ein 351.

Ich selbst verwendet, um dieses ........

dddd.png

Edited by Painkilleraxel
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.