Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



Sign in to follow this  
NoelC

Why does SystemSettings.exe automatically start 5 minutes after logon?

Recommended Posts

Tripredacus    286

I have not been able to see either of those processes running in Task Manager in these scenarios:
- Pro 1511, Audit Mode, no internet connection
- Pro 1511, local user, no internet connection, not activated
- Pro 1511, local user, internet connection, not activated

I can try 1607, but I can't do a test with a system activated right now.

Share this post


Link to post
Share on other sites

NoelC    1,371

Thanks for checking.  That's good feedback.  It tends to make me think even more that it could have to do with one of the things I do that are fairly far off the reservation, e.g.,

  • Disable Windows Update service.
  • Disable Windows Firewall service (I have the 3rd party Sphinx firewall).
  • Disable a number of other services I don't believe I need.
  • Remove all Apps including Cortana.
  • Run with UAC disabled.
  • Use a local account.
  • A dozen other significant tweaks to try to undo most of what's "Modern" in Windows 10.

Thing is, this is no more than an annoyance as everything works.  I just don't understand what's starting SystemSettings then almost immediately having it go to Suspended status.

-Noel

Share this post


Link to post
Share on other sites
tfw2002    1

As a Windows user from Version 3.0, Win10 could've been better optimised without the Metro/Modern interface. Anyhow, there is a way to stop SystemSettings.exe from ever starting at startup. I will attach a copy of the modified registry entries for Win10 1703 64-bit. You will need to launch Regedit with TrustedInstaller permissions using PsExec or NSudo.

Save a copy of this registry location...

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsRuntime\ActivatableClassId

And compare with the attached tweaked version. This works with a local account, untested with a Microsoft account since I have no need to use one.

Hope this helps.

10actclsidsrs2.zip

Edited by tfw2002
Added additional info

Share this post


Link to post
Share on other sites
NoelC    1,371

Does that stop SystemSettings from running entirely?  Or just from being auto-started?

This behavior seems to be gone from version 1703 anyway, so it's kind of a moot point going forward.

-Noel

Share this post


Link to post
Share on other sites
tfw2002    1

Noel, it stops SystemSettings from starting up every 5 minutes after being killed and it doesn't start on startup. SystemSettings still starts up for me on the Creators Update around the 5 minute mark, so I took a deeper inspection in the registry to see what was causing it. The critical 3 keys are the SystemSettings ones under [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsRuntime\ActivatableClassId\] and delete the Activatable named entries.

  • Upvote 1

Share this post


Link to post
Share on other sites
NoelC    1,371

Wow, so the question becomes:  What have I done this time around to avert it?

Whatever it is, it's in my re-tweaker script.  The only difference this time around is that I did NOT choose to remove all the Apps, since updates start to fail if they're removed.  Having left them in, I did still kick the legs out from under the UWP table (e.g., by disabling the Unistack services).  It uses more disk space this way, and SearchUI.exe does run so it uses a tiny bit more memory and another process, but it's still silent online and is pretty well optimized for desktop operations.

Finding just how much one can carve back out and still end up with a viable, manageable system is the trick, isn't it?

-Noel

Edited by NoelC

Share this post


Link to post
Share on other sites
Rbert    1

Hi,  i extra register here because i also was searching for a solution (sorry for my bad english).

I hope that i have understand the problem correct. 

I think, i found the solution in the Dexpot-Forum (i use Dexpot and first i thought it is a Dexpot Problem)

In this Forum the user paracanary wrote here

Quote

disable superfetch in services and metro or microsoft apps do not preload. To disable, find superfetch and in properties choose disable. All problems solved.

I also changed in regedit HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters  "EnablePrefetcher" from 3 to 0 (i use a SSD)

My problem is solved. Hope it helps you.

Greetings

Edited by Rbert
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×