Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



calfmuscle

Can't Generate Key

Recommended Posts

calfmuscle    0

Hi All,

Just to get it out of the way yes i've read through the forums for a similar topic, yes I read the stickies, can't find any help for my specific issue. 

Aeroglass works fine on my windows 10 build, I donated and received the email, however when I sign in and try to generate the key the page just seems to refresh without actually adding a new key. I'm definitely adding the correct Machine ID and when I click generate the page flickers and nothing happens. It also still says "You have already generated 0 keys (3 remaining)". Tried this with all adblockers/popup blockers turned off, tried it in different browsers, tried it on a different machine. Any ideas? At this point surely it must be either an issue with my account or a problem with the glass8.eu website. 

Hope you can help. 

Thanks

Share this post


Link to post
Share on other sites

calfmuscle    0
16 hours ago, genecooper said:

Try a different browser, especially if you are using IE.  Try Firefox.

Thanks for the reply, however you seem to have missed the part in my original post where I stated I'd already tried different browsers. Getting the same issue on Chrome, Firefox, IE, Edge, and even safari on my friend's macbook. All have exactly the same problem. 

Are you sure the website isn't experiencing issues?

Share this post


Link to post
Share on other sites
bigmuscle    528

Hello, I tried on several computers with several OS and no problem - could you send me your login e-mail via PM so I can check it?

Share this post


Link to post
Share on other sites
bigmuscle    528

I tested your profile and there is no problem with it. The key can be generated and downloaded correctly.

Share this post


Link to post
Share on other sites
calfmuscle    0

Thanks for checking it, It seems to be partially working now - at least it's giving me an error message instead of nothing. It now says "Invalid key size.". I've tried both the PC Name (TOM-PC) as well as the Physical address of the PC in ipconfig (of the format XX-XX-XX-XX-XX-XX), both don't seem to work. Can you please explain what the Machine ID is supposed to be?

Thanks!

Share this post


Link to post
Share on other sites
groomp    6
15 hours ago, bigmuscle said:

Strange, I always though that the dialog box on the Aero Glass startup is noticeable, or isn't it?

BM I just did a test and moved my donation.key out of c:\Aeroglass and rebooted. On reboot I got no warning of no licence key or pop up dialog box displaying machine ID.

edit: scrap that, the dialog box was behind another window displaying the machine ID.

In the meantime calfmuscle you can copy the machine ID from c:\Aeroglass\debug.log (open it with notepad) to generate the correct key file.

Edited by groomp

Share this post


Link to post
Share on other sites
calfmuscle    0

I haven't been getting any errors on startup other than the "cannot hook your version" message which I assume is because I'm using this on Win10. No dialog box regarding license key or anything.

My debug.log is just full of this repeated over and over: 

[2016-08-07 21:16:28][0x910:0x1B0C] Installing DWM hook...
[2016-08-07 21:16:28][0x910:0x1B0C] User: SYSTEM
[2016-08-07 21:16:28][0x910:0x1B0C] Module: C:\Program Files (x86)\AeroGlass\DWMGlass.dll

Once for each startup. 

Any ideas?

Share this post


Link to post
Share on other sites
calfmuscle    0

Yep got it working fine now, had to fiddle around with GlassOpacity in the registry to get the proper effect working again (it was just giving me the windows 10 colour instead of clear glass) but the message is gone now, no popups on start, and my debug.log has the key recognised in it. 

Thanks for the help! Sorry it was something that I should have noticed in the guide. I spent so long looking at the registry part of it I think I just glossed straight past the first bit that says not to install in program files! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×