Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



MERCURY127

Launch of new Wi-Fi USB devices on 9x

Recommended Posts

MERCURY127    9

Hello! I many times try run my usb wifi dongle in 9x, and now, after four years owning this device, i can say - it work! 

u can look on my screenshots: 

Spoiler

erj604.png
r88c5j.png
2wd0k5f.png
rlayxj.png
2dtt1zk.png

in this post i want say, how u can do it for our devices... post will periodically updating. 

===== 

what need having for experiments: 

WDMEX from rloew. i am sorrry, but w/o this u need yourself implement one stupid function - NdisInitializeString. W/o this function driver RT2870.SYS (and many other drivers for 2k/xp) is just not starting - we see error code 2 or 10 in DM. 

So i assume, that u have implementation of NdisInitializeString. if so, can continue. 

one NdisInitializeString is not enuogh. driver req some other imports, which i can close old good WDMSTUB. 

after this, i check in debugger, that driver loaded w/o errors, and try using it with help Odyssey, but w/o good results. adapter was present in DM, but not present in Network Properties. then i try ME, and immediately get results! i connect to my router and can out in Internet. 

but on 98 it not work. Sweetlow say me, that support NDIS5 in 9x is poor, and recommend use NDIS3. i try, and all success. 

here i attach my work inf file for Ralink driver version 3.01.08.0000 date 27.Dec.2010. this driver work with Odyssey 4.52 and WPA2 AES. Most new version 5.01.25.0 from official site can not connect... 

this inf req UR work. U MUST manually add into VID/PID for our device!

DWA140.INF

Edited by MERCURY127
additions... at 25 December
  • Upvote 2

Share this post


Link to post
Share on other sites

MERCURY127    9

I know not how attach here my verified sys file - it's too big. I say u which need version, think u can find it... Also, need use 2k/xp file, not Vista / 7 or x64 variants :D

also, Odyssey can reject work, saying that can't connect with he's service. If so - try use kernelex and set ME mode on all exe files in Odyssey folder... 

Share this post


Link to post
Share on other sites
farfigs11    3

Glad to hear... I have the DWA-130.   However, I can't find  WDMex on Rloew's site to purchase.  I have the first three versions of the rt2870.sys file from 2007-all missing only NdisInitializeString.  I hope to use it with this utility(contains rt2870.sys driver also):    https://web.archive.org/web/20071110223821/http://www.airlink101.com/support/index.php?cmd=files&id=103

Share this post


Link to post
Share on other sites
dencorso    512
32 minutes ago, farfigs11 said:

However, I can't find  WDMex on Rloew's site to purchase.

Either PM or e-mail him. He'll get back to you real fast. :yes:

Share this post


Link to post
Share on other sites
rloew    87

My Catalog is for products that I think would be of general interest. It is by no means comprehensive.
I had not identified enough applications for WDMEX to put it in the Catalog.
If Mercury127's work opens up opportunities for it, I will add it to the Catalog.
In any case, it is available by name.

  • Upvote 1

Share this post


Link to post
Share on other sites
MERCURY127    9

here i write, that buy on aliexpress new wifi dongle, how say seller, based on rtl8188... its was delivered today, and i do some tests...

it's vid/pid is USB\VID_0BDA&PID_8179 (rtl8192eus), first founded product with match - TP-Link TL-WN725N Ver 2...

i get driver from TP Link. checked it on my win7, and it work. driver file is rtwlanu*.sys, not rtl8192su.sys, how i think. minimal wersion windows, that req in inf file, is XP. here is no 2K version. rtl8192su.sys is not work with this device absolutely.

rtwlanu.sys not req any unimplemented functions. i will try run it on 2k and me... but i have no hope. on 98 i already have code 2.

Share this post


Link to post
Share on other sites
MERCURY127    9

maybe, but on 2k this rtwlanu_xp.sys is not work also - code 31. i will find other versions rtwlanu..
=====
tried with 2k three diff versions of rtwlanu.sys. two - latest (5 mb size, 2016) and oldest (1 mb, 2012) give code 31. third (2012, released three month later) - bsod. its first time, when i see BSOD on 2k...

Edited by MERCURY127
addition

Share this post


Link to post
Share on other sites
MERCURY127    9

Have a little problem... Netcps speed test give max 800 000 bytes / sec. This match closest standart speed 6.5 Mbod 

40da70f4-4b3f-4a22-826d-d29e320a0099.jpg 

but with 7/xp this device work at link 150 mbod. Why it is not connecting at 150 on 9x? I use usb2 port. when i test ordinal 10 mbit pci ethernet card, i get 2000 kbytes / sec, so this is not limit of my p3 machine. 

Have any ideas? 

Share this post


Link to post
Share on other sites
LoneCrusader    94

I was able to duplicate Mercury's results with the same VID&PID RALINK device and using rloew's latest WDMEX. Successfully connected to a WPA2 network under 9x using the Odyssey Client as well. :D

  • Upvote 1

Share this post


Link to post
Share on other sites
cov3rt    2

does anyone know if odyssey client 4.56 is compatible with all wireless adapters for 98SE? i would like to use it instead of wsc gaurd 4.0 if it can do direct wpa2 support and support ALL cards where as with wsc gaurd 4.0 that only supports certain wireless cards, also odyssey client 4.56 is a little smaller in size, making it better for archived packaged contents for burning on a cd-r or cd-rw, also a little off topic but does anyone know if there is a lighter or more compact package for the unofficial service pack for 98SE? it has increased so much in size from all the versions, i don't need some of the packaged contents like office 97 or ie 5.5 core files, etc.

Share this post


Link to post
Share on other sites
MERCURY127    9

i possible found main problem.
when i test speed on 2k, OUTGOING speed is high - its match my UPLINK, 1.5 mbit, hundreds packets per sec, as show Odyssey.
but when i do test on 98, OUTGOING speed is low, very low - one-two packet per 10-20 sec!!!
why???
=====
it all was about iperf test. this test just stay w/o any progress. one time after manual abort it show me speed 4 bit (not kbit!) / sec.
but if i try connect to http or ftp site - i can download with speed 30-40 kbytes / sec. packets in Qdyssey runs at hundreds per sec...
very strange wifi under 98... :wacko:

Edited by MERCURY127

Share this post


Link to post
Share on other sites
MrMateczko    17

Aren't LAN/WiFi speeds under 98SE slow in general?

My nForce3 250 MoBo, ASRock K8Upgrade-NF3, with its built-in LAN controller, is quite rubbish in 98SE.

I have abysmal speeds, even after all the tweaks and patches I could found.

What's interesting is that, it will download fast, but after about 15 seconds, it slows down.

Also, M$ lies!

https://msdn.microsoft.com/en-us/library/windows/hardware/ff559027(v=vs.85).aspx

It says 98SE supports NDIS5 (which might help with speeds), but in reality, I haven't found any 98se network driver which uses ndis5, all of them uses ndis3. Some ME drivers do use ndis5 though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×