Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

Katsinwater

Aero Glass for Win8.1+ v1.5.2

Recommended Posts

Natsu    0
On 2017/1/30 at 1:17 AM, UCyborg said:

Must be a regression. I can reproduce the bug with text being too far to the left by turning off caption glow effect. Use atlas image options work correctly.

AGTextCaptionGlowOn.png

AGTextCaptionGlowOff.png

Thank you very Much !

Share this post


Link to post
Share on other sites
Lum    0

So today my AeroGlass switched back to the free version with nag screen and watermark (and a different machine key), happened when I used "Turn windows features on or off" to remove Hyper-V, and I don't think that should happen

and for added bonus, the glass8.eu site is gone, so I can't even make myself a new key. What now?

Share this post


Link to post
Share on other sites
Lum    0

It's back now, but it was a domain parking page yesterday. Will sort out my licence next time I reboot :)

Share this post


Link to post
Share on other sites
Tusticles    21

No chance to fix this?

Text position is messed up when using 'theme settings'  for 'Caption glow effect mode'

Ypvq49P.png

Text seems fine with 'atlas image' or 'atlas image and theme settings '  but I prefer the blur applied by 'theme settings'

EOln6t6.png

Also, the blur goes outside the titlebar on tool windows or windows with no caption icon when using 'atlas image' or 'atlas image and theme settings ' 

Share this post


Link to post
Share on other sites
UCyborg    70

@Lum
Strange, Hyper-V presence shouldn't change hardware ID. At least it doesn't happen on my end.

@Tusticles
Which theme you're using that has this type of glow you get in the first screenshot?

Share this post


Link to post
Share on other sites
Tusticles    21
1 hour ago, UCyborg said:

@Tusticles
Which theme you're using that has this type of glow you get in the first screenshot?

A modified version of aero 7

The glow is already there. I just changed a few resources, like shadows, borders(bottom, left, right, top) etc and enabled the blur globally

w9hLFTx.png

and changed aero glass settings to

Qklmt7x.png

I wish I could use it but the text position is messed up...

--edit--

Seems to work for Paint.NET window only

QvjWMbn.png

Edited by Tusticles
  • Upvote 1

Share this post


Link to post
Share on other sites
UCyborg    70

@Tusticles
Thanks for the hint! I found the most important properties are under Windows & Captions Buttons -> Aero -> Window.

We can only hope that at least bugs in Aero Glass will be fixed sometime.

Edited by UCyborg

Share this post


Link to post
Share on other sites
UCyborg    70

Correct settings in .msstyles really gives you working composited text glow. Aero Glass GUI "Use theme settings" option with theme defined text glow size is also the most consistent variant because the text caption text will be look identical across application, whether they use plain window frame or draw their own controls on it before drawing caption with DrawThemeText API.

Unless for example you want custom colored caption text. But I think it boils down to the fact that these things are unofficial extensions that were never intended by Microsoft so the original design doesn't account for them. Glow effect baked in theme atlas image you get with "Use atlas image" is also Aero Glass exclusive concept if I'm not mistaken.

There is another issue with "Use theme settings" on 1.5.2 besides being rendered at incorrect position. Setting glow size to 0 means 0 instead of theme defined size.

Share this post


Link to post
Share on other sites
Klamatiel    5

Windows updated, 14393.953, DWM doesn't know how to hook (0x5). AG works correctly though.

[2017-03-14 20:54:56][0x35C:0x12A8] DllGetClassObject CLSID {DDC05A5A-351A-4E06-8EAF-54EC1BC2DCEA}, IID {00000001-0000-0000-C000-000000000046}
[2017-03-14 20:54:56][0x35C:0x12A8] Hook (USER32.dll!CreateWindowInBandEx from ApplicationFrame.dll) installed
[2017-03-14 20:54:56][0x35C:0x12A8] Delayed hook (ext-ms-win-ntuser-window-l1-1-1.dll!CreateWindowExW from ApplicationFrame.dll) installed
[2017-03-14 20:54:56][0x35C:0x12A8] Hook (GDI32.dll!StretchDIBits from ApplicationFrame.dll) installed
[2017-03-14 20:54:56][0x35C:0x12A8] DllGetClassObject CLSID {DDC05A5A-351A-4E06-8EAF-54EC1BC2DCEA}, IID {00000001-0000-0000-C000-000000000046}
[2017-03-14 20:55:11][0x1B4:0xE70] DWM incompatibility error 0x5
 

Share this post


Link to post
Share on other sites
dna-systems    10
10 hours ago, Klamatiel said:

Windows updated, 14393.953, DWM doesn't know how to hook (0x5). AG works correctly though.

[2017-03-14 20:54:56][0x35C:0x12A8] DllGetClassObject CLSID {DDC05A5A-351A-4E06-8EAF-54EC1BC2DCEA}, IID {00000001-0000-0000-C000-000000000046}
[2017-03-14 20:54:56][0x35C:0x12A8] Hook (USER32.dll!CreateWindowInBandEx from ApplicationFrame.dll) installed
[2017-03-14 20:54:56][0x35C:0x12A8] Delayed hook (ext-ms-win-ntuser-window-l1-1-1.dll!CreateWindowExW from ApplicationFrame.dll) installed
[2017-03-14 20:54:56][0x35C:0x12A8] Hook (GDI32.dll!StretchDIBits from ApplicationFrame.dll) installed
[2017-03-14 20:54:56][0x35C:0x12A8] DllGetClassObject CLSID {DDC05A5A-351A-4E06-8EAF-54EC1BC2DCEA}, IID {00000001-0000-0000-C000-000000000046}
[2017-03-14 20:55:11][0x1B4:0xE70] DWM incompatibility error 0x5
 

I just got the same thing too..  updated to .953 and received the infamous "hook" error.

Share this post


Link to post
Share on other sites
Cris_    4

Build AeroGlass .834,  Windows 10.0.14393.953 x64.
Same error

[0x210:0x116C] DWM incompatibility error 0x5

Edit: Sorry, needed 2 reboots but AeroGlass still injected!

ScreenShot - Info 240.png

Edited by Cris_
  • Upvote 1

Share this post


Link to post
Share on other sites
Prado    1
18 minutes ago, Cris_ said:

Build AeroGlass .834 works without any issue here after the Windows updates yesterday!  ^^ Windows 10.0.14393.693 x64.


[2017-03-15 11:02:17][0x21DC:0x1F58] Machine ID: WHB4W4LJU7ZIILHAYWBFxxxxxXLPOXVBMLDC2YQLLBT6DVY
[2017-03-15 11:02:17][0x21DC:0x1F58] Checking key 90c84977565c768ab126bxxxxx70f430a2c6797f56ebb8aca097b98927858dxxxxx798df7136a1454e6557a8ca470a for ID WHB4W4LJU7ZIILHAYWBFxxxxxFXLPOXVBMLDC2YQLLBT6DVY...
[2017-03-15 11:02:17][0x21DC:0x1F58] DllGetClassObject CLSID {DDC05A5A-351A-4E06-8EAF-54EC1BC2DCEA}, IID {00000001-0000-0000-C000-000000000046}
[2017-03-15 11:02:17][0x21DC:0x1F58] Hook (USER32.dll!CreateWindowInBandEx from ApplicationFrame.dll) installed
[2017-03-15 11:02:17][0x21DC:0x1F58] Delayed hook (ext-ms-win-ntuser-window-l1-1-1.dll!CreateWindowExW from ApplicationFrame.dll) installed
[2017-03-15 11:02:17][0x21DC:0x1F58] Hook (GDI32.dll!StretchDIBits from ApplicationFrame.dll) installed
[2017-03-15 11:02:17][0x21DC:0x1F58] DllGetClassObject CLSID {DDC05A5A-351A-4E06-8EAF-54EC1BC2DCEA}, IID {00000001-0000-0000-C000-000000000046}
[2017-03-15 11:02:44][0x2578:0x2934] Machine ID: WHB4W4LJU7ZIILHAYWBFxxxxxFXLPOXVBMLDC2YQLLBT6DVY
[2017-03-15 11:02:44][0x2578:0x2934] Checking key 90c84977565c768ab126xxxxxd70f430a2c6797f56ebb8aca097b98927858xxxxxc44798df7136a1454e6557a8ca470a for ID WHB4W4LJU7ZIILHAYWBFxxxxxFXLPOXVBMLDC2YQLLBT6DVY...
[2017-03-15 11:02:44][0x2578:0x2934] Hook (USER32.dll!DrawTextW from udwm.dll) installed
[2017-03-15 11:02:44][0x2578:0x2934] Hook (GDI32.dll!CreateBitmap from udwm.dll) installed
[2017-03-15 11:02:44][0x2578:0x2934] Hook (GDI32.dll!CreateRoundRectRgn from udwm.dll) installed
[2017-03-15 11:02:44][0x2578:0x2934] Aero Glass for Win8.1+ 1.5.2.848 x64 correctly loaded (C:\Optik\AeroGlass\DWMGlass.dll).
[2017-03-15 11:02:44][0x584:0x588] C:\Optik\AeroGlass\DWMGlass.dll has been injected into dwm.exe.
[2017-03-15 11:02:45][0x2578:0x24CC] DBGHELP: Symbol Search Path: .;SRV*C:\Optik\AeroGlass\symbols*http://msdl.microsoft.com/download/symbols
[2017-03-15 11:02:45][0x2578:0x24CC] Loading settings (flags = 0x3) from HKEY 0x00000000000005CC for session #5
[2017-03-15 11:02:45][0x2578:0x24CC] dwmcore.dll version 10.0.14393.479
[2017-03-15 11:02:45][0x2578:0x24CC] udwm.dll version 10.0.14393.0

. After yesterday's updates, the build of Windows rises to version 14393.953.

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×