Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



Sign in to follow this  
DarrenA

Registry Hack to prevent Win98 "Advanced Startup menu" from ever running

Recommended Posts

DarrenA    0

Hello, I was directed to this group in hopes to have a question answered. I have a PC in a arcade type environment, the PC is running Windows 98 SE. And as it is in a Arcade Cab, I can not "shutdown" the PC with the start button.

I have it set to scandisk every start to check for errors ect...

But windows wants to run the Advanced Startup menu when it detects a improper shutdown. This is not acceptable.

How can I force Windows to boot "normal" every time even if it gets improperly shut down?

Share this post


Link to post
Share on other sites

MrMateczko    17

Hmm...I guess you are talking about the one when it defaults to the Safe Mode, if Windows failed to load.

I don't think it can be removed altogether, but try this workaround (if it works at all, never tested it)

In MSDOS.SYS add/edit these under the [Options] section:

BootMenu=1

BootMenuDefault=1

BootMenuDelay=1

It will load Windows in one second, while displaying the Boot Menu every time...now the question is...will this override the "failed load" boot menu...:/

Edited by MrMateczko

Share this post


Link to post
Share on other sites
DarrenA    0

Thank you I will give it a try. I know win95 did not have this issue (as far as I can tell) Not sure if there was a patch for that but win95 never posted to the Safe mode screen when it was improperly shut down. I am not sure if that had anything to do with tweakUI installed on it or now.  But I know win XP and up can be edited to stop that from happening.

Share this post


Link to post
Share on other sites
jumper    53

In MSCONFIG.EXE, General->Advanced...->Disable Scandisk after bad shutdown.
Also TweakAll.exe, Boot Options->Automatically run Scandisk: Never.
(These probably set the "AutoScan=0" in MSDOS.SYS.)
This should ignore the bad shutdown and do a normal startup. Add Scandisk to your autoexec.bat to always run it regardless of how the system was shutdown.

In MSDOS.SYS:
[Options]
AutoScan=0
bootmenu=0


Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×