Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



ruthan

Seaching for Intel 218V XP 32bit driver

Recommended Posts

ruthan    1

Hello,
i have managed boot Windows Xp and Geforce 970, but i need also some Audio and Lan driver, and using USBtoLAN adapter as backup and without sounds gaming boring, i had MSI board MSI Z97 Gaming 7 where all these things working, but wasnt available, so i have bought Asrock Z97 Extereme 4/3.1

  Yes i could use also USB audio or soundcard, but switching is annoying.

Update:
Realtek HD 2.74 seems to work fine, so only LAN driver is needed.

Edited by ruthan

Share this post


Link to post
Share on other sites

ruthan    1

Its somehow possible use driver for other or similar device just by change some IDs? Its just Lan card, i dont have problem pay some bucks for driver.

 

Its possible somehow hack other driver to use it with this card?

Edited by ruthan

Share this post


Link to post
Share on other sites
Plosa    3

Try this Intel driver:

https://downloadcenter.intel.com/download/24555/Intel-Ethernet-Drivers-for-Microsoft-Embedded-Operating-Systems

It says "for XP Embedded" but it (obviously) works just fine on regular XP.

Extract from the readme file (DriverSelectionGuide.txt):

Quote

For these devices use the e1d driver:
    By Device ID:
        153A, 153B, 155A, 1559
    By Product Name:
        Intel(R) Ethernet Connection I217-LM
        Intel(R) Ethernet Connection I217-V
        Intel(R) Ethernet Connection I218-LM
        Intel(R) Ethernet Connection I218-V

Good luck!

Share this post


Link to post
Share on other sites
ruthan    1

Device ID 15A1.

I have tried driver e1d above, i was able to install it, but it was not working - exclamation mark, after reboot - Start could not be started.

 

I have invested a lot of time so not networking without some coding (i dont know if just some inf editation could be enough)

Edited by ruthan

Share this post


Link to post
Share on other sites
ruthan    1
Quote

try Snappy Driver Installer

https://sdi-tool.org/download/

worked for me

Worked for this NIC and Windows XP, or its generic experience?

Update: In this package is not driver for Intel 218-V, so we still need a help.

I also checked blackwing driver for Windows 2000 - its not working for me - device start error(10).

Edited by ruthan

Share this post


Link to post
Share on other sites
ruthan    1
Quote

You still need help?


  If you are able to fix driver, yes i do.

Share this post


Link to post
Share on other sites
Damnation    10
15 hours ago, ruthan said:


  If you are able to fix driver, yes i do.

can you grab the device ID for the problem device from device manager?

Share this post


Link to post
Share on other sites
ruthan    1

HardwareID is:
PCI\VEN_8086&DEV_15A1&SUBSYS_15A11849&REV_00

 Error, i cant now reboot because im doing something else, but problem is simply that driver could be installed, but after reboot there is exclamation mark and network is not working,
if im not working error message say something about, that device could be started.
 

Share this post


Link to post
Share on other sites
ruthan    1

I on other location so i have to use other MB with same Intel 218-V controller, device ID is now:

PCI\VEN_8086&DEV_15A1&SUBSYS_78851462&REV_05

With this board its not working.

  When i point Device manager to folder with driver, driver is installing, but device name is work, i press install anyway (not signed driver) and after installation there is error, that searched line was not found in the inf file.

Edited by ruthan

Share this post


Link to post
Share on other sites
Damnation    10
6 hours ago, ruthan said:

I on other location so i have to use other MB with same Intel 218-V controller, device ID is now:

PCI\VEN_8086&DEV_15A1&SUBSYS_78851462&REV_05

With this board its not working.

  When i point Device manager to folder with driver, driver is installing, but device name is work, i press install anyway (not signed driver) and after installation there is error, that searched line was not found in the inf file.

Made some edits to .inf

https://ufile.io/4p5ly

please try it

Share this post


Link to post
Share on other sites
ruthan    1

Thanks, im on work trip so give me 2 days, or perhaps someone with same NIC, could test it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×