Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

98SE

DOS and 9X/ME on Z77 Test

Recommended Posts

98SE    7

Installing DOS and 9X/ME on Z77 for legacy testing.  I will be documenting compatibility of DOS and 98SE programs on Intel Z77 Chipset.

 

Edited by 98SE

Share this post


Link to post
Share on other sites
98SE    7
On Wednesday, June 21, 2017 at 10:58 PM, 98SE said:

Installing DOS and 9X/ME on Z77 for legacy testing.  I will be documenting compatibility of DOS and 98SE programs on Intel Z77 Chipset.

Original Ramdisk Franck Uberto Ramdisk v1.9i - 8-12-1998 - XMSDSK.EXE and EMSDSK.EXE

working in 98SE DOS boot disk.

.

Fresh install of Windows 98 Second Edition completed to desktop completed all features selected.

Edited by 98SE

Share this post


Link to post
Share on other sites
98SE    7

98SE works with over 512MB installed without modifying Windows system files or memory patching.

Tried using a Blu-ray SATA drive can copy files but strange behavior when a disc is left in tray when loading into Windows.

Share this post


Link to post
Share on other sites
98SE    7

PS/2 Keyboard Port - working PS/2 Keyboard

USB Keyboard works on USB 2 rear ports no drivers.

USB Mouse control failure on USB 2 rear ports no drivers.

VIA USB 2 card functional drivers - USB mouse working, USB keyboard working, USB storage not working

NEC USB 2 card functional drivers - USB mouse working, USB keyboard working, USB storage not working

USB mouse can't operate on USB 3 ports.

USB keyboard can't operate on USB 3 ports.

Share this post


Link to post
Share on other sites
98SE    7

Ensoniq PCI Sound card tested audio works for regular sound effects.

There was a MIDI wavetable issue now I have patched it for 2MB, 4MB, and 8MB options.

Canyon.Mid and Passport.Mid worked.

Testing of 98SE DOS Prompt running DOS Games, DOS BOX Sound Blaster Emulation, and MAME testing next.

 

Result:

Dos Prompt running DOS Game works

DOS BOX works

MAME works

 

Issues:

Ensoniq PCI card sometimes flakes out need to test other modern sound cards.

 

Edited by 98SE

Share this post


Link to post
Share on other sites
ragnargd    12

When cards produces instability on AM3+ - like when NVidia-driver is installed, but also with SB Audigy - i found RLoews Interrupt-Fix to be the solution. If the situation is comparable (and only IF), maybe this is worth trying on Z77/Z68/P67 as well?

Share this post


Link to post
Share on other sites
98SE    7

Creative Labs uses IRQ5 for the newer sounds cards.

The SB Live is working it's the Ensoniq that couldn't handle multiple audio streams at once.  I ran 6 simultaneous files with continuous playback while using Mame and DOSBOX.

 

 

Share this post


Link to post
Share on other sites
jumper    55

Ensoniq might be sharing an IRQ with the HDD controller. If playing the files from ramdisk or USB works, changing the IRQ or using RLoew's Interrupt-Fix could be the solution.

Share this post


Link to post
Share on other sites
98SE    7

Both cards used IRQ5 so that isn't the problem or the SB Live would have had the same issues.  Last few days it seems stable.  SB Live definitely is a better choice.  I had spent a whole day on the Ensoniq and I think that's enough.  I'm still testing with DX 6.1a which I believe was the original version that came with 98SE.  I am planning on testing 7.0, 8.0, 9.0 later to see if that changes anything but SB LIVE drivers might be more stable and has support for XP+.

Share this post


Link to post
Share on other sites
98SE    7

Tested nVidia GeForce 7600 GS PCIe 256MB

82.69 modified - installed but failed to black screen on desktop.

 

Will test McKracken drivers next.

"http://www.msfn.org/board/topic/97786-geforce-67-and-8-agppci-e-driver-edition-for-win98me-by-zak/"

 

Edited by 98SE

Share this post


Link to post
Share on other sites
rloew    90

My Interrupt Fix only solves problems where the Mouse freezes, jerking once every 15 seconds, along with shutdown of other devices sharing the Video. not Mouse, interrupt, such as disk drives.

The 7600GS might need the PCI Patch in my NVSIZE Package.

Nothing new in the McKracken package. Try reading the entire thread.

Share this post


Link to post
Share on other sites
98SE    7

Tested nVidia GeForce 7600 GS PCIe 256MB - McKracken drivers failed

nVidia GeForce 8500 GT PCIe 256MB - failed

nVidia GeForce FX 5500  PCI 128MB - failed

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×