Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

ruthan

Win98SE debug,normal boot freezing + Rloew patches (RAM/SATA/NVSIZE/AHCI) installation debugging, NVU 82 drivers

Recommended Posts

ruthan    1

@rloew: Thanks for reply.

   Hmm, i didnt get that so called Sata patch, is actually not for classic classic vanilla Sata, but only for special cases like - like MB with Sata controller and IDE or RAID mode, external controller Sata controllers etc.. 
   Because with AMD 97 have tried - only controller in AHCI mode with patch.. Because i dont want to use IDE mode with modern OS, where i want to use full speed of Sata III and that i one of reasons why i even bough the patch. Yeah you can said that i can use different disk for differrent OSes, but its annoying.
 
  One clarification, i dont care about real AHCI things like NCQ, TRIm etc, i care only write / read performance in Win98x, without patch is 1 MB/s and freezes during file operation make new HW retromachine dont useful. 

Ok, so have i last version of Sata.inf - i have version from 2009?

  Ok so i how i turn off AHCI on my external Sil 3512 controller? Because this is only supported scenario.. and i dont know how to set this - AHCI off mode, i refer to this:

Quote

 AHCI off. This is the only scenario where ATA0106.INF would work with my SATA Patch without other programs or Drivers. So far, only one cheap Laptop actually worked this way.

Quote

remove the "NOIDE" Entry from the Registry.

   Could you describe it in more detail? I tried to search for this entry in Registry and a i deleted something and Windows stopped booting.

Terabyte patch - I have bad memory but i think that i bought it together with Sata patch, im sure that i dont stole it - im sure that its your patch, or at least demo, timestamp is 2008.

RFDISK MBR - its it free or for money?

Edited by ruthan

Share this post


Link to post
Share on other sites
rloew    90
2 hours ago, ruthan said:

@rloew: Thanks for reply.

   Hmm, i didnt get that so called Sata patch, is actually not for classic classic vanilla Sata, but only for special cases like - like MB with Sata controller and IDE or RAID mode, external controller Sata controllers etc.. 
   Because with AMD 97 have tried - only controller in AHCI mode with patch.. Because i dont want to use IDE mode with modern OS, where i want to use full speed of Sata III and that i one of reasons why i even bough the patch. Yeah you can said that i can use different disk for differrent OSes, but its annoying.
 
  One clarification, i dont care about real AHCI things like NCQ, TRIm etc, i care only write / read performance in Win98x, without patch is 1 MB/s and freezes during file operation make new HW retromachine dont useful. 

Ok, so have i last version of Sata.inf - i have version from 2009?

  Ok so i how i turn off AHCI on my external Sil 3512 controller? Because this is only supported scenario.. and i dont know how to set this - AHCI off mode, i refer to this:

   Could you describe it in more detail? I tried to search for this entry in Registry and a i deleted something and Windows stopped booting.

Terabyte patch - I have bad memory but i think that i bought it together with Sata patch, im sure that i dont stole it - im sure that its your patch, or at least demo, timestamp is 2008.

RFDISK MBR - its it free or for money?

You have the latest standard SATA Patch, which is for IDE. I also had sent you ATA0104.INF which is for IDE RAID Mode as in some old VIA Controllers.
A few days ago, I sent you ATA0180.INF which is for Mass Storage Drivers such as the Sil 3512, and PATCHPCI which fixes the problem with VIA Controllers that made using RAID Mode necessary.

The Sil 3512 has a configuration menu. If I allows selecting IDE vs. AHCI, select IDE.
Use the ATA0180.INF File to install it.

I wrote the ATA0106.INF because some early PCI-E Cards used the AHCI Code. Like my Laptop, the Cards did not Enable AHCI by Default so they worked with the INF.

The AMD 97 Motherboards will Enable AHCI when using RAID or AHCI Mode so the INF is not enough. I developed a separate program (AHCIBIOS) after you bought the SATA Patch that can turn off AHCI and provide a replacement BIOS to run DOS until Windows can boot. You would need this Program if you want to multi-boot with other OSes using AHCI.

TRIM is not an AHCI related Function. I sell a separate TRIM Program.

The NOIDE Value is in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\IOS. It is a Binary String that would be set to 01.

The "terabyte" Patch you refer to is my High Capacity Disk Patch, which overcomes the 137GB limit. It lets you use 2TiB Hard Drives but is not described as a "terabyte" Patch as I have other Patches with that name.

The RFDISK MBR is installed when you use RFDISK. I haven't offered it separately. See the description of RFDISK on my Website. 

Share this post


Link to post
Share on other sites
ruthan    1

Thanks for reply, i know you are probably old terminal fan, but if you dont have any master utility with inbuild configuration autodetection or step by step gui installer.. at least some picture like flow chart or mindmap style diagram packaged with product would help more that long text files and per user support.. Because when i bought something with name Sata patch, i just though that i will install something and all Sata configuration would be just handled without users tweaking, yeah maybe im naive or spoiled user..
  
  Yesterday i think i did all by the book (original installation guide all 6 or 7 steps) for my AMD970 (asus m5a97 r2.0.) board:
- BIOS is set to AHCI for Sata 0-3 and IDE for SATA 4-5 // Disks are connected to port 4+5 (both Sata III devices)
- i have removed controllers, copied sata inf
- rebooted Sata driver is used for DUAL PCI controller and primary a secondary channels redetected
- reboot

  But there is still error code 10 on both channels and disc are still in MS-DOS compatibility mode, discs operation are slow and there are long system frezees.. No any other or patch related / zombie controllers involved, no disk controller cards, only NIC + 2x Geforce videocards.


  Were could be problem? If you need some for info, logs etc, i will provide them.

Quote

The Sil 3512 has a configuration menu. If I allows selecting IDE vs. AHCI, select IDE.


  Do you mean,Windows 98 control panel wizzard for Sil controller, or config menu  which could be access during boot before OS is started?

Quote

The NOIDE Value is in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\IOS. It is a Binary String that would be set to 01.

  Or and should i remove whole IOS - node, or only delete NoIDE - entry or change its value?

AHCIBIOS - It would be nice to have this one, but now im unable to make it working IDE in mode..

RFDISK - Its possible use it without data loss? Sorry i dont study its principle, if it acctually edit MBR or only is some wrapper in Windows 98 which make OS thing that MBR is other that real one.

Edited by ruthan

Share this post


Link to post
Share on other sites
rloew    90

Since the SATA Patch is normally installed from DOS, a GUI is not practical.

The Error 10 will remain until you reboot after removing the NOIDE Entry.

Do not remove the IOS Key, just the NOIDE entry.

I was referring to the Sil3512 Config Menu before the Hard Disk is Booted.

AHCIBIOS will work with the M5A97. You can contact me by E-Mail to order it.

RFDISK does not cause data loss if properly used. It will replace the MBR with one I designed, if you use the "M" Command.

Share this post


Link to post
Share on other sites
ruthan    1

GUI - was primary speaking about documentation, where picture help, same as on the web. But even in DOS, you could use VGA mode - 320x240x256 or 640x480x16, its running i think still on all Windows 98 VGA cards, SVGA would a bit more fun.. Other solution is some text graphics mode - like old turbovision from Borland, i assume that new developed IDE has such libraries too.

  I just tested remove noide key on both my systems, is not magic solution - when i remove it i have got normal boot hang,  removed controller, normal boot ok - sata patch installed, normal boot hang.. And doesnt helped with zombie controllers, there still there - and are still non removable.

  Sil3512, i have using it on on Conroe865PE MB machine. I not sure about bios IDE/SATA setting.. There is Compatibility mode - which enabling one IDE controlller +SATA - but in my case i have always got with this mode boot hang - even before OS boot, so im using some enhanced mode - in Bios description is that is good for Win 2000 / XP.. So i probably cant enable classic old IDE mode - i will debug it, if is problem with Sata III HD or with Sata DVD driver, or in general with board.. So im probably booting with AHCI mode enabled.

   Because is have such headaches with Sata patch, i would probably just use SIL controller, but it seems that it is not supporting Grub boot loader even with newest bios and i wrote in the past, when i install its drivers i cant now boot - my is because of conflict with other setting.. I will check its setting, i didnt that after its bios flash.

  Update: BIOS has to set to Enhanced mode - other wise is not my SATA drive detected at all, so its means that i here im probably also using AHCI and there is not other choice, completly disconected DVD drive for testing.

   AHCIBIOS - what is price?

  RFDISK - i need make Sata running, after that i will think about it.

Edited by ruthan

Share this post


Link to post
Share on other sites
rloew    90

I am assuming that the SATA Patch has been applied and the SATA.INF File is in the WINDOWS\INF Folder.

Switch all 6 SATA Ports to IDE in the BIOS. Boot into Safe Mode. Remove all of the Controllers except Primary and Secondary ones. Remove the NOIDE Registry Value. Reboot into normal mode.

AHCIBIOS is $11.00 US. We can worry about this after you resolve the SATA issue.

Share this post


Link to post
Share on other sites
ruthan    1
Quote

I am assuming that the SATA Patch has been applied and the SATA.INF File is in the WINDOWS\INF Folder.

     It is.

Quote

Switch all 6 SATA Ports to IDE in the BIOS. Boot into Safe Mode. Remove all of the Controllers except Primary and Secondary ones. Remove the NOIDE Registry Value. Reboot into normal mode.

  Ok new info, i want to all port in IDE mode, but i will try it.

 

Quote

AHCIBIOS is $11.00 US. We can worry about this after you resolve the SATA issue.

  Im affraid that it will be neccesity, to be honest this Windows 98 project, is probably biggest failure in my retro gaming journey.. I invested much less time, into Unraid Windows 98, which is now up and working, but im dont like messy accounts, so im not give up on physical machines.. 

    BTW you should consider some you all in one package for gaming or something like that. I hope that on dead bed you will make it open source and enhance manking, im affraid that even in next decades some madmans will this try to check authentic Win98 experience..

  Ok all above was about my AMD970 machine, what abou my Conroe865PE, is there any hope, without AHCIBIOS patch? Present situation summary - its booting only in Enhanced - IDE mode, when im getting MS-DOS mod and im unable to make DVD drive working on mother Sata port or on Sil3512 controller.  
   I experimenting in was day with Compact flash to IDE adapter and this MB IDE looks problematic.. there are issues too.. Installation of XP with USB installer took 5 hours, very slow disk transfers, could be crappy adapter (i have tried 2), but i think that is about board a its enhanced mode, compatibility mode dont working for most of my devices at all.. Or it maybe dont like my SIl3512 board, but XP and WIndows 7 and LMDE 2 Linux are working fine with that and without working Sata i dont want to remove it..

Edited by ruthan

Share this post


Link to post
Share on other sites
ruthan    1

Ok, i did it:

Quote

Switch all 6 SATA Ports to IDE in the BIOS. Boot into Safe Mode. Remove all of the Controllers except Primary and Secondary ones. Remove the NOIDE Registry Value. Reboot into normal mode.

 Once again its not working for me, reboot after is Sata driver installed in normal mode and second (first with installed drivers) normal boot freeze, im quite sure that i did all steps right.. I think that you really should write some simple check (if i did all really right) or installation utility.. Because probably some assumption how it is working is wrong..
 

Edited by ruthan

Share this post


Link to post
Share on other sites
rloew    90

I just E-Mailed you a Program that can completely clean out all Disk Drivers and Settings from the Registry.

What is the size and date of the WINDOWS\SYSTEM\IOSUBSYS\ESDI_506.PDR File?

Boot into Normal Mode using the Logging Option. Post the last 10 lines from the resulting BOOTLOG.TXT File.

Share this post


Link to post
Share on other sites
ruthan    1

Thanks,

Here is end of bootlog, before purge from freezing configuration:

[0002D509] Enumerated Sdílení souborù a tiskáren v sítích Microsoft (NETWORK\VSERVER\0006)
[0002D509] Loaded PNP drivers of Protokol standardu IPX/SPX (NETWORK\NWLINK\0002)
[0002D509] DEVICEINIT   = DOSMGR  
[0002D509] DEVICEINITSUCCESS   = DOSMGR  
[0002D509] DEVICEINIT   = VMPOLL  
[0002D509] DEVICEINITSUCCESS   = VMPOLL  
[0002D509] DEVICEINIT   = JAVASUP 
[0002D509] DEVICEINITSUCCESS   = JAVASUP 
[0002D509] DEVICEINIT   = VCOMM   
[0002D509] DEVICEINITSUCCESS   = VCOMM   
[0002D50A] DEVICEINIT   = VCOND   
[0002D50A] DEVICEINITSUCCESS   = VCOND   
[0002D50A] DEVICEINIT   = VTDAPI  
[0002D50A] DEVICEINITSUCCESS   = VTDAPI  
[0002D50A] DEVICEINIT   = KEYREMAP
[0002D50A] DEVICEINITSUCCESS   = KEYREMAP
[0002D50A] DEVICEINIT   = VFLATD  
[0002D50A] DEVICEINITSUCCESS   = VFLATD  
[0002D50A] DEVICEINIT   = Display1
[0002D50A] DEVICEINITSUCCESS   = Display1
[0002D50A] DEVICEINIT   = SBEMUL  
[0002D50A] DEVICEINITSUCCESS   = SBEMUL  
[0002D50A] DEVICEINIT   = VDMAD   
[0002D50A] DEVICEINITSUCCESS   = VDMAD   
[0002D50A] DEVICEINIT   = V86MMGR 
[0002D50A] DEVICEINITSUCCESS   = V86MMGR 
[0002D50A] DEVICEINIT   = TSKNF700
[0002D50A] DEVICEINITSUCCESS   = TSKNF700
[0002D50A] DEVICEINIT   = SPOOLER 
[0002D50A] DEVICEINITSUCCESS   = SPOOLER 
[0002D50A] DEVICEINIT   = UDF     
[0002D50A] DEVICEINITSUCCESS   = UDF     
[0002D50A] DEVICEINIT   = VFAT    
[0002D50A] DEVICEINITSUCCESS   = VFAT    
[0002D50A] DEVICEINIT   = VDEF    
[0002D50A] DEVICEINITSUCCESS   = VDEF    
[0002D50A] Initing mcdbus.mpd
[0002D50A] Init Success mcdbus.mpd
[0002D50A] Initing esdi_506.pdr
[0002D50A] Init Success esdi_506.pdr
[0002D50A] Initing esdi_506.pdr
[0002D50A] Init Success esdi_506.pdr
[0002D50A] Initing esdi_506.pdr

  Looks like esdi, related. 

Date of this size: ‎9. Nov(11th month) ‎2000, ‏‎18:53:06, size - 24 431
+ there are 2 *.baks file backups with almost same name.. one 5.5.1999, one 3 May 2015

  I will update this post later, after purge etc.
Hmm, i have stupid problem, i cant run purge in safe mode, because when i start command.com i have go black screen (monitor constantly changing between black screen and powerstate), i dont know if is Nvidia or my HP 24 LCD (When will machine start to working i will search in garage for proper CRT monitor) related problem (its 60 Hz, maybe Windows trying set 70 Hz, or unsupported Windows resolution...), or Windows problem..

Update:
I have started purge in normal mode, i ran ok no controller, but after that again normal boot freeze.. I didnt checked it, i have go to sleep, but i bet that i would be esdi problem..

Update2: Bootlog hangs on same line.

 

Edited by ruthan

Share this post


Link to post
Share on other sites
rloew    90

I see the problem.

You overwrote the Patch with another ESDI_506.PDR. It looks like the Version that comes with U98SESP3.

Delete the 2 BAK Files.
Rerun the SATA Patch Program.

When installing something like U98SESP3, you have to Uninstall the SATA Patch, Install the Third-Party Software, then Reinstall the Patch, all without rebooting.

Share this post


Link to post
Share on other sites
ruthan    1

I will do it once more, but i have read U98SESP3, release notes and there was how it work with you Sata patch, i think that i did all what i should to do.. but i will recheck it. Pleas stay tuned.

  On second machine - intel 865 is not U98SESP3 install so problem have to elsewhere, but i had no time to check purgehc here, i think here is primary problem active ahci..

 I wonder what improvements have U98SeSO3 Esdi file and why is not possible to use your patch for it?

Edited by ruthan

Share this post


Link to post
Share on other sites
rloew    90

You can use my SATA Patch with the U98SESP3 ESDI_506 File, but you must apply the Patch after it is installed.

U98SESP3 replaces the ESDI File. It doesn't Patch it.

Share this post


Link to post
Share on other sites
ruthan    1
Quote

98SESP3 replaces the ESDI File. It doesn't Patch it. 

  I know that is replaced, not patched, but its details, important is when i tried to patch it, i have got message that this file cannot be patched - Version 2015, which was on my Conroe865 machine.------ 
I repeated procedure with my AMD970 i have progress, your - drivers are used, but its empty victory..

 I dont have now any exclamation mark in device manager, but..
- whole point of patch was performance and its same, look at picture still around 2 MB/s like without patch, i attach same benchmark on Windows 7 same disk, its 150x faster (I expected that result would be capped around 133 MB/s in Windows 7 because of IDE mode, but board can somehow bypass with limitation, i hear that some board cant use multiple buses at once and combinate traffic, so probably this is that case..)
- small freezes in game are still there, i dont know if it is storage problem or Nvidia driver problem, but i have know both patches, so its time to messing with IRQ patches?

  Its not too important know, but i wonder, how is possible that with same installation clone, i can on Conroe 865 start command.com in safe mode and i have got it in window mode and on AMD970 machine, i have got black screen,
even in normal mode, i have discover, that my right click open command line there extension - when is used in 16bit color mode, make all colors pallete broken, in 32 bit mode it is ok. Its it some Unofficial Nvidia 82 driver bug?
---
Next question, what procedure should be used to turn on ahci on port 0-3.. to keep your patch working. Which controller should i disable in device manager - could i recognize, controller for port 0-3 and second for port 4-5? I set IDE for both, but problem was in ESDI so, i thing is not necessery..

I though that i saw heaven..:

NoExclamationMarks.png

Win 7:

AttoBenchMark-SSD-Windows7.png

Windows 98:

AttoBenchmark-Windows98-Slow.png

-----------
I now will experiment with Conroe865 machine, what is nice that purgehd is working well..


  Update: This machine is jester, especially that Asrocks Enhanced SATA mode, i disable all IDE controllers in the bios, but after purge were again redetected Intel IDE controllers.. I dont understand is it coverup name for Sata controllers or what? One is without Exclamation mark, second with..

Edited by ruthan

Share this post


Link to post
Share on other sites
rloew    90

Go to the "Disk Drives" Section in Device Manager.

Turn on DMA on each Drive.

This should improve performance.

PURGEHDC erased all of the previous settings.

If you enable AHCI, the Controller ID and Type will change so it will appear as a New Unknown Device. You do not need to disable the existing Driver as it will not be loaded for that Controller.
In this case having ATA0106.INF installed would be a liability.

Be aware that some AHCI BIOSes incorrectly handle Odd Address Transfers in Compatibility Mode and can cause corruption.

I would recommend using AHCIBIOS and ATA0106.INF for long term usage.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×