Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



xper

Forum upgrade to v4.2!

Recommended Posts

We did forum upgrade to version 4.2. Please post bugs in here.

  • Upvote 1

Share this post


Link to post
Share on other sites

An annoying bug I've noticed while browsing some topics is that whenever I change the topic page, it stays on loading and doesn't load anything. I have to manually refresh the page to see it.

I'm using Firefox 54.0.1 x64 on Windows 8.1.

Share this post


Link to post
Share on other sites
3 minutes ago, greenhillmaniac said:

An annoying bug I've noticed while browsing some topics is that whenever I change the topic page, it stays on loading and doesn't load anything. I have to manually refresh the page to see it.

I'm using Firefox 54.0.1 x64 on Windows 8.1.

Oh me too, thought that was this junk internet I'm on but I guess not.

Share this post


Link to post
Share on other sites

I know what causing it. Will fix it now.

Share this post


Link to post
Share on other sites

Xper, I really hope this means that you're considering keeping the board open now.
Why would you do a software update a couple of days before closing it?!
Looking at other threads, you will have no shortage of support from your members, to whom this board has come to mean such a lot.
Cheers, Dave.
:)

Share this post


Link to post
Share on other sites

 

This is IMHO serious and should be solved:

Cannot say if it's the font, its stupid gray colour (and thus almost null contrast), some form of antialiasing or what, but it is almost unreadable, requiring an excessive effort to read anything, really, it makes my eyes tear, it is unbearable.

These are minor things:

The "Unread Content " link does nothing (it works *somehow* from the top dropdown menu Activity->Unread Content that actually leads to http://www.msfn.org/board/discover/unread/

For whatever reasons you have to hover the mouse on "Activity" then after a delay the dropdown opens and you can choose the items in the dropdown,

The "Activity" itself if clicked leads directly to http://www.msfn.org/board/discover/ same as Activity->All activity

There is also an item Search that leads (just like the magnifying icon on the right) to http://www.msfn.org/board/search/

You need to "approach" the manifying icon from the left, the right or the bottom with the mouse because if you do it from the top it get covered by the expansion of the Contacts dropdown.

It's good to have to learn new UI usage conventions.

The good news are that at least the user "avatar" on the top left  doesn't grow anymore out of scale as it did before.

jaclaz
 

Share this post


Link to post
Share on other sites

@jaclaz, what browser?

Unread Content link works for me.

 

Share this post


Link to post
Share on other sites
Posted (edited)

@xper add a notification for those who are using adblocker.  Please do it . I will ask my parents to make PayPal account so that I can donate something. 

Wrong thread

Edited by xper

Share this post


Link to post
Share on other sites
Posted (edited)
48 minutes ago, xper said:

@jaclaz, what browser?

Unread Content link works for me.

 

Opera . 12.15

 

Checking again BOTH "Home" and "Unread Content" (or "All activity" if not logged in) don't work, i.e. everything in the gray bar on the left of the facebook/twitter/google+ don't work (but the facebook/twitter/google+ do work), i,e, I can see the "

Home->The General Stuff->General Discussion->Site & Forum Issues->Forum upgrade to v4.2

at the top of the thread, but no item in it is clickable.

Also, I am replying with a Chrome, sice the "+" and "Quote" below each post don't show at all in Opera.

Usual mess by the guys at IPB :realmad: but still not a major problem, at the most it simply further prevents to make proper quoting of previous posts.

Readability/font/contrast IS a real issue.

Besides being VERY VERY blurry (in Opera) it is a little crispier (though anyway FAR from being actually crisp) in Chrome (OK Iron actually) but here it is too d@mn small (and thus as well unreadable)

jaclaz

  

Edited by jaclaz

Share this post


Link to post
Share on other sites

jaclaz, your problems are I'm afraid almost certainly being caused by using an old version of Opera.
I adored the original Opera, and used it as my default browser for many many years, and was horrified when they replaced it with something that was Chromium-based and stripped out all the customisation options that I used fully on the old version.
I kept Opera 12.18 (the latest and almost certainly last version) as my default browser until literally a week or two ago, when I had to accept that so many sites were now not working properly in Opera 12 that I had to admit defeat and move to Firefox as my default.
Not only do many pages display wrongly in Opera 12 now, javascript links often don't work, which is really annoying when you spend ages filling in a form and then the "submit" button does nothing!
I'm sure the problem with the MSFN site is nothing to do with the coding, I'm sure it works fine in current browsers, it's Opera 12 that's the problem I'm afraid.
:(

  • Like 2

Share this post


Link to post
Share on other sites

New forum software is smooth for browsing from smart phones.  Android and google chrome is working fine here.

  • Like 1

Share this post


Link to post
Share on other sites

I'm using Pale Moon 27.4 x64 and Nightly 57.  Both work so far

:)

 

  • Upvote 1

Share this post


Link to post
Share on other sites
7 minutes ago, Dave-H said:

jaclaz, your problems are I'm afraid ...

No,

I have NO problems whatsoever, nor does Opera have any, this board (its software) have them, we were asked to report if we noticed any problem (of the board and of its software) and that is what I did.

The non-solution to these problems (very common BTW) is to blame the user for not using this (or that) browser, this is an entirely wrong approach by a number of arrogant, usually clueless lazy developers, including particularly the guys at IPB board, who well demonstrated in the past to be among the most clueless and less custom oriented folks around.

They (as well of course as Xper that obviously has much less power in fixing any bug) are perfectly free to botch (as they ALREADY did at EVERY SINGLE new release of the board) the board, the looks of it, the readability of it, each and every link, reference and Quote and Code (let alone Codebox) text, make the editor unusable,  and to mark each and every bug report (as they ALREADY did for hundreds of them) as "Won't Fix" or "This is by design".

I don't need fellow members to tell me how Opera is outdated, I know, thank you.

jaclaz

 

  • Like 1

Share this post


Link to post
Share on other sites

Of course you were quite right to report the problems jaclaz, I wasn't saying that you shouldn't, whatever browser you're using.
The fact has to be faced though that Presto-based Opera hasn't been properly updated now for over four years. The last 12.18 update was over two years ago, and was only to help with security protocol compatibility, it didn't do anything to help fundamental site compatibility, which had always been a struggle with Presto Opera anyway, as nobody coded for it as its user base was so small. Opera always had to put loads of workarounds into the browser, like browser.js, which had to be constantly updated as sites changed their coding.
With no updates for so long, inevitably sites were going to start to malfunction, and the browser is now crawlingly slow on javascript-heavy sites like YouTube and Facebook.
Sorry to be blunt, but even I had to bite the bullet eventually, as much as I loved Opera 12. Frankly it's like wondering why MSFN doesn't work properly in IE8.
I wouldn't hold your breath for any fixes if they're only affecting Opera 12, whose user base must now be minute.
Cheers, Dave.
:)

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

I am attaching three cropped screenshots (it is a .7z file containing three .bmp's, I didn't intentionally use .jpg format to avoid any image compression artifacts) to show what I see here.

The text (ALL text) is severely blurred and/or too d@mn small to be easily readable.

As said, in Opera it is more blurred but a little larger, and in Chrome (Ok, Iron) it is slightly less blurred but way too tiny, even enlarging it in 110% it remains blurry.

It is UNREADABLE, and since the idea of publishing anything is that people is able to read it (and read it easily) it seems to me like a serious issue.

The text on Qtweb is much crispier. and - as a side note - even with javascript disabled the "Unread Content", etc. i.e. contents of the gray bar work fine in it.

I am also attaching three small .jpgs of Dave-H latest post, only to show the differences in the readability (or lack thereof) of a single post text.

As expected the .jpg compression severely worsen the quality, the "real" QTweb view is much crispier than what it seems from the jpegs.

jaclaz

 

 

msfn_view.7z

daveH_opera.jpg

daveH_iron.jpg

daveH_qtweb.jpg

Edited by jaclaz

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×