Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



MrMateczko

Ultimate 98SE PC - Ultimate Disappointment

Recommended Posts

17 minutes ago, 98SE said:

Just installed GeForce 6600GT.  Tried your trick and it worked.  Now I have to add a sound card for audio.  I forgot about 98 driver hell.  P4 was so much easier with PnP.

DOSBOX working with Bear.

Now we need Intel HD HDMI audio out driver for 98SE.  Portable Gaming on the Go with USB Flash.

I wonder why this trick was necessary.  Lone Crusader must have had a hell of a time detecting his motherboard.

What are you talking about?

I'll have you know I have no trouble "detecting" my motherboard. It's right where I left it on my testing bench. It is not mobile and does not have cloaking ability. :whistle:

Stop hijacking threads and cross-posting multiple subjects across different threads.
This thread is about MrMateczko's Windows 98SE machine.
It has nothing whatsoever to do with VBE9X, DOSBOX, or any of my motherboards.

Share this post


Link to post
Share on other sites

Posted (edited)
1 hour ago, ruthan said:

     but HDMI audio in Win98, i dont believe that it will work. Solution is USB audio, i didnt try to find smallest USB audio card, but could small as old volume controlls for discman and walkman..

This is the easier method if HDMI audio can be used.  DOSBOX takes care of Sound Blaster emulation so a crisper sound experience and less cable clutter using HDMI video.  I will have to test USB ports later.  The on board USB2 ones may work but USB3 will probably be a big problem on newer chipsets so HDMI audio option would be required.  No more PCI slots on some newer motherboards unless there is a PCIe sound card with Windows 98 driver that exists (Preferably a PCIex1 short card).  Also running out of internal slot space so I must remove the network card to test that option.  Hmmm on board might be Realtek Audio so maybe another option?

Edited by 98SE

Share this post


Link to post
Share on other sites
1 hour ago, LoneCrusader said:

What are you talking about?

I'll have you know I have no trouble "detecting" my motherboard. It's right where I left it on my testing bench. It is not mobile and does not have cloaking ability. :whistle:

Stop hijacking threads and cross-posting multiple subjects across different threads.
This thread is about MrMateczko's Windows 98SE machine.
It has nothing whatsoever to do with VBE9X, DOSBOX, or any of my motherboards.

This is the 9X neutral zone.  We must maintain peace at all costs in order to save MSFN.  All is related to that main mutual goal of getting 98SE to work on his motherboard.  MrMateczko is using a 100 series motherboard which I have a Z170 and probably the only member active or inactive with one.  Unless you have a 100/200 Series or Z170/Z270 to assist aside from the X99?  Otherwise shields down and decloak and disarm disruptors on the Warbird.  It is not a good day to die at least not till 25 days from now which hopefully can be avoided.  Do not engage the self-destruct sequence. :no:

Now you got me to geek out.  Must resist. :blink: There is... "One" Liight!!!! err Month...

Share this post


Link to post
Share on other sites
35 minutes ago, 98SE said:

This is the 9X neutral zone.  We must maintain peace at all costs in order to save MSFN.  All is related to that main mutual goal of getting 98SE to work on his motherboard.  MrMateczko is using a 100 series motherboard which I have a Z170 and probably the only member active or inactive with one.  Unless you have a 100/200 Series or Z170/Z270 to assist aside from the X99?  Otherwise shields down and decloak and disarm disruptors on the Warbird.  It is not a good day to die at least not till 25 days from now which hopefully can be avoided.  Do not engage the self-destruct sequence. :no:

Now you got me to geek out.  Must resist. :blink: There is... "One" Liight!!!! err Month...

You can discuss 9x issues here to your heart's content (or till you're blue in the face), take your pick. But you must learn to separate different issues and keep discussions on topic. Different specific forums and threads exist for a reason. Use them as such. Do not post about 9x things in the XP forum. Do not discuss subjects from one thread in a different thread. Failure to do this results in a nightmare for anyone looking for specific information or trying to follow a discussion. In the event there is an issue with "overlap" across multiple operating systems, you need to keep the discussion in the forum for the OS where the issue originated and where it will receive the most relevant attention.

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, LoneCrusader said:

You can discuss 9x issues here to your heart's content (or till you're blue in the face), take your pick. But you must learn to separate different issues and keep discussions on topic. Different specific forums and threads exist for a reason. Use them as such. Do not post about 9x things in the XP forum. Do not discuss subjects from one thread in a different thread. Failure to do this results in a nightmare for anyone looking for specific information or trying to follow a discussion. In the event there is an issue with "overlap" across multiple operating systems, you need to keep the discussion in the forum for the OS where the issue originated and where it will receive the most relevant attention.

Acknowledged.  Probably the jumping around between the two forums I use the most.  I sometimes forget which I am in with over 200 tabs open at times at the top the browser tabs don't have a separate logo for a different forum.  It usually requires going to very top or looking at the very bottom of the page and I'm usually in the middle of the thread reading at times or left at that position when moving to another tab.

I noticed there is a dark blue bar separating each message and also one at the top and bottom.  Could the Subject of the forum be embedded into that dark blue area somehow or as an example while in the 9X/ME forum a Microsoft Windows Logo of 95/98/ME OS be stamped in that blue bar area ?  Also when starting a reply/post the grey bar area between "Notify me of replies" and "Submit Reply" this forum title, topic, and OS logo could be added there as well.

Edited by 98SE

Share this post


Link to post
Share on other sites
Posted (edited)

Hello!
My 7900 GTO has arrived on Friday.
I was super busy with other stuff, and could not focus fully on the build.
Further discussion will be in the topic below, which will be up (hopefully) tomorrow, once I gather enough resources, and testing materials. It will be a final topic, no more extra topics, promise :)
It will contain everything you might know about my build, and a step by step guide how I've installed 98SE on such a new motherboard. Enjoy!

(placeholder topic link)

See below

Edited by MrMateczko

Share this post


Link to post
Share on other sites

Sadly, I will have to call this a defeat. I'll no longer be interested in putting 98SE on my main rig.

The number of obstacles is simply too much for what it's worth. So here's what's wrong:

1. NO USB Support! (therefore no Audio whatsoever!)

The USB controller in the motherboard uses this hardware ID:

PCI\CC_0C0330

But USB drivers, such as NUSB expect this ID:

PCI\CC_0C0320

So I can't use any USB devices, other than the keyboard and mouse I use emulated as a PS/2 devices via BIOS option.

This means I cannot use the USB audio card I've bought :(:(

2. Drive forced in compatibility mode with no hope whatsoever! :/

This is the biggest issue. I've tried many methods to make the drive not at slow as it is:

-tried XHDD, machine hangs in BOOTLOG.TXT at "DEVICEINIT   = VFAT"

-tried XMGR, does not load at all

-even contacted rloew about the SATA Patch, with the result I got from his "test" program, it shows the SATA controller in my motherboard works only in AHCI mode, which is bad :/ (maybe related to that, the ESDI file is not attempted to load at all, it goes straight to the compatibility mode)

I know I could use SMARTDRV, or other workarounds, but they will not be as stable and reliable as a true 32-bit disk access with the ESDI_506.PDR file. I want that, nothing else.

The results are constant freezes when there's lots of file moving/copying. I also got some disk write error BSODs, which got me scared.

3. The system randomly freezes for no apparent reason after installing the 82.69 drivers. I though the freezes would be detected by the TESTEOI test device form rloew, but no, I didn't get a single error message/BSOD related to the EOI bug.

4. The system does not shutdown, it just hangs at the shutdown logo, I've tried everything, like the shutdown supplement, and service packs, but nothing worked.

5. The NVCHECK utility from rloew did show correctly that -> "Resource Under Allocated    Driver Patch or BIOS Flash Needed"

6. The 3DMark2001 SE scores I got were really low. I got about 45k score, where as I wanted to get about 65k as seen here: http://hwbot.org/submission/3228042

(this very submission was partly the reason I bought the 7900 GTO and started this whole build, hoping I could be as good as him, but...nope :( )

So, in conclusion...not worth it. I love 98SE, but the design choices made back in 1999 do show their cons in 2017 :)

Now I got a 7900 GTO and a USB sound card I don't know what to do with now...I'll keep them, maybe they'll come in handy later, who knows, I'm mad enough I got rid of some stuff I sold for practically nothing I could have used :(

Share this post


Link to post
Share on other sites

@Damnation I know there are USB 2.0 PCI-E x1 cards, but that's spending more money on stuff :unsure: Besides, I only have one PCI-E x1 slot, if I had two of them, I would consider it, alongside a SATA PCI-E x1 card compatible with 98SE. But as of now, I'm so freaking tired of 98SE, I don't want to look at it, at least for now.

@ragnargd Hehe, thanks :) I know you are very experienced with 98SE, and know that it's a tough OS to love.

Share this post


Link to post
Share on other sites

Because XHDD is a Disk utility, it might be the cause of the VFAT crash. Normally a VFAT crash is a sign of DMA Memory starvation due usually to Gigabit Ethernet Drivers or oversize Registries.
My RAM Limitation Patch /M option fixes this. My Demo can be used to verify this.

Share this post


Link to post
Share on other sites
Quote

Sadly, I will have to call this a defeat. 

  Common man not be soft, second round of suffering .. when you trying to make all working with Rloew patches and its still not working is even better! 

Share this post


Link to post
Share on other sites
15 hours ago, MrMateczko said:

Sadly, I will have to call this a defeat. I'll no longer be interested in putting 98SE on my main rig.

The number of obstacles is simply too much for what it's worth. So here's what's wrong:

1. NO USB Support! (therefore no Audio whatsoever!)

The USB controller in the motherboard uses this hardware ID:

PCI\CC_0C0330

But USB drivers, such as NUSB expect this ID:

PCI\CC_0C0320

So I can't use any USB devices, other than the keyboard and mouse I use emulated as a PS/2 devices via BIOS option.

This means I cannot use the USB audio card I've bought :(:(

2. Drive forced in compatibility mode with no hope whatsoever! :/

This is the biggest issue. I've tried many methods to make the drive not at slow as it is:

-tried XHDD, machine hangs in BOOTLOG.TXT at "DEVICEINIT   = VFAT"

-tried XMGR, does not load at all

-even contacted rloew about the SATA Patch, with the result I got from his "test" program, it shows the SATA controller in my motherboard works only in AHCI mode, which is bad :/ (maybe related to that, the ESDI file is not attempted to load at all, it goes straight to the compatibility mode)

I know I could use SMARTDRV, or other workarounds, but they will not be as stable and reliable as a true 32-bit disk access with the ESDI_506.PDR file. I want that, nothing else.

The results are constant freezes when there's lots of file moving/copying. I also got some disk write error BSODs, which got me scared.

3. The system randomly freezes for no apparent reason after installing the 82.69 drivers. I though the freezes would be detected by the TESTEOI test device form rloew, but no, I didn't get a single error message/BSOD related to the EOI bug.

4. The system does not shutdown, it just hangs at the shutdown logo, I've tried everything, like the shutdown supplement, and service packs, but nothing worked.

5. The NVCHECK utility from rloew did show correctly that -> "Resource Under Allocated    Driver Patch or BIOS Flash Needed"

6. The 3DMark2001 SE scores I got were really low. I got about 45k score, where as I wanted to get about 65k as seen here: http://hwbot.org/submission/3228042

(this very submission was partly the reason I bought the 7900 GTO and started this whole build, hoping I could be as good as him, but...nope :( )

So, in conclusion...not worth it. I love 98SE, but the design choices made back in 1999 do show their cons in 2017 :)

Now I got a 7900 GTO and a USB sound card I don't know what to do with now...I'll keep them, maybe they'll come in handy later, who knows, I'm mad enough I got rid of some stuff I sold for practically nothing I could have used :(

 

<<constant freezes when there's lots of file moving/copying.

What are you doing when this going on?  Are you running a program or just idling on the desktop?

Your MB only has two PCIe slots, one tied up by the Graphics card leaving you with just the PCIe slot.

I'd go with a PCIe sound card if all you want to do is game.

But if you want to hook up other external hard drives then you have to get a PCIe USB card and then try your USB sound card on it.

So the choice is between gaming by adding a PCIe sound card or if you want external storage access (and the possibility of the USB sound card working) go with a PCIe USB card and hope it works without issues.

Sometimes you have to take a break and sleep and a new idea pops in your head overnight or during the relax period.

This 98SE is a headache (reliving) it can be frustrating but the payoff is when it's finally working.

What programs are planning for this system to run in the end aside from the benchmark when the build is working?

Share this post


Link to post
Share on other sites

Unfortunately, based on test results that MrMateczko sent me, this Motherboard adds two more nails to the Windows 9x coffin, and I do not have enough Patches to cover them.

There are not enough slots or BIOS Options on this particular Motherboard to put together a decent 9x System.

If I can get an AHCI Driver working, it might become a minimally decent System for 9x.

Unfortunately, the work LoneCrusader and I have been doing on USB3 has not gotten very far, so a fix seems far off.

Share this post


Link to post
Share on other sites

I did predict the coffin coming down and the tombstone is laid out in preparation.  However seeing if this truly the end of the road (for newer chipsets) as I earlier already predicted and by your two recent 100 series and AM4 results although I have other ideas that might work and it helps to have the actual hardware in front of you and I might be your last hope to confirm through exhaustive efforts if the final nail in the coffin is to be hammered in and the coffin lowered into the ground.  Unless you are willing to buy your own set of 100 series and AM4 motherboards to test if any of your patches will change this outcome this is your last chance for access to someone with the skill, hardware, and most importantly time to troubleshoot it.

Starting with Z77 for testing since it has a combination of both PCI and PCIe slots I'm able to thoroughly test and move cards around or eliminate and adjust BIOS settings and run a battery of testing (time consuming) before finalizing my results.

However seeing this board may have less than a month ? and it appears to be your main domain for luring any potential follow up customers it's probably more your bread and butter for 9X/ME clients.  I can only offer I'm testing all possibilities before closing up my experiments.

So if there are any patches you want me to try out in my Z77, Z170, and AM4 tests this is your last opportunity.

Any results I find working or not working with your patches will be reported here as proof.  And given my username probably no better endorsement if they help in any way succeed in making any newer chipsets work.

If want to attach any programs you want tested made available for all on here to use freely you can attach it here or if are you still withholding certain ones for a fee but still want me to test them (I will not distribute) as part of my experiments just for the purpose of confirming whether your program will or will not assist in making it work or fix any instabilities you can PM me with a direct link of the working program which I will keep solely for testing.

Otherwise I will just finish my experiments and once done it may or may not be the final nail in the coffin depending on the outcome but it will be as thorough as you'll get from anyone.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×