Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



Sign in to follow this  
~♥Aiko♥Chan♥~

Windows 98SE acting up on laptop?

Recommended Posts

The title says it all, I'm trying to figure out why my Windows 98 installation on my Dell Latitude D600 always acts so unstable. The CD rom will not work despite being recognized and changing the resources to avoid conflicts. Windows itself is extremely slow and "lags" just for simply clicking on a simple explorer window to display files.

What could be causing the issues
-Having 1gb of ram in the machine. Despite having 1gb of ram, my machine never failed to install Windows and drivers.
-The combination of VxD and WDM drivers? I've read somewhere having these two different types of drivers on windows can cause instability and conflicts. Since Dell did not officially provide drivers for my laptop there could be a possibility the different driver manufacturers created a different types with no intention of being used in the hardware combination of a Dell Latitude D600.
-The unofficially modded wireless broadcom driver by PROBL3MCH1LD (If that's how I spell his username). Another used has told me the card's taking up the first 32mb of ram can cause boot failure, although it never happened to me. The user fixed his problem by using rloew's ram patch and typing a certain command.
-Enabling ACPI? I've heard ACPI causes some issues on Windows 9x.

I'm so confident this could be fixed >o<

Edited by ~♥Aiko♥Chan♥~

Share this post


Link to post
Share on other sites

MrMateczko    21

Use HIMEMX, it can make system more stable above 512MB.

Never install 98SE using ACPI. There's a reason IBM officially(!) says to install 98SE on my ThinkPad T40 in APM mode and not ACPI.

Do you have DMA enabled? Do drivers work in 32bit protected mode (no errors in the last tab in System properties about compatibility mode?)

Can you try different graphic drivers? I use Omega Drivers too, but you can try official T40 ones: https://www.techspot.com/drivers/downloadnow/3415/?evp=248e71de1f89703e55b98a0dba7e16bc&file=1

Try removing modules from laptop one by one (wifi card, modem, bluetooth, what can you) and see what removal makes system snappier.

Try changing every BIOS option you can, especially disabling all modules you can (serial, parallel, infrared, wifi, ethernet, among others).

 

  • Upvote 1

Share this post


Link to post
Share on other sites
On 10/11/2017 at 1:01 PM, MrMateczko said:

Use HIMEMX, it can make system more stable above 512MB.

Never install 98SE using ACPI. There's a reason IBM officially(!) says to install 98SE on my ThinkPad T40 in APM mode and not ACPI.

Do you have DMA enabled? Do drivers work in 32bit protected mode (no errors in the last tab in System properties about compatibility mode?)

Can you try different graphic drivers? I use Omega Drivers too, but you can try official T40 ones: https://www.techspot.com/drivers/downloadnow/3415/?evp=248e71de1f89703e55b98a0dba7e16bc&file=1

Try removing modules from laptop one by one (wifi card, modem, bluetooth, what can you) and see what removal makes system snappier.

Try changing every BIOS option you can, especially disabling all modules you can (serial, parallel, infrared, wifi, ethernet, among others).

 

Thank you! I will try this when I get the chance!

I installed Windows 98 without ACPI at first, then enabled it. Does that make any difference?
I do have a few compatibility mode issues: Generic Cardbus and Floppy Disk.
Never knew the Thinkpad T40 video drivers were compatible with the 32mb raedon 9000 card!

Share this post


Link to post
Share on other sites
MrMateczko    21

Disable ACPI in registry, it should be enough. I would better reinstall 98SE from scratch, setting the system up is half the fun after all :)

Did you have compatibility mode issues before you've enabled ACPI?

 

 

Share this post


Link to post
Share on other sites
On 10/13/2017 at 4:40 AM, MrMateczko said:

Disable ACPI in registry, it should be enough. I would better reinstall 98SE from scratch, setting the system up is half the fun after all :)

Did you have compatibility mode issues before you've enabled ACPI?

 

 

Haven't got to tweaking Windows 98 yet, but no, I don't believe so.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×