Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



Sign in to follow this  
SteTommo

Stange "pagefile disabled" issues on Win98SE with > 512MB RAM

Recommended Posts

I've been trying to get this to work for ages and familiarised myself with a lot of the limitations and setting involved but I seem to be getting an issue that I can't see anyone else having. I've tried on a few other forums, but a lot of links lead here so I thought I'd try my luck and see if you guys can figure this out!

Without trying to tell the full story chronologically, as it get's complicated, let me tell you what I've figured out so far...

System:  P4 / Intel 865G,  Tried 512/1024/2048 MB RAM, ATI 9600 AGP

Settings:  MaxPhysPage=2000,  MaxFileCache=65536

What I've discovered:

  • Limiting physical memory with MaxPhysPage in addition to using onboard GPU (shares physical memory) causes windows to disable the swapfile regardless of swapfile settings. This only happens once GPU drivers have been installed and the problem goes away after uninstalling the drivers.
  • Limiting physical memory with MaxPhysPage in addition to using a SBLive  (uses physical memory to store SoundFont files) causes the same swapfile issue. Uninstalling the drivers did not seem to fix the issue.
  • Sometimes I end up in a situation where windows boots but hangs with a completely empty desktop and no tasks running. Ctrl-Alt-Del works and you can shutdown. Changing system .ini settings has no effect, the only way to resolve this issue is to remove the RAM and install 512MB.
  • I have had the system running fine with 1GB and 2GB of ram using the settings above just fine, it seems to be installing the drivers for either SBLIve or onboard GPU that causes the problems.
  • I've removed all drivers but now I seem to be stuck in a situation where no matter what I do with system.ini it won't boot unless I install only 512MB RAM.
  • Using RLoew's patch does allow me to use windows without MaxPhysPage, however it's causing Direct3D games to crash. (Using DX9c), I'm not bothered about utilising all the RAM either I just want a stable system.

What I want to achieve:

  • Multiboot system with several OSes, therefore I need 1GB, ideally 2GB of physical RAM installed in the system.
  • Not bothered about Win98 being able to use more than 512MB RAM, just want it to run standard Win98 games. The extra RAM is just for the other OSes.
  • Don't need on-board GFX, The Radeon 9600 AGP is needed for gaming.
  • Would prefer to be able to use SBLive or Audigy2, but I can settle for SB Vibra 128 for example which also has DOS SB16 emulation.

 

Edited by SteTommo

Share this post


Link to post
Share on other sites

> Settings: MaxPhysPage=2000, MaxFileCache=65536
Try: MaxPhysPage=20000, MaxFileCache=65536
You can also disable the swapfile if your games don't need it.

ATI 9600 AGP: 128MB or 256MB?

You probably will need RLoew's RAM patch to get everything that you want without compromising.

Share this post


Link to post
Share on other sites

Sorry that was a typo!  I've tried 20000 (and 30000 and 40000) if I set MaxPhysPage and I'm using the onboard GPU, or SBLive the windows pagefile gets disabled.  I wish there was an error logged somewhere then at least I'd know why it was being disabled.

Since my last post I have tried RLoew's patch and this works, however the first 2 games I tried, Colin McRae 2 and UT99  (both D3D), crashed instantly with exceptions relating to D3D.  I'm running DX9c.

 

It's a 128MB 9600SE

Edited by SteTommo

Share this post


Link to post
Share on other sites

Use HIMEMX.EXE from here:

https://sourceforge.net/projects/himemx/

Put the EXE in the Windows folder and type this at the beginning of the CONFIG.SYS file:

DEVICE=C:\WINDOWS\HIMEMX.EXE \MAX=1048576

(or 524288 if you still have problems)

Also use the Vcache patch from here:

Remove any MaxPhysPage and everything from the [vcache] section (MaxFileCache etc.) from the SYSTEM.INI.

Tell us if this fixes stuff.

Also try using ConservativeSwapfileUsage=1 and DMABufferSize=64 in the [386enh] section.

Also try older graphic drivers.

Edited by MrMateczko

Share this post


Link to post
Share on other sites

I've reverted back to just 512MB of physical RAM and I'm still unable to run D3D games. I've removed all other patches tweaks etc.  The only drivers I can find for Win98 are Catalyst 6.2.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×