• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
Sign in to follow this  
Followers 0
Glowy

Hidden Systemfiles

12 posts in this topic

I'm building an unattended XP SP1 CD with several registry tweaks.

But there's a poblem with unhiding Systemfiles.

I know the reg key is :

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]"ShowSuperHidden"=dword:00000001

When I load the Defaultuser ntuser.dat into the registry I can see the key is set correctly.

But with any user, the value doesn't even exist ? :) ?

manualy adding the value after installation works. But how do I get it to work with all users???

Help I'm desperate... :rolleyes: this is one of the last issues with my image when this works I can go and use it...

BTW I'm Using XPCreate in combination with Xplode and Config Select

Edited by Glowy
0

Share this post


Link to post
Share on other sites

You need to add a line to your cmdlines.txt for the HKCU portion of your automated build

"REGEDIT /S d:\XP_Installed_Programs\XPUserSettingsHKCU.reg"

That will install per user setting at the 11 min mark before the GUI changes to interactive mode and locks the file

Roger

0

Share this post


Link to post
Share on other sites

uhm yeah I'm aware of that...

I'm using Xplode wich is called from the cmdlines.txt and that imports the reg keys

It imports owkay as any other reg tweak I use (checked in default users' NTUSER.DAT) (Most of them in the HKCU) but it doesn't pass down to new users, other tweaks do....

I'm lost :rolleyes:

FYI currently using about 60 regtweaks only 1 not working :)

0

Share this post


Link to post
Share on other sites
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]"SuperHidden"=dword:00000001

The syntax is wrong. To enable showing system files, change the above to the code below and it should work

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]

"ShowSuperHidden"=dword:00000001

Hope this works for you.

0

Share this post


Link to post
Share on other sites

Dôh that's pretty stupid.... it's a typo in my post...

sorry... corrected... but the problem still exists :)

0

Share this post


Link to post
Share on other sites

Tried to edit the hivedef.inf.. didn't work either :C

0

Share this post


Link to post
Share on other sites

Try this.

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\SuperHidden]

"DefaultValue"=dword:00000001

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]

"ShowSuperHidden"=dword:00000001

; To get rid of that annoying backwards warning.

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\SuperHidden]

"WarningIfNotDefault"=-

0

Share this post


Link to post
Share on other sites

WOHOO Worked like a charm!!! :D

THNX Mate couldn't have done it without you!!

:):rolleyes:

0

Share this post


Link to post
Share on other sites

Hi, what a good thing,

I was looking for what this f... option did'nt wnat to work

many thanks :)

0

Share this post


Link to post
Share on other sites
Try this.

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\SuperHidden]

"DefaultValue"=dword:00000001

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]

"ShowSuperHidden"=dword:00000001

"SuperHidden"=dword:00000000

does this line,

"SuperHidden"=dword:00000000

should be '0' or '1'?

0

Share this post


Link to post
Share on other sites
Try this.

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\SuperHidden]

"DefaultValue"=dword:00000001

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]

"ShowSuperHidden"=dword:00000001

"SuperHidden"=dword:00000000

does this line,

"SuperHidden"=dword:00000000

should be '0' or '1'?

It's correct how he had it.

AND OMG, IT WORKS!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.