Sign in to follow this  
Followers 0
nuhi

nLite - Windows reduction tool

672 posts in this topic

Ah ok, thx for the fast reply, you don't really need them right? They're some audio and video codecs if I'm not mistaken. Can't do anything wrong by throwing them in in the meantime right?

It'd probably be easier to just remove their entries from txtsetup.sif. Yes, they're Indeo Codec files. For what it's worth, most 3rd party codec packs come with that anyway.

0

Share this post


Link to post
Share on other sites

@ZuluDC, you are my best beta tester, seriously :rolleyes:

@Jazz, sorry pal, I never use Fast Switching so never had a chance of eliminating the bug, that's why this is still in beta phase...now wait till all the known bugs are eradicated or else you will get frustrated

@gareththegod, hmm, not a bad idea about bartPE/WinPE generator support, but that's up to bart (for WinPE i don't know who is author) if he gives me permission...I'll keep that in mind

About multi-menu, I think it will be best that you make it manually, somehow I don't see it in nLite.

@AztecMystic, thanx

Weird problem, we will wait to see if anyone else has hanging shutdown bug.

@RyanVM, yes i may put those lines to remove them every time if those files are not there, just to be sure

Just tried nLite to slim win2k...results are amazing, on cd it's down to almost 100MB, when installed 250MB !

Of course that version is not ready yet :)

0

Share this post


Link to post
Share on other sites

Thanks for compliment nuhi, but it needs all of us here. :)

Without Jazz i never had seen the Fast User Switch-problem. It is good that many people from different countrys and with brutal deep knowledge like gosh, GreenMaschine, Evilvoice and other have sometimes a look into this thread. It is always good if masses of eyes starring on one tool...it is getting better and better throught this...

0

Share this post


Link to post
Share on other sites

@ nuhi

got error can't find logagent.exe after

deleting MSagent

using Beta 6

bonedaddy

EDIT

Well I deleted that also

0

Share this post


Link to post
Share on other sites

@ZuluDC, of course, i'm not implying that you are the only one :), it's just you see all those hard traceable little thingies

@bonedaddy, weird, that file is a part of Media Player...at first glance i can't find the problem, gonna try to reproduce it later. So i will check only MSAgent and test it.

0

Share this post


Link to post
Share on other sites

Very strange.. beta6 and beta5 make larger cds/installs than beta2 did

I checked _everything_ in beta6 and got 171 mb, in beta2 i left some things unchecked and got 157 mb. Could be an unique problem, but worth noticing.

0

Share this post


Link to post
Share on other sites

@nuhi

(for WinPE i don't know who is author) if he gives me permission...I'll keep that in mind

I doubt you'll get official support for it. You're not even supposed to have WinPE unless you bought like 3 copies of XP at a time, or had some special arrangement. WinPE is made by Microsoft, which would be why bart made is own :)

0

Share this post


Link to post
Share on other sites

Ok...another thing...some hairsplitting more :)

It is not a bug, i think it is only because some components are not around (dereg something?, delete a entry somewhere in an inf?...infact i have absolutly no idea:wacko: ). I never have needed this...only found out throught the click & crash-method. On a important-scale between 0 till 10 it is 0 or less.

The alert says:

The application could not be initialisized because (DacCom) is not right installed. Install this product once again.

post-70-1084995088_thumb.jpg

post-70-1084995088_thumb.jpg

0

Share this post


Link to post
Share on other sites

Clicking on "OK" brings this message:

Microsoft Managment Console

Snap-In can't be initialisized

Thanks for having tried to strip-down w2k once nuhi! (...it is standing on another paper if this tool ever will reach going public for w2k making smaller...). I love this system same as XP.

post-70-1084995650_thumb.jpg

post-70-1084995650_thumb.jpg

0

Share this post


Link to post
Share on other sites

I am not able to install this installer.plz help me .

It gives these errors at the time of Extraction of exe

Cannot create Data\bootsector.bin:{4c8cc155-6c1e-11d1-8e41-00c04fb9386d}

Cannot create Data\sfc_os.dl_:Zone.Identifier

Some files could not be created.

Please close all applications, reboot Windows and restart this installation

I've tried all these steps but all in vain!

Note: I 've downloaded the installer several times but the result is same.

0

Share this post


Link to post
Share on other sites

@ nuhi

with beta 5 no problem with logagent.exe

only beta 6, rechecked both.

bonedaddy

0

Share this post


Link to post
Share on other sites

@gandalfgrey, I think it's true, can't even test it now, started to work on new version and planned not to release it until 2k reduction support works properly but i see now i'll have to fix this first.

Ok, tomorrow may be a next version, fixed, i hope.

@Alanoll, :rolleyes: , silly me, I knew what winPE is, but i thought that the public versions are all made with batch like bartPE, or is the bart's the only public version available ?

And one more thing...is it advisable to remove OOBE from components, jodeboeck just warned me that it can be a legal issue ?

@ZuluDC, will fix it, thanx again :)

@Mohammed, i just tried downloading it and it works, try to use some download manager like Flashget

@bonedaddy, going to take your word on it and take special concideration when tweaking new version

0

Share this post


Link to post
Share on other sites

I am not able to install this installer.plz help me .

It gives these errors at the time of Extraction of exe

Cannot create Data\bootsector.bin:{4c8cc155-6c1e-11d1-8e41-00c04fb9386d}

Cannot create Data\sfc_os.dl_:Zone.Identifier

Some files could not be created.

Please close all applications, reboot Windows and restart this installation

I've tried all these steps but all in vain!

Note: I 've downloaded the installer several times but the result is same.

0

Share this post


Link to post
Share on other sites

If I remove windows media player from the iso, does that mean I still need to install the windows update for windows media player, even though it doesn't exist? Will windowsupdate tell me to install the updates despite not having WMP installed? Also what is MDAC and OOBE? Can I remove those, or I need to have it installed? Thx

0

Share this post


Link to post
Share on other sites

Good question, i wanted to know exactly that !

So if i dont need to include the updates, that means that i dont include the hotfixes in xpcreate in the first place, or after nLite removes stuff, it removes contents even of the upadate ??

For eg, i have media player in the i386, and i also provide xpcreate with the media player patches and hotfixes.. now if i process the 1386 in nLite and remove the media player, will it even remove the contents of the hotfix that xpcreate slipstreamed ?

I hope i make sense :)

Bye,

Jazz

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.