• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
trainee

TEXTMODE MassStorageDrivers Method

140 posts in this topic

Thanx cdob for the answer
well i used this
[MassStorageDrivers]
"Intel® 82801GR/GH SATA RAID Controller (Desktop ICH7R/DH)" = "OEM"
and still doesn t work i wasted like 6cds until now
I foud this on intel site too
[url="http://www.intel.com/support/chipsets/imst/sb/CS-020825.htm"]http://www.intel.com/support/chipsets/imst/sb/CS-020825.htm[/url]
but still doesn t work the strange thing on this methode is that
iaAHCI = "Intel SATA AHCI Controller" doesn t exsist in textsetup.oem
i even have IAAHCI.CAT, IAAHCI.INF, IASTOR.CAT, IASTOR.INF, IASTOR.SYS, and TXTSETUP.OEM copied over three folders which are
D:\XPCDFE\$OEM$\TEXTMODE
D:\XPCDFE\I386\$OEM$
D:\XPCDFE\I386\$OEM$\Textmode

and again here is what is in winnt.sif
[MassStorageDrivers]
"Intel® 82801GR SATA AHCI Controller" = "OEM"

[OEMBootFiles]
iaAhci.inf
iaStor.sys
iaAhci.cat
Txtsetup.oem


i used a newer version of the sata files here is the file again
Any other suggestion ? :(

Thanx in advance
0

Share this post


Link to post
Share on other sites
Crow, I'm just getting into this $OEM$ integration also. I was interested in getting this done because I'm also using HFSLIP. Then I ran into Fernando1's various conversations about force-fitting difficult NVidia RAID drivers, and he mentioned a program called Windows Unattended CD Creator. It was developed by his friend, Vitali Graf. Go to: [url="http://www.vitaligraf.de/en/index.htm"]http://www.vitaligraf.de/en/index.htm[/url]

I haven't used all of the features of the CD Creator, but I can tell you that it worked great integrating those Intel iaStor drivers. It also integrated (in PnP mode) the IntelINF drivers perfectly.

The nice thing about this program as it will interest you is that it applies TEXTMODE drivers in the traditional $OEM$ manner.

You may want to give it a shot. Vitaly is German, but you can setup the program for English, and he has an English forum. If you give it a go, let me know how it works out for you. Edited by PVU
0

Share this post


Link to post
Share on other sites
hi PVU i m sure that that method will work i got my sata drivers slipstreamed using nlite too but i want to do it with this methode cuz it doesn t Change any file i ll give that software a try
BUT i m still interested in this textmode methode

Thanx
0

Share this post


Link to post
Share on other sites
@TheCrowX

There are reliable CD-RW.

Winnt.sif and txtsetup.oem has to contain the same string.

You may edit txtsetup.oem.
A edited txtsetup.oem may contain 'iaAHCI = "Intel SATA AHCI Controller"'.

ISO9660 directroy name has to be $OEM$, not _OEM_.
ISO9660 names has to be uppercased: $OEM$, WINNT.SIF, TXTSETUP.OEM
Run ISOBuster and compare.

Does your hardware use ID PCI\VEN_8086&DEV_27C3 ?
0

Share this post


Link to post
Share on other sites
I need help peeps.

I've got a new Dell 5150c, with the ICH7R (AHCI) sata controller. Several people here have this same controller onboard and must be facing the same problem I am. Of course the XP setup doesn't recognize any hard drive because of this controller. I've read through every post on this thread, and I've done everything right as far as I can tell but setup STILL does not see the controller and thus no hard drive.

I have a multiboot cd environment, so keep that in mind.

I've got txtsetup.oem and the iaStor.sys, iastor.inf, iastor.cat, iaahci.inf, and iaahci.cat files in the following folders:

CDROOT\PRO1\$OEM$
CDROOT\SETUP\XP\PROFESSIONAL\$OEM$\TEXTMODE

my winnt.sif file has the following relevant entries:

[MassStorageDrivers]
"Intel® 82801GR/GH SATA RAID Controller (Desktop ICH7R/DH)"
"Intel® 82801GR/GH SATA AHCI Controller (Desktop ICH7R/DH)"
"IDE CD-ROM (ATAPI 1.2)/PCI IDE Controller" = "RETAIL"

[OEMBootFiles]
txtsetup.oem
iaahci.cat
iaahci.inf
iastor.cat
iastor.inf
iastor.sys

For good measure, I've copied the iastor.sys file (uncompressed) to the PRO1 folder, as well as the i386 folder. Still not working. What am I doing wrong? Or what am I missing? BTW: in case it matters, I've got a 250GB sata drive hooked up which Dell suggests may be the problem and they said to try changing a BIOS setting on the SATA portion to Combination mode rather than normal mode. I haven't tried that just yet but my feeling is that it is the driver support above that is causing my problem.

Any help is appreciated. Thanks
0

Share this post


Link to post
Share on other sites
Okay, I realized I had left off the critical = "OEM" part within the WINNT.SIF for the [MassStorageDrivers] section.

I've fixed that and now during the initial part of setup (before it would let you partition drives), I get an error immediately after loading the iaStor.sys file that says

Section Files.SCSI.iaStor_ICH7R of the INF file is invalid
0

Share this post


Link to post
Share on other sites

This worked absolutely great!!! All I did was use the exact WINNT.SIF file in the very first post (substituting my data for the "XXXX" fields, of course). Here was the situation I overcame:

We send out server appliances to all our clients and use them to provide remote DBA admin/monitoring services for the client's servers. I recently painstakingly built up a Ghost image to use on these servers that includes a 3Ware 8006-2LP SATA RAID card to provide a RAID 1 mirror for the XP Pro OS we install. We had been using 1U servers that had an Intel® Server Board SE7520BD2 motherboard. I built the original Ghost image by using a scratch manual install from CD with a Floppy to "F6" the 3ware drivers at the beginning. No big deal and I didn't care about unattended because I only had to build up one box from scratch and then Ghost would do the grunt work for all the rest. Well...

We just got our next batch of servers, and lo and behold, our HW vendor has switched our motherboards to Intel® Server Board S5000VSA motherboards. So now my Ghost image is no good due to the changed underlying hardware and there is not only no floppy drive in the new servers, but NO FLOPPY CONTROLLER either!

I tried to slipstream the driver into an XP Pro SP2 CD image using nlite's "Add Driver" (which looks like it just crams it down as compressed files in two places under i386?), but that didn't work. Then I found this thread and simply used the exact WINNT.SIF file and burned another CD (with the drivers tossed into the $OEM$\TEXTMODE\ and I386\$OEM$\ directories). I didn't even care about unattended, I just wanted to get XP loaded somehow, some way, on my 3Ware array sitting on a floppyless mobo! Well now I've killed two birds with one stone, because I have a sweet unattended install CD that includes my 3Ware drivers. I can even use the same CD if the motherboard changes again. I probably only understand about 70% of how this works too, but that's fine with me!

Thank you very, very, much!

0

Share this post


Link to post
Share on other sites

Hi there,

I want to build an installation of xp from my USB-Stick. (It will be handled on my Mainboard as a harddisk ...)

In cause I'm using a RAID0 set on my PC, I want to integrate the RAID Drivers (nForce 4) into the Installation.

Now I want to try the Textmode-Method, but I have a little problem, because I also want to integrate the SATA Driver (Silicon Image).

I read in the deploy.chm that I'm able to add multiple instances, but -naturally- this is not documented by Ms.

Could anybody give me an answer how to do it ?

My problem is: I have two txtsetup.oem files -one for the nvraid(RAID) and one for the sil3132(SATA)- and

I don't know what to do now.

Must I add the entries of the one txtsetup.oem to the other txtsetup.oem or am I able to create Subfolders and

set the path in the [OEMBootFiles]-Section to the txtsetup.oem's ?

Or is it better to install the Silicon Image SATA Driver over the OemPnPDriversPath.

I don't need the Silicon Image Driver at Boot-up, just the nvraid/nvatabus Drivers !

winnt.sif

[MassStorageDrivers]
"NVIDIA RAID CLASS DRIVER (required)"=OEM
"NVIDIA nForce Storage Controller (required)"=OEM
"Silicon Image SiI 3132 SATALink Controller for Windows XP/Server 2003"=OEM

[OEMBootFiles]
idecoi.dll
nvatabus.sys
nvraid.cat
nvraid.inf
nvraid.sys
nvraidco.dll
txtsetup.oem
si3132.cat
SI3132.inf
Si3132.sys
SilSupp.cpl
SiWinAcc.sys
TxtSet.oem

bzzz.png

You can see that I renamed the TxtSet(up).exe in the moment, so don't wonder - it's just temporary renamed til I found a solution ...

Greetz

Greenhorn

Edit: Sorry for this Spam, I found the answer in this thread ... :blushing:

Edited by Greenhorn
0

Share this post


Link to post
Share on other sites

EDIT: here is my previous post

Does this method override txtsetup.sif?

I only ask because I noted that you have to include the line

"IDE CD-ROM (ATAPI 1.2)/PCI IDE Controller" = "RETAIL"

to prevent the system from being unable to find the boot device (this is a reference to a device also found in txtsetup.sif). I have already added drivers using driverpacks for mass storage devices, I am just wondering if I need to reference these drivers again in [MassStorageDrivers] or only the above line of code in order to take advantage of mass storage drivers from both places (i will be using my installation disk on a variety of hardware and am aiming for the maximum compatibility)

For reference, this method does override txtsetup.sif, or rather, it overrides where it looks in that file. I placed a different raid controller in my test system which worked before I defined a [MassStorageDrivers] section or [OemBootFiles] section in my winnt.sif and it was unable to find the drive during the installation.

Previously, I had added entries to winnt.sif under the IDE cdrom one as such:

"Adaptec AHA-294X/AHA-394X/AIC-78XX SCSI Controller" = "RETAIL"
"Adaptec AHA-294XU2/AIC-7890 SCSI Controller" = "RETAIL"
"Adaptec RAID Storport Driver" = "RETAIL"
"Agilent HHBA-510x PCI Fibre Channel Controller" = "RETAIL"
"Compaq Drive Array" = "RETAIL"
"Compaq Fibre Channel Host Controller" = "RETAIL"
"Smart Array 53xx/63xx Controller" = "RETAIL"
"Emulex Scsiport Fibre Channel Host Adapters" = "RETAIL"

with the same names listed in txtsetup.sif. However, with something like 50 or so drivers to list, or some other factor I may be unaware of, the presence of all of those devices in [massstoragedevices] prevented it from detecting the controller I was trying to add to the install:

"AMCC 3ware 7000/8000 Series ATA RAID Controller" = "OEM"

As listed previously in this thread, this is the only method that works with this controller.

I think it may be possible to get past this by referencing txtsetup.sif in the oembootfiles section, but I'm not sure if that would work.

Edited by penpen
0

Share this post


Link to post
Share on other sites

Just a thort here why not use the Driverpacks Mass Storage drivers from driverpacks.net and slipstream them directly into your setup cd?

Sorry if this has already been mentioned :(

Stoner81

0

Share this post


Link to post
Share on other sites
Just a thort here why not use the Driverpacks Mass Storage drivers from driverpacks.net and slipstream them directly into your setup cd?

Sorry if this has already been mentioned :(

Stoner81

This is mentioned on the driverpacks forums. To quote from that link:

; Disabled! driver conflicts with the Silicon Image 3112r and Silicon Image 3132 drivers.

; if you need this, unzip, disable [s-5] [s-5-A] [s-B] and [s-C] and enable this section

; ( to enable, change ms_count=0 to ms_count=1 )

This is specific to the AMCC 3ware 7000/8000 series sata controller drivers. Later in that same thread, its stated that these drivers were removed from the driverpacks project (the initial post is in reference to a much older version of DriverPacks). However, for my disk I just ended up using a workaround with a multiboot, with a different winnt.sif for if I am installing on a system using that card, or a different one I can use if I just want to use the native driverpacks drivers (which use method 1 for driver slipstreaming). The guide outlined in the first post of this thread is what i think is known as method2, using $OEM$\TEXTMODE and defining an [OemBootFiles] section in winnt.sif/unattend.txt

I also found that with all of the driverpacks mass storage drivers enabled, it takes a long time for the installer to start as it loads every mass storage driver into memory every time you run the installer. For this reason, I may end up making a few other multiboot options to load different sets of drivers to allow the installer to run a little more smoothly at the start. Since method1 drivers add lines for them into txtsetup.sif, you should be able to directly reference them in winnt.sif as such:

;this is example code from txtsetup.sif, of lines which were added by driverpacks
[SCSI]
aic78xx = "Adaptec AHA-294X/AHA-394X/AIC-78XX SCSI Controller"
aic78u2 = "Adaptec AHA-294XU2/AIC-7890 SCSI Controller"
arc = "Adaptec RAID Storport Driver"
afcnt = "Agilent HHBA-510x PCI Fibre Channel Controller"
cpqarray = "Compaq Drive Array"

taking these lines, we should be able to create a winnt.sif that only looks for those specific drivers by placing them in [MassStorageDevices] as such:

;this is example code from winnt.sif, referencing the lines above from txtsetup.sif
[MassStorageDrivers]
"IDE CD-ROM (ATAPI 1.2)/PCI IDE Controller" = "RETAIL";if you are going to define any set of method1 drivers in winnt.sif, you need at least this one.
"Adaptec AHA-294X/AHA-394X/AIC-78XX SCSI Controller" = "RETAIL"
"Adaptec AHA-294XU2/AIC-7890 SCSI Controller" = "RETAIL"
"Adaptec RAID Storport Driver" = "RETAIL"
"Agilent HHBA-510x PCI Fibre Channel Controller" = "RETAIL"
"Compaq Drive Array" = "RETAIL"

I'll probably test that out later tonight and post my results.

0

Share this post


Link to post
Share on other sites
Once you have it working we can work on removing what you don't need. Its not too hard to rewrite the txtsetup.oem file, that is what RASOR does...its around here somewhere I swear...

Are there any updates to RASOR?

Is RASOR open source?

Does anyone have a working URL to download RASOR?

0

Share this post


Link to post
Share on other sites

Was wondering the same thing.

Is this also applicable on XP Pro x64 Edition install-images? It seems that the nlite textmode driver-slipstream does not work at all for the Intel Matrix set of storage chips.

0

Share this post


Link to post
Share on other sites

I like this method and with the Intel SATA drivers it works like a charm. Thank You for this!

Intel® Matrix Storage Manager Driver 8.9.0.1023

I've put the drivers in the two folders:

$OEM$\TEXTMODE\

I386\$OEM$\

Then I opened the TXTSETUP.OEM and looked up the controller names in the [scsi] section:

[scsi]

; iaAHCI.inf
iaAHCI_ESB2 = "Intel(R) ESB2 SATA AHCI Controller"
iaAHCI_7RDH = "Intel(R) ICH7R/DH SATA AHCI Controller"
iaAHCI_7MMDH = "Intel(R) ICH7M/MDH SATA AHCI Controller"
iaAHCI_8RDHDO = "Intel(R) ICH8R/DH/DO SATA AHCI Controller"
iaAHCI_8MEM = "Intel(R) ICH8M-E/M SATA AHCI Controller"
iaAHCI_9RDODH = "Intel(R) ICH9R/DO/DH SATA AHCI Controller"
iaAHCI_9MEM = "Intel(R) ICH9M-E/M SATA AHCI Controller"
iaAHCI_10DDO = "Intel(R) ICH10D/DO SATA AHCI Controller"
iaAHCI_10R = "Intel(R) ICH10R SATA AHCI Controller"
iaAHCI_PCHM = "Intel(R) PCHM SATA AHCI Controller 4 Port"
iaAHCI_PCHM_1 = "Intel(R) PCHM SATA AHCI Controller 6 Port"
iaAHCI_PCH = "Intel(R) PCH SATA AHCI Controller"

; iaStor.inf
iaStor_ESB2 = "Intel(R) ESB2 SATA RAID Controller"
iaStor_7RDH = "Intel(R) ICH7R/DH SATA RAID Controller"
iaStor_7MDH = "Intel(R) ICH7MDH SATA RAID Controller"
iaStor_8R9R10RDOPCH = "Intel(R) ICH8R/ICH9R/ICH10R/DO/PCH SATA RAID Controller"
iaStor_8ME9MEPCHM = "Intel(R) ICH8M-E/ICH9M-E/PCHM SATA RAID Controller"

After that I modified my WINNT.SIF (German version of Windows) and added the following lines:

[MassStorageDrivers]
"Intel(R) ESB2 SATA AHCI Controller"="OEM"
"Intel(R) ICH7R/DH SATA AHCI Controller"="OEM"
"Intel(R) ICH7M/MDH SATA AHCI Controller"="OEM"
"Intel(R) ICH8R/DH/DO SATA AHCI Controller"="OEM"
"Intel(R) ICH8M-E/M SATA AHCI Controller"="OEM"
"Intel(R) ICH9R/DO/DH SATA AHCI Controller"="OEM"
"Intel(R) ICH9M-E/M SATA AHCI Controller"="OEM"
"Intel(R) ICH10D/DO SATA AHCI Controller"="OEM"
"Intel(R) ICH10R SATA AHCI Controller"="OEM"
"Intel(R) PCHM SATA AHCI Controller 4 Port"="OEM"
"Intel(R) PCHM SATA AHCI Controller 6 Port"="OEM"
"Intel(R) PCH SATA AHCI Controller"="OEM"

"Intel(R) ESB2 SATA RAID Controller"="OEM"
"Intel(R) ICH7R/DH SATA RAID Controller"="OEM"
"Intel(R) ICH7MDH SATA RAID Controller"="OEM"
"Intel(R) ICH8R/ICH9R/ICH10R/DO/PCH SATA RAID Controller"="OEM"
"Intel(R) ICH8M-E/ICH9M-E/PCHM SATA RAID Controller"="OEM"

"IDE CD-ROM (ATAPI 1.2)/PCI IDE-Controller"="RETAIL"

[OEMBootFiles]
iaahci.cat
iaAHCI.inf
iastor.cat
iaStor.inf
IaStor.sys
TXTSETUP.OEM

For the English version of Windows it's important to change the following line from:

"IDE CD-ROM (ATAPI 1.2)/PCI IDE-Controller"="RETAIL" to

"IDE CD-ROM (ATAPI 1.2)/PCI IDE Controller"="RETAIL"

Perhaps this very important difference between the two language versions should be mentioned in the first post of this thread?

Now my problem is, that I want to create a CD with SATA drivers for a repair installation (not recovery console) of Windows XP, but when I use this CD I haven't the chance to start a repair installation. After choosing the partition the setup immediately starts to copy files onto it ending up with a second Windows installation in the same partition.

Is there a way to use the TEXTMODE method to create a CD with which I'm able to start a repair installation?

A similar situation is discussed here: http://www.msfn.org/board/index.php?showtopic=136061

best regards

Noxolos

Edited by Noxolos
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.