Sign in to follow this  
Followers 0
xper

Windows Installer Helper Utility

522 posts in this topic

when using the skipsettings switch the install.ini isn't loaded

0

Share this post


Link to post
Share on other sites

It's loaded here. Be sure install.ini is in same folder as wihu.exe.

Benjamin Kalytta

0

Share this post


Link to post
Share on other sites

No problem benjamin.

Actually, there are some other things i'd like to be added:

1. a commandline parameter to skip the software install part. That way i could run your program twice. Once through cmdlines.txt to create an admin account and setup the computer settings. The second time after first logon with the new account to just run and install the software part, here it would skip the account screen.

2. an option to rename the default Administrator account instead of creating a new admin

3. a possibility to use the name and password of the newly created account as variables in the install.ini file (e.g. %newuser%, %newpassword%).

This is used in the cmdlines.txt part to run a batch file which injects the autologon parameters into the registry and thus lets you autologon using your newly created account.

0

Share this post


Link to post
Share on other sites

@syntax_13:

You could use wihu /autoinstall 0 /username "New User" /userpassword 1234567890

In this case, settings will not be skiped.

Setting %NewUserPassword% is a security risc, don't know if it is so suitable.

Changing Administrator isn't that easy. What about just disabling it?

Nevertheless I added this feature at this moment. May be there will be a command line switch in future to disable it. %NewUserPassword% and %NewUserName% is now available.

Benjamin Kalytta

0

Share this post


Link to post
Share on other sites

Who programmed this tool? I'd prever to get the source and to include it directly in my code.

Benjamin Kalytta

0

Share this post


Link to post
Share on other sites

when I use the switch /skipsettings, I get the screen below, but when I don't use the switch it shows up normal

EDIT: just did another test, when I call wihu.exe from the commandline without the switch its also like in the screenshot

post-70-1088429790_thumb.jpg

0

Share this post


Link to post
Share on other sites

@MarcoTips: Do you use the newest version. Please try to download it again (WIHU 1.6.1).

Or may be your Ini file isn't correct?

Benjamin Kalytta

0

Share this post


Link to post
Share on other sites

I'm using 1.6 just downloaded it again and I'm using the ini file that is provided, if I don't run it from the command line then it shows up properly

0

Share this post


Link to post
Share on other sites

@syntax_13: thx, I'll take a look at it.

@MarcoTips: Strange you're right ... I'll fix this soon.

Benjamin

0

Share this post


Link to post
Share on other sites

I would like to make one more request, an option to specify the time when windows reboots, and make it visually so that the user sees when it is going to reboot, I would like to have this option so that the shell can load properly before it reboots

0

Share this post


Link to post
Share on other sites

It's not possible. It's not predicable how long installation process lasts.

Benjamin

0

Share this post


Link to post
Share on other sites
... Be carefull, or you will be asked to update your program to do everything, including washing the dishes! ...

You were warned!

Keep up the good work, BenjaminKalytta!

0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.