Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

dx won't install and component

- - - - -

  • Please log in to reply
33 replies to this topic

#26
svasutin

svasutin

    Member

  • Member
  • PipPip
  • 192 posts
  • Joined 08-January 04
Once again I'm back, and going to dissappear to try some more options. So let me start out once again by saying thank you.

It appears this thread was about to diverge. I think my issue is with my original CD; however, this does not explain why dx 9 correctly when I double click dxsetup.exe.

On a side note, I called up Msft and they agreed to ship me a new one for free. All retail/upgrade versions are entitled to get 1 free. When SP2 ships, I can get a new CD for $14.00 USD.

Anyway, I'm going to get rid of my unattend and restore dosnet and see what happens. If I'm lucky, I get to attempt this 3 times a day (wake up/lunch/sleep).

Actually...brb


How to remove advertisement from MSFN

#27
svasutin

svasutin

    Member

  • Member
  • PipPip
  • 192 posts
  • Joined 08-January 04
Fun stuff I tell you. My dosnet.inf has two [files], [OptionalSrcDirs], and [ForceCopyDriverCabFiles]:rolleyes:

And they appear to be coming from the /integrage:<path> option for
kb840374

I guess msft's installer doesn't check for an updated dosnet.inf, nor svcpack.inf for that matter (I remember it over wrote my old svcpack.inf).

As for my dosnet.inf, I install the patch(es), I extract conents, compare the files to see which are really in use/updated, then move the required files to my i386, and finally check my dosnet.inf to see if the file is already listed. If it ain't, I add it to the [files] and [force...] sections. Since I have a system running dx9, I used my above process for the contents of the opk.

Once again, I'll be back, and thank you.

PS: if we're going to diverge, there is a new msft tweakui powertoy. Anyone know of usable command switches? Have tried /q, /qb, /s /v/q(|n|b|!), but then again, my dosnet is messed up. Oh nevermind, one thing at a time. :)

PPS: Thank you AMD for the download. I'm between vs 97 and vs .nyet right now. I have the software, just in the process of trying to get my xp correct first.

#28
prathapml

prathapml

    Follow the rules please :-)

  • Patrons
  • 6,791 posts
  • Joined 14-November 03
  • OS:Windows 8 x64
  • Country: Country Flag

there is a new msft tweakui powertoy.  Anyone know of usable command switches?

Tried searching ? TweakUI switches

P.S. : The above mentioned powertoy is not 'new' - it was released around the time of SP1 for WinXP.
Posted ImageCheers !!!   Donate to MSFN and Help Keep This Site Running
||Please Read the Forum Rules||  Etiquette   || Welcome to MSFN - Forum Basics || Before posting
prathapml :: MSFN Supermod :: Private Message me if you ever have a problem while at MSFN

#29
svasutin

svasutin

    Member

  • Member
  • PipPip
  • 192 posts
  • Joined 08-January 04
Some 1,400 files later, I've got a few notes:

First, dosnet.inf does have two [files] sections

Next, upon removing useless files, I have 830 files (includes everything needed); getting rid of kb/q exe's, security cat's, inf's, and multi language I am left with 615 files. From these 615, there are 453 included in the i386 folder by default. Although, I could be off by 30 files either way (comparing sp1 i386 to the extracted contents leads me to believe I can further remove another 26 files).

Finally, where am I getting some of my files:

dplayx.dll 5.3.0.903 <- msfn's rar gave 900
dpwsockx.dll 5.3.0.903
dsound.vxd <- 1.5 year diff between sp1 and dx9 rar

fpencode.dll 2003.1100.5510.0
hccoin.dll 5.1.2600.1515 <- not sp1 nor update file
msconv97.dll 2003.1100.5510

qsaf.dll <- which 1 do you have: 9.0.0.2980 or 6.5.1.900

usbccgp.sys 5.1.2600.1515 <- these should be 1243
usbehci.sys 5.1.2600.1515
usbhub.sys 5.1.2600.1515
usbohci.sys 5.1.2600.1515
usbport.sys 5.1.2600.1516
usbuhci.sys 5.1.2600.1515


So now I get the fun of actually replacing files with my dvd, then finally testing the opk.

Prathapml, on the old msft powertoys, the svqn switches work fine, it's with the new powertoy.

Give me one more day, and I should have a new DVD.

Once again, thank.

#30
svasutin

svasutin

    Member

  • Member
  • PipPip
  • 192 posts
  • Joined 08-January 04
As for qchain, I found an interesting kb, 815062
updated qchain fix for xp/2k

Anyway, looks like I really messed things up somewhere :)
Stupidly I deleted my entire image and started from scratch. Now my setuperr.log is hugh.

Thank you, all of you, for all your comments and help. I've got lots of work trying to figure out what to change and replace.

Does msfn keep a list of up to date files, including version numbers, referenced to kb/q files, and placement in the cmdlines vs svcpack? If not, anyone interested in starting one?

Thank you

#31
prathapml

prathapml

    Follow the rules please :-)

  • Patrons
  • 6,791 posts
  • Joined 14-November 03
  • OS:Windows 8 x64
  • Country: Country Flag

Prathapml, on the old msft powertoys, the svqn switches work fine, it's with the new powertoy.

The reason you couldn't get it to work is because you did not have a good enough look at the link here :
how to get TweakUI to install silent
Posted ImageCheers !!!   Donate to MSFN and Help Keep This Site Running
||Please Read the Forum Rules||  Etiquette   || Welcome to MSFN - Forum Basics || Before posting
prathapml :: MSFN Supermod :: Private Message me if you ever have a problem while at MSFN

#32
svasutin

svasutin

    Member

  • Member
  • PipPip
  • 192 posts
  • Joined 08-January 04
coo Prathapml

I've uploaded a file containing all the updates I use if anyone is interested. It's mylist.zip and is a 47kb (compressed to 7kb) text file. It's broken down into svc, cmdline, and gui sections by date.

It appears the problem is not with my install, but something to do with my dvd-r's. After receiving my new xpsp1a pro cd from msft, I find I encounter the same problems with the same files :) ; I suppose I should try installing and extracting from a cd device to see if there is a difference.

Thank you once again.

#33
svasutin

svasutin

    Member

  • Member
  • PipPip
  • 192 posts
  • Joined 08-January 04
I don't suppose other people could check their setuperr.log for similar issues. I have 5 recurring file issues:

Setup detected that the system file named [c:\windows\system32\FileNameBelow.dll]is not signed properly by Microsoft.  This file could not be restored to the correct Microsoft version.
Use the SFC utility to verify the integrity of the file.

FileNameBelow is, well, below

d3dim700.dll, mmcndmgr.dll, msvidctl.dll, mswebdvd.dll, qmgr.dll

Your setuperr.log is located in c:\windows, and should only be updated when xp is installed. Presently, mine is 2k

Thank you

#34
svasutin

svasutin

    Member

  • Member
  • PipPip
  • 192 posts
  • Joined 08-January 04
Well I've changed my DVD-R to a DVD/CDRW, then to a CD w/o success. I have changed the internal cables ~ again no luck. Guess I get to try a new hard drive.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users