• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
Sign in to follow this  
Followers 0
Raiden

PROB | ATI DVD-Decoder

69 posts in this topic

I only recently came across this prospective solution recently, so bear with me. I have tried the suggestion made by polymorphean on aug 27, 2004, tried the suggestion made by OCedHrt on dec 1, 2005 and finally the suggestion made by edadat on dec 7, 2005 - all without success.

the common failed moment is the following error message:

This installation needs to be launched from the ATI DVD Web Wizard
Setup will now exit.

Any further suggestions or comments as to what I might be doing incorrectly.

thx
0

Share this post


Link to post
Share on other sites
Im sorry my dear friend, but did you take the trouble of reading my post, please go through it

Get the file here(http://www2.ati.com/drivers/setup.exe)

Then form the setup file you have do a admin install using
CODE
setup.exe /A
as the parameters

This will give you the following files
1. ATIDec.msi
2 Common folder

Now note that the Common folder contains all the filters and that the executable to this is the ATIDec.msi but if you click on it it will give you an error message that it cannot be run from the msi directly(bul*****). So I happened to check out this site and while going through the Quicktime deployment issues found out the solution.


So now to overide all the msi and other restriction you can run the msi directly without modifying or anything by this command
CODE
msiexec /i ATIDec.msi ISSETUPDRIVEN=1 /QB


The command ISSETUPDRIVEN=1 overides the cannot be run from the msi directly condition without even having to touch the ATIDec.msi with ORCA(A Msi editing tool). For those installing on fresh XP SP 2 machines it will give you an error that it needs some ISS scripting engine is not installed no to worry try to run the setup.exe directly it will give you an error message saying that it needs to be run from the ATi CD-wiz, do not click on ok, first go to your temp(C:\Documents and Settings\Your Namet\Local Settings\Temp) directory and from there look around for a file named ISScript9.Msi

Then in order to not get that error message and be able to install write a cmd file ATIDVD.cmd with the following code in it

CODE
msiexec /i ISScript9.Msi /qb
msiexec /i ATIDec.msi ISSETUPDRIVEN=1 /QB


Please note you need to put the actual file locations in place of the file names, I have tried this and I know it works...

Hope this help...

This is the method it should have been done, please don't tell me about all the other person's method, try out my way if it does not then complain, otherwise leave, peace Edited by tommy_vercetti
0

Share this post


Link to post
Share on other sites
Tommy, my apologies for not reading the entire email chain thoroughly. I simply lost patience with the approaches and attempts that I had made. Your solution not only worked, it worked first time, and was by far and away the simplest approach. My thanks to you for your ingenuity and clearly your patience with me. :thumbup
0

Share this post


Link to post
Share on other sites
Can't wait to get home and try this.

I have to ask: anyone noticed a difference in the decoder/installer for different versions of the ati cards?

For example: I've got an 9800pro and X800pro and both CD's labelled to avoid confusion, but when I install the decoder *ONLY* the 9800 disk will
work for either card.

Odd, but frustrating.

But if t_v's meathod is as sound as it sounds, all will be bliss.
0

Share this post


Link to post
Share on other sites
Hey dude,

Do post whether it worked or not. would be happy to know that it worked.
0

Share this post


Link to post
Share on other sites
Hi This post has been very useful for me in installing the ATI DVD Decoder. Thank you very much tommy_vercetti.
0

Share this post


Link to post
Share on other sites
Has anybody old SIM file to allow decode more than 2.1 channels ??

It's from version 2 , today's version is probably 6
0

Share this post


Link to post
Share on other sites
Could anboy tell me that the version above(http://www2.ati.com/drivers/setup.exe) is the latest one or have there been any new versions out, could anybody with newer cards post there views, thanks
0

Share this post


Link to post
Share on other sites
[url="http://www2.ati.com/drivers/setup.exe"]http://www2.ati.com/drivers/setup.exe[/url] unpacks the same as [url="http://www2.ati.com/drivers/6-8_xcode_35179.exe"]http://www2.ati.com/drivers/6-8_xcode_35179.exe[/url] (byte-identical as verified on 2006/11/02).
0

Share this post


Link to post
Share on other sites
I downloaded and installed [url="http://home.valornet.com/ddriver/download/ATI_Decoder.exe"]http://home.valornet.com/ddriver/download/ATI_Decoder.exe[/url] and it works fine. Unfortunatly, my 3D accelleration doesn't work as well. Tuxracer is like riding a tricycle in the snow. The unninstall is a dead link. Does anyone know how to rip it out manually? You'd really be helping me out a lot, as if i cannot rip it out, i most likely will rip out my hair instead... and that's *just not productive...
0

Share this post


Link to post
Share on other sites
Redid my box a few months back and the instructions by mr V worked as advertised.

Made it into my pc rebuild directory.
0

Share this post


Link to post
Share on other sites
Is there any advantage to using the official ATI DVD decoder over the Cyberlink decoder included in Shark's [url="http://www.msfn.org/board/index.php?showtopic=66826&st=0"]"Vista Codec Pack"[/url]?
From what I understand, the ATI DVD codec is 3d hardware accelerated while the Cyberlink codec is software emulated.
Does anyone know for sure? Does anyone have CPU utilization numbers for both? Edited by mr_smartepants
0

Share this post


Link to post
Share on other sites
Nevermind, I just built a switchless installer for this and installed it but the ATI package is just a repackaged Cyberlink PowerDVD decoder.

CPU utilization on my notebook is identical between both packages (between 20-30%) :rolleyes:
So much for the "hardware accelerated" claims.

Oh well, if someone requests it, I'll post directions to build your own switchless installer (.exe) for this.

**edit
Anyone know how to enable hardware acceleration in WMP11?
Tools->Options->Performance->Advanced->Prefered decoder (greyed out)

I have 9800Pro with ATI decoder installed properly.
Is there a reg entry that I missed?
I tried this utility to 'force' the decoder but it didn't work either.
[url="http://www.microsoft.com/downloads/details.aspx?FamilyId=DE1491AC-0AB6-4990-943D-627E6ADE9FCB&displaylang=en"]MS Link[/url] Edited by mr_smartepants
0

Share this post


Link to post
Share on other sites

good news, i repackage ati dvd decoder with install rite and it work for me and no need for cd checking or anything... It'll install silently and the only way to tell if it's installed, go to control panel and look at listing under add/remove programs and you'll see "ATI DVD Decoder"

Download

ATI DVD Decoder Ver 3.0.1 / 2.8mb / Updated 8-16-04

no switch are need and let me know if it worked or not.

EDIT: Uploaded newer one, and got rid of bunches of useless registry, mostly are unrelated to ati.

Hey dude, the link to the file is dead. Just tried it and it locked up my browser, had to go through the task manager to shut down the browser and then restart. (BTW... Windows XP MCE)

Not sure when it went, but I had to goto another post that allowed me to download directly from ATI. Been looking for that file all darn day. :lol: I have the CD from my dads ATI card (Raedon 9500), but the decoder says can't find ATI hardware. :} Oh well. Found the link to the ATI decoder from the site, and since the wizard wouldn't download it it took me forever to find the darn thing. Oh well, if you get the file back up you can repost. Koodous for trying though, I was hoping the link was still up.

Third page here on the forum you can find the file from ATI directly if you want it. Till later dude, nice try though.

Edited by davidlb11
0

Share this post


Link to post
Share on other sites

Hey "dude". What did you expect from a link that is over EIGHT YEARS OLD, and that was last discussed over five years ago? It must have worked well since no one has needed to discuss it since. I think that deserves a whole lot more than "nice try". Since you were able to find a link to a file that worked for you, it would be kind of you to post that link just in case there are others looking for that type of solution, you know, save someone else from having to look "for that file all darn day", ie give back to the community.

Cheers and Regards

0

Share this post


Link to post
Share on other sites

?Post#16 - SETUP.EXE

Clear TEMP folder, Run, DO NOT click "ok" when msg "must be run from", copy files/folder from TEMP folder to "elsewhere", follow install instructions (see other posts) for the two MSI files.

Notes/warnings:

This may or may not work/function depending on your ATI card. "Buyer beware".

Why? Bro had gotten a used "ATI All In Wonder VE PCI" (no CD - obtained drivers/software from ATI - YES the correct ones) and it refuses to allow non-copy-protected (recorded himself for a sermon) videos to be played from his videocam to edit for the WWW. He wound up using a webcam instead.

So... if it works for you, fine, otherwise don't complain and don't post saying "doesn't work". Why? I do NOT know and it wasn't worth the effort to figure it out. In addition, trying this may be construed as questionably legal even though you own the card but have no CD.

Frustrating, isn't it? :(

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.