Sign in to follow this  
Followers 0
opensurf

Problem with Settings in WIHU 2.0.41.1

12 posts in this topic

Hi Benjamin,

i have testet the new settings in [settings] (thanks for skipsettings and resizable probertysheets!).

When "skipsettings" in [settings] isn't used anything work's fine, but when i activate "skipsettings=1" in your install.ini, i get an errormessage "Fehler 87, Installation von "Just open calculator" konnte nicht gestartet werden: Falscher Parameter.C:\WINNT\system32\calc.exe".

I selected only "Just open calculator" and called wihu.exe without parmaters.

Thx

0

Share this post


Link to post
Share on other sites

Thx for quick response, but now i get the following message: "Fehler 1326, Installation von "Just open calculator" konnte nicht gestartet werden: anmeldung fehlgeschlagen: unbekannter Benutzername oder flasches Kennwort. C:\WINNT\system32\calc.exe. :blushing:

I used your install.ini and activated "skipsettings=1" and called wihu.exe without parmaters and selected only "Just open calculator".

CU

0

Share this post


Link to post
Share on other sites

Edit: Hmm, there are many problems with user creating settings ... I decided to remove entire existing user loading things.

Benjamin

0

Share this post


Link to post
Share on other sites

additionally i removed the complete sections [users]. The programs should be installed with the currently logged in user and i didn't want add additional users.

Now i get the message "Fehler 87, Installation von "Just open calculator" konnte nicht gestartet werden: Falscher Parameter.C:\WINNT\system32\calc.exe" again.

Thx, opensurf

0

Share this post


Link to post
Share on other sites

Please don't remove a feature i was waiting for so long. At least make it an option!

But if you decide the other way, and you are the boss of the program, just keep the good work.

0

Share this post


Link to post
Share on other sites

As I said ... I'll revise entire user account behaviour which causes the problem here. May be tommorow I'll release revised version 2.0.42.0.

Just take a look at "Changelog" thread for alternative feature I'll add instead.

Benjamin

0

Share this post


Link to post
Share on other sites

@opensurf

Now that Benjamin has released a new version, are those errors gone you reported before?

0

Share this post


Link to post
Share on other sites

The problem with the new way is that you need to hardcode the users that you want to edit, not having graphical and runtime way to do it. What i think is, if you have the code and is working, why not leave it, at least defaulted to off. And only show it for example with a /ShowLocalUser or a checkbox in the users dialog.

The new way is very nice, but also keep the GUI editing feature!! Just a wish ;)

Thanks

0

Share this post


Link to post
Share on other sites

Olá! ;)

I'm in contact with Benjamin and according to what I know there were big problems dealing with modifying already existing users. That's why he has chosen to remove the feature or at least replace it with some easier methods. Generally I agree with that because it's better not to have a function then to have it but not working properly. :)

I don't think it would help much to disable or enable it by a command line switch because the feature has to be coded, of course, and that is what brings the trouble, not necessarily using it.

The new way is very nice, but also keep the GUI editing feature!! Just a wish

Yes, I agree with that. GUI would be nice, too. ;)

Até a proxima vez

0

Share this post


Link to post
Share on other sites

@Benjamin

Now that Benjamin has released a new version, are those errors gone you reported before?

The problem still exist, but i possible know :blushing: the problem:

- when i start WIHU with commandline /skipsettings, in the programcode the variable "UseCurrent" is always set to 1

- but when i start WIHU without commandline and skipsetting=1 is activatet in [settings], the userdialog is always skipped, but "UseCurrent" isn't set to 1.

Could this the problem?

CU

0

Share this post


Link to post
Share on other sites

Yes opensurf you're right ... I missed to set UseCurrent=1 when reading this from ini file.

Benjamin

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.