Sign in to follow this  
Followers 0
Gape

New Features of Version 2.0

202 posts in this topic

:hello: Maraba, komshu  :D

Why? Were there any bugs???

USB mass storage device suport is very usefull in 98.

Is it possible not to uninstall them when uninstalling RC1 and then install RC3?

Or to put them in the next version?

Merhaba :D

Yes, there are some bugs, and some problems.

You can use Maximum Decim's USB drivers, they're very good. Or don't uninstall RC1, install RC3 over RC1.

0

Share this post


Link to post
Share on other sites

they should be updated to support all usb flash drives and cameras then it would be worthwhile.

0

Share this post


Link to post
Share on other sites
they should be updated to support all usb flash drives and cameras then it would be worthwhile.

No driver can support ALL usb flash drives and cameras.

There are many different chips and protocols used and therefore only limited set of devices can be supported. Maximus Decim pack relies on Windows ME files, i.e. FIVE years old drivers. Windows XP is newer and has better support but backport it to Windows 98 seems to be impossible.

Maybe somebody skilled with free time (do you know anybody?) could write the driver, but to test it means tho have several hundreds of different flash disks and cameras - this is impossible for one person, and even for small company.

The only way is to use what suits best to you - either Maximus Decim driver, or original manufacturer drivers.

Petr

0

Share this post


Link to post
Share on other sites
BTW, does anybody know any tool that logs http transactions? It would good to see what requests are sent by the Internet Explorer.

The Proxomitron web filter, besides blocking ads and lots of other cool tricks, can log all HTTP activity.

You can get it here along with a patch that fixes a lot of interface issues and makes it generally look and work better...

http://www.xs4all.nl/~vsetten/prox/

And if you dig using Proxomitron (I've been using it for 5 years), you'll love the JD5000 filter set...

http://www.jd5000.net/proxo/

0

Share this post


Link to post
Share on other sites
Just an idea - what about to add the right link to the registry so that the Windows Update menu item in Internet Explorer will really point to Windows Update site, i.e. http://v4.windowsupdate.microsoft.com/

I failed to find the right place just now, probably there are some redirects.

Maybe it will be different for original IE 5.0 and newer 5.5 and 6.0sp1.

Petr

So I played with Proxomitron and things are really strange.

All versions of IE seems to use the first request at address

http://www.microsoft.com/isapi/redir.dll?p...&os={SUB_OSVER}, where:

{SUB_PRD} = ie

{SUB_CLSID} = Locale ID, i.e. 0x0409 for US English, 0x0407 for German, 0x0405 for Czech etc.

{SUB_PVER} = 5.0 for IE 5.0, 6.0 for IE 6.0 (SP1)

{SUB_OSVER} = 98 for Windows 98 (SE)

So for US English IE 5.0 the request is:

http://www.microsoft.com/isapi/redir.dll?p...ar=ienews&os=98

and the response from Microsoft is redirection to the fillowing pages (for Locale ID 0401 to 0420):

0401, 0402, 0403, 0404, 0407, 0409, 040d, 040f, 0411, 0417, 0418, 041b, 041c

http://windowsupdate.microsoft.com/default...=productupdates

0406, 0408, 040a, 040b, 040c, 040e, 0410, 0412, 0413, 0414, 0415, 0416, 0419, 041a, 041d

http://windowsupdate.microsoft.com

0405 (Czech):

http://www.microsoft.com/windows/ie_intl/cs/

Both http://windowsupdate.microsoft.com/default...=productupdates

and http://windowsupdate.microsoft.com is redirected to

http://v4.windowsupdate.microsoft.com/ - real Windows Update site.

Just for Czech Locale ID it goes to different place.

For US English IE 6.0 SP1 the request is:

http://www.microsoft.com/isapi/redir.dll?p...ar=ienews&os=98

The redrection for all locales is to http://windowsupdate.microsoft.com/ - again with exception of locale 0405 (Czech) which redirects directly to http://v4.windowsupdate.microsoft.com/cs/default.asp

So the problem exists just for 0405 Czech locale (at least from 32 locales tested) and iis caused by wrong setting of the Microsoft server.

I will try to solve it with Microsoft, and if necesary, in Czech localization of SP 2.0.

Sorry for suggesting bad idea.

Petr

0

Share this post


Link to post
Share on other sites

Hi Gape,

regarding QFE registry entries, I have read your half year old discussin where you described that it is not easy to put registry entries just for files actually installed.

If added the possibility that files can be installed also later by the preserving mechanism, it is almost impossible I think.

I suggest an easy way - just put to the registry everything, for all files, even for those without QFE special build version, and QFECheck tool can be used to see if any files from the Service Pack were overwrittedn accidentaly by some older version or not. It means that in the documentations would be written that "Missing File" is no error.

It is better than nothing and it would enable everybody to see that all files are correctly updated.

What do you think?

I will send you the sample of such file by e-mail.

Petr

0

Share this post


Link to post
Share on other sites

And another idea - many countries has changed the telephone dialing system since release of Windows 98 so it would be good to correct the registry entries.

Changes in the Czech Republic are described in http://support.microsoft.com/kb/327517

and the new registry entry is:

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Telephony\Country List\420]

"LongDistanceRule"="G"

Here it is described also for Greece: http://support.microsoft.com/kb/750109

Petr

0

Share this post


Link to post
Share on other sites
then explain why when my comp was workin fine with no problems and i put this file where it's sposed to and the next reboot it wants msdos 8.0 n thats windows me before it will start means a format of 98

comp is fairly new only 1-3 months old

Sounds like you're trying to use a file from MS-DOS 8x when using MS-DOS 7x!!!

You can't do that!!!

0

Share this post


Link to post
Share on other sites

I havent tried the ver 2.0 yet, but I tried RC3 not long ago.

I remember that I have once written a comment and ask for the ability of "Set attributes of sub files and sub-folders"

It takes place when we select and adjust the attributes of some folders and files, the sub files and folders (if exist) are also be changed.

This function is available in WinME and above, but Win 98 isnt.

I think it's very handy for users like me

Then you said you would try to make it, I was hopeful... :huh:

It was when you have ver 1.5. But now, even after a long time and now it has become 2.0, I noticed that ver RC3 (haven't tested but quite sure 2.0 Final still so) didn't have that function. Is it impossible to add it in?

Maybe you just forgot to add it in (hope so - dont tell me it's impossible! ^_^), so I write this to remind you :)

Waiting your response...

Edited by nasadows98
0

Share this post


Link to post
Share on other sites
2.0 RC2:

...

- REMOVED: General USB Mass Storage Device Drivers.

My flash drive works with the older versions, but not with the post-RC2 builds. Would you be able to create either an optional install of these drivers or maybe even a separate installer for people like me??

Thanks a MILLION, if possible!

:D

TiMeBoMb

0

Share this post


Link to post
Share on other sites

hi gape!

i'm a boy who works repairing and maintaining computers and networks.

and i'm from argentina, country where a lot of people still use windows98se, and we speak spanish...

i have did a special version of total commander (titled 'total commander reloaded+) with a lot of plugins and improvements.

also, i did a multiboot cd for myself (personal use) that have all (more than 100 items) boot utilities i need (os boot, partition managers, data recovery, hardware diagnostics, etc).

all with graphical user interface!

last year i saw your wonderfull idea about doing this SP for Win98SE, but I noticied that it is only avaliable in english.

i've sent you an e-mail last year telling (and requesting to you) some minimal help, tips and tricks for developing the Spanish SP for Win98SE. But no answer given... :}:(

Obviously i will credit you for your great idea and help in developing the spanish version (if any...)

Please, think about the possibility of millions of people (who speak spanish in Spain and Latin-america) upgrading their full-of-bugs win98SE installing this pack!

i promise i will only do some questions to get the thing working. thank you in advance!

mail me / msn me at: sidefx88@hotmail.com

thanks again

javier

0

Share this post


Link to post
Share on other sites
2.0 RC2:

...

- REMOVED: General USB Mass Storage Device Drivers.

My flash drive works with the older versions, but not with the post-RC2 builds. Would you be able to create either an optional install of these drivers or maybe even a separate installer for people like me??

Thanks a MILLION, if possible!

:D

TiMeBoMb

Have you tried maximus-decim's native usb 2.2 drivers? excellent....

it's posted here at the forums....http://www.msfn.org/board/index.php?showtopic=43605

or am I barking up the wrong tree!!

0

Share this post


Link to post
Share on other sites

Hi Gape,

congratulations for your excellent work! :thumbup

What about ADSL connection support? I think it's very important now.

Greetings from Uruguay...

0

Share this post


Link to post
Share on other sites
It simply boils down to aesthetics - "XP is prettier" is the common thread.

*steps up on soapbox*

Personally, I think the XP UI looks like a f**king clown car. Who thought that purple, orange, blue, red, and green was a good color scheme? Hell, while they were at it, they should have thrown in some fuschia. It sure couldn't make it uglier. And what's up with the ridiculously large window close, minimize, and maximize controls?

*steps down*

I routinely turn off all of the LUNA-cy when using XP, so it looks more sane, meaning identical to 95/98.

MS themselves admits that the little crap in LUNA is the results of "set for best APPEARANCE" while what is wanted is "set for best PERFORMANCE". Both are available, but the lunacy "serving suggestion" turns on all of the slow-down overhead. Thus, even if you have a fast machine, XP crawls along identically to what it does on a "slow" machine [well, slow for XP standards!].

Apparently, things work sort-of like this:

When the start menu goes to another level, schedule a sleep task and the task to get ready the stuff to paint the screen with. When either is done, wait for the other. When both are complete, THEN paint the screen with the results. So, if your machine takes 3 seconds to number-crunch the next menu-level update, then you are just about done when the sleep task is already done, and then you paint the screen after the delay. If you have a **** fast machine, you might calculate the screen update in less than 1/4 sec, but you then wait for 2.75 more seconds for the sleep task to finish. Either machine appears equally crawlly, etc.

But if you set the max PERFORMANCE settings, the slow machine appears fidgety, unlike in 98SE, since the overhead shows how overloaded the slower machine can be. On the fast machine, it can resemble the zippy performance we are used to in 98SE, etc.

BTW, XP SP2 has added another category of cosmetic silliness to luna, to slow things down even more. When you click on an .exe file, execution, BY DEFAULT, is delayed as the selected icon fades out. Thus, the further disparity between "maximum appearance" and "maximum performance".

Remember, LUNA makes it real easy for those who have more fingers on their hands than items they access on their computers. To run the REAL program menu you have to goto "all programs" and wait three more seconds to get into the actual programs start menu. [but you can make any number of desktop icons to match whatever you run often, so why need LUNA at all? Isn't in your face better than having to call up any form of sub-menu? Besides, the desktop itself could have folders on it with sub-menus inside, ad nauseum, etc.]

Another user has perhaps a better description of LUNA, it's the TELETUBBIES version of Windows. [bob version 2?]

cjl

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.