Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

RIS +OEM Nics&MassStorage +Sysprep Factory&Reseal

* * * * * 1 votes

  • Please log in to reply
4 replies to this topic

#1
dk_

dk_
  • Member
  • 6 posts
Excuse me for my English... :)

This is short guide how to installing MS RIS and deploying WinXP OS w Drivers and additonal software.

Hardware:
Server 1 - AD + DHCP (w2k3std)
Server 2 - RIS (w2k3std)
Test workstations w Intel and Sis MB (wXP prof, wXP Home as Guest OS ;)
LAN - included ;)

AD:
Must exist user w/o Admin privilege, but w right to "Join a computer to the domain"
This right may added via "Domain security policy" -> Local Policy \ User Right Assignment \ Add workstations to domain
Or Active Directory Users and Computers \ "DOMAIN" \ Delegate Control -> Join a computer to the domain.
Or together :)

DHCP:
1 Scope w Ip range 192.168.0.xx - 192.168.0.xx
Scope options like Proxy, dns, wins, ntp - NOTHING ELSE
INet may say to you - Add option #60, 66, 67 - its not needed for modern NICs w PXE 2.xx boot rom like Intel PRO 100/1000, Marvell, Realtek, Sis LOM
(IMHO ;)

RIS:
Little story
I have E55 Error... something like "PROXY DHCP do not answer" After reading PXE spec. I'm understand what is PROXY DHCP - its RIS binl service. Good name for TFTPD... ;) In Binlsvc.log found - Sending response to 255.255.255.255 only!!! Of course its nothing to work :O
PXE client show me that it takes IP from DHCP... but RIS is sending reply to all... HM... And I'm stop and disable DHCP service on RIS service (w/o any scope) -- remote boot starts to work.
End of Little story

Nothing intresting in tuning RIS. Adding RIS from Install/Remove, then risetup -add to next images.

2 servers is not necessary, may be one is better, but... :)

OSC:
laziness - is the main world engine :)
In RemoteInstall\OSChooser\%LANG%\login.osc
My %LANG is Russian
Lets find strings

&nbsp&nbspUser name: <INPUT NAME="USERNAME" MAXLENGTH=255>
&nbsp&nbsp&nbspPassword: <INPUT NAME="*PASSWORD" TYPE=PASSWORD
MAXLENGTH=20><BR>

and add
VALUE="USER_NAME_IN_AD_W_PRIV_TO_ADD_NEW_PC_TO_AD"
VALUE="PASSWORD_OF_THIS_USER"

like this:
&nbsp&nbspUser name: <INPUT NAME="USERNAME" MAXLENGTH=255 VALUE="USER_NAME">
&nbsp&nbsp&nbspPassword: <INPUT NAME="*PASSWORD" TYPE=PASSWORD MAXLENGTH=20 VALUE="PASSWORD"><BR>

it's all my changes in .OSC files

WAR1 - w Intel NICs:
Trying to install wIn from RIS and, of course, Error about Win "don't have necessary network drivers" MS.com says to add drivers to i386 folder and $OEM$\$1\Drivers\Nics and edit Ristndrd.sif w follow:
OemPreinstall=Yes
OemPnPDriversPath = "drivers\nic\ipro100"
But it's NOT work!!!
SPECIAL for MS RIS Intel have SOLUTION! Named (from Intel): "RIS-Specific INF files for use with Intel 10/100 Network Adapters on Windows* XP RIS images."
http://downloadfinde...ldID=6761&agr=N
Great - it's WORK :P ....
But not all - new Intel LOM (Lan on MotherBoard) on i915 chipset failed w same Error :(
Installing wIn from CD and cheking Hardware ID = pci\ven_8086&Dev_1065. Seeking Dev_1065 in downloaded from Intel INF. None :((
After dancing around INF file with shaman tambourine... combine SPECIAL INF w ORIGINAL INF for this NIC :) Hand made INF ;)))

Nics from SIS, Marvell and Realtek working fine 8-)

WAR2 - w MassStorageDevices:
After 3 days of experiments found 4 points of parsing MassStorageDrivers
1) Textmode setup before copying files
2) Textmode setup after copying files to c:\bla-bla.~LS
3) Before loading GUI setup
4) Loading Installed wIn

Steps
1) In $OEM$ folder creating TEXTMODE folder
2) Copy txtsetup.oem from original driver to Textmode folder
3) Parsing txtsetup.oem (examples from my txtsetup.oem):

[Disks] ;Location of sys, cab, dll & inf files. This section needed for section [Files.xxxxxx]
d1 = "SiS Raid/IDE Driver Diskette", \disk.tag, \
NameOfDisk(any) = "Unused information(any)", PathToTagFile\TagFile(Unused by Setup) , PathToFiles (\ - root of TEXTMODE)
In RIS may be only one "Disk" maped to root of Textmode like
disk = "Textmode MSD",\ ,\ (but not tested)
About points of parsing MSD... On first point (Setup is loading drivers...) setup parser understend folder structure under Textmode!!!!!
May be:
+ Textmode
|--------SisRaid
|--------IntelRaid
and [Disks]
disk1 = "SiS Raid/IDE Driver Diskette", \disk.tag, \SiSRAID\
!!!!!!!!!!!!!!!
Setup load correct driver and possible to manage partions
BUT on Second stage (copying files from c:\bla-bla.~LS to c:\windows) setup stops w error somthing like "sysraid.sys not found -> Retry, Skip" After skipping and rebooting GUI setup will load BSOD :) Point 3
So... structure of folders in Textmode is impossible :'(
Ok, get back to txtsetup.oem. Next section
[Defaults]
scsi = VMSCSI
This section Seems not important or not used by setup

[scsi]
SISRAID964_181 = "WinXP SiS180 Raid Controller"
VMSCSI = "VMware SCSI Controller Installation Disk"
iaStor = "Intel® 82801ER SATA RAID Controller"

InternalNameForThisSIF = "Discription"

"Discription" MUST BE in ristndrd.sif (i386\Templates) like this
[MassStorageDrivers]
"WinXP SiS180 Raid Controller" = "OEM"
"VMware SCSI Controller Installation Disk" = "OEM"
"Intel® 82801ER SATA RAID Controller" = "OEM"
"IDE CD-ROM (ATAPI 1.2)/PCI IDE Controller" = "RETAIL"

Next sections
[Files.scsi.SISRAID964_180] ;[Files.scsi.InternalNameForThisSIF(from [SCSI])]
driver = d1,SiSRaid.sys, SISRAID ; SISRAID - name of service must be = name of file
!IMPORTANT START!
catalog= d1,Property.dll
;Original line was DLL= d1,Property.dll, DLL MUST BE RENAMED to "CATALOG" NOT TO INF, as you may read in other web-sites, because setup process rename files w INF predict to "OEMscsXX.inf" and place to \%windir%\OemDir !
03.09.2004 14:40 1 779 oemscs01.inf
30.03.2001 22:58 135 168 oemscs02.inf ; this is not INF!!!! By size :D
27.09.2004 12:41 8 264 sisraid.cat
03.09.2004 13:43 46 464 SiSRaid.sys
For SiS Raid I'm found error (then dll was renamed) in setupapi.log in \%windir% (not full log)
[2004/10/19 17:40:16 288.1111 Driver Install]
#-019 Searching for hardware ID(s): pci\ven_1039&dev_0180&subsys_810e1043&rev_01,pci\ven_1039&dev_0180&subsys_810e1043,pci\ven_1039&dev_0180&cc_010485,pci\ven_1039&dev_0180&cc_0104
#I022 Found "PCI\VEN_1039&DEV_0180" in C:\WINDOWS\inf\oem0.inf; Device: "SiS 180 RAID Controller"; Driver: "SiS 180 RAID Controller"; Provider: "Silicon Integrated Systems Corp"; Mfg: "Silicon Integrated Systems Corp"; Section name: "SIS180PCI".
#I058 Selected best compatible driver.
#-124 Doing copy-only install of "PCI\VEN_1039&DEV_0180&SUBSYS_810E1043&REV_01\3&267A616A&0&28".
#-167 SPFILENOTIFY_NEEDMEDIA: Tag = "", Description= "SiS 180 Raid Controller Driver Disk", SourcePath = "C:\WINDOWS\OemDir", SourceFile = "property.dll", Flags = 0x00000000.
#E169 SPFILENOTIFY_NEEDMEDIA: returned FILEOP_ABORT. Error 1223: The operation was canceled by the user.
#W187 Install failed, attempting to restore original files.
#I060 Set selected driver.
#-166 Device install function: DIF_INSTALLDEVICE.
#I125 Installing NULL driver for "PCI\VEN_1039&DEV_0180&SUBSYS_810E1043&REV_01\3&267A616A&0&28".
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!! Installing NULL driver - is really BSOD
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
#I121 Device install of "PCI\VEN_1039&DEV_0180&SUBSYS_810E1043&REV_01\3&267A616A&0&28" finished successfully.
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!! finished successfully :DDDDDDDDDDD
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
This is Point 4 ;)
!IMPORTANT STOP!
inf = d1,SiSRaid.inf
catalog= d1,sisraid.cat

this sections from original driver w/o changes
[HardwareIds.scsi.SISRAID964_180]
id="PCI\VEN_1039&DEV_0180", "SISRAID"

[Config.SISRAID]
value = parameters\PnpInterface,"5",REG_DWORD,1

All about txtsetup.oem, full listing of my config fliles will be at the end of post

Steps continue:
4) After compiling txtsetup.oem copy all files listed in [Files.xxxxxx] sections to Textmode\
5) In ristndrd.sif (i386\Templates) MUST BE Sections from [SCSI]
"WinXP SiS964 Raid Controller" = "OEM"
"VMware SCSI Controller Installation Disk" = "OEM"
"Intel® 82801ER SATA RAID Controller" = "OEM"
;AND THIS (below)
"IDE CD-ROM (ATAPI 1.2)/PCI IDE Controller" = "RETAIL"

Another intresting thing... In ristndrd.sif section [OEMBootFiles] is EMPTY (but exist)! I'm not list files from Textmode to this section and all working fine!!!!!!!!

Tip. All errors during setup w MassStorageDrivers like error in bla-bla.c file string XXXX BECAUSE txtsetup.oem is BAD. Write it carefully!!!

Deploy process:
Client from PXE install OS
At the end of Install run sysprep -factory -quiet - reboot
Factory copy from network share needed files; pnp drivers, Mui, other...
Factory install pnp drivers
Starting reseal
At the end of reseal installing MUI, reg tweaks, OEM logos

Directory structure:

RIS Server\D\
+OEM
|--Drivers -> Then copy drivers via Factory paths !!automatically!! added to HKLM \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ DevicePath
|----- 00_addons
|----- 01_chipset
|----- 02_Video
|----- ......
|-- Mui
|-- Mui2k3
|-- OEM -> My .cmd files; oeminfo.ini, oemlogo.bmp and other
|-- Storage -> For 2k3 server raid drivers

+RemoteInstall
|-- Admin
|----- NicI386 - collection of files, to add in I386 folder for new Image
|----- TextMode - MSD
|--Setup\Russian\Images\XPC.SP2
|----- $OEM$
|--------$1
|----------- Drivers
|-------------- Nic -> For Factory work
|----------- Sysprep
|-------------- factory.exe
|-------------- netcfg.exe
|-------------- setupcl.exe
|-------------- sysprep.exe
|-------------- sysprep.inf
|-------------- winbom.ini
|-------- Textmode
|----- i386

LISTINGs
-------------
ristndrd.sif
-------------
[Data]
AutoPartition="0" ;Setup don't auto create partitions
MsDosInitiated="1"
UnattendedInstall="Yes"
floppyless="1"
OriSrc="\\%SERVERNAME%\RemInst\%INSTALLPATH%"
OriTyp="4"
LocalSourceOnCD=1

[SetupData]
OsLoadOptions="/noguiboot /fastdetect"
SetupSourceDevice = "\Device\LanmanRedirector\%SERVERNAME%\RemInst\%INSTALLPATH%"

[GuiUnattended]
AdminPassword=*
AutoLogon=Yes
AutoLogonCount=99
OEMSkipRegional=1
OEMSkipWelcome=1
TimeZone=201

[Unattended]
AutoActivate=No
CrashDumpSetting=0
DriverSigningPolicy=Ignore
UpdateInstalledDrivers=Yes
FactoryMode=No
FileSystem=LeaveAlone
Repartition=No ;Setup don't auto create partitions
OemPreinstall=Yes
OemPnPDriversPath = "drivers\nic\D-Link\500sx;drivers\nic\D-Link\500T;drivers\nic\D-Link\530;............."
OemSkipEula=Yes
TargetPath=\windows
UnattendMode=FullUnattended
UnattendSwitch=Yes
WaitForReboot=No
OverwriteOemFilesOnUpgrade=No
InstallFilesPath = "\\%SERVERNAME%\RemInst\%INSTALLPATH%\%MACHINETYPE%"
LegacyNIC = 1

[Display]
BitsPerPel=32
Xresolution=1024
YResolution=768
VRefresh = 60

[PCHealth]
ER_Display_UI=0
ER_Enable_Applications=None
ER_Enable_Kernel_Errors=1
ER_Enable_Reporting=0
ER_Enable_Windows_Components=1
ER_Force_Queue_Mode=0
ER_Include_MSApps=0
ER_Include_Shutdown_Errs=0
RA_AllowFullControl=1
RA_AllowToGetHelp=1
RA_AllowUnsolicited=1
RA_MaxTicketExpiry=28800

[RegionalSettings]
Language = 0419
LanguageGroup=5,1
SystemLocale=00000419
UserLocale=00000419
UserLocale_DefaultUser = 00000419
InputLocale=0409:00000409, 0419:00000419
InputLocale_DefaultUser=0409:00000409

[Shell]
DefaultStartPanelOff=No
DefaultThemesOff=Yes

[TapiLocation]
CountryCode=7
Dialing=Pulse
AreaCode=3812
LongDistanceAccess="0"

[TerminalServices]
AllowConnections=1

[UserData]
ProductKey=XXXXX-XXXXX-XXXXX-XXXXX-XXXXX
FullName="OEM"
OrgName="BTG-OEM"
ComputerName=*

[URL]
AutoConfig=1

[Identification]
JoinWorkgroup=VTI

[Networking]
InstallDefaultComponents=Yes

[RemoteInstall]
Repartition=No ;Setup don't auto create partitions
UseWholeDisk=No ;Setup don't auto create partitions

[Branding]
BrandIEUsingUnattended=Yes

[URL]
Home_Page=http://www.btg.ru
Help_Page=http://www.btg.ru
Search_Page=http://www.ya.ru

[WindowsFirewall]
Profiles = WindowsFirewall.TurnOffFirewall

[WindowsFirewall.TurnOffFirewall]
Mode = 0

[GuiRunOnce]
Command1="c:\sysprep\sysprep -factory -quiet -reboot"

[MassStorageDrivers]
"WinXP SiS964 Raid Controller" = "OEM"
"WinXP SiS180 Raid Controller" = "OEM"
"VMware SCSI Controller Installation Disk" = "OEM"
"Intel® 82801ER SATA RAID Controller" = "OEM"
"IDE CD-ROM (ATAPI 1.2)/PCI IDE Controller" = "RETAIL"

[OEMBootFiles]

[OSChooser]
Description ="XP Prof Corp SP2"
Help ="MSD: VmWare BUSLogic, SiS: 964_180,964_181,965, iNTEL: 82801ER SATA Raid"
LaunchFile = "%INSTALLPATH%\%MACHINETYPE%\templates\startrom.com"
ImageType =Flat
Version="5.1 (0)"

-------------
winbom.ini
-------------
[Version]
signature=$CHICAGO$

[ComputerSettings]
ExtendPartition = 0
FontSmoothing = On
Hibernation = No
PowerScheme = Desktop

[Factory]
AutoDetectNetwork = Yes 'If you have error 1231 in winbom.log this line must BE
FactoryComputerName = * 'If you have error 1231 in winbom.log this line must BE
RebootAfterComputerName = Yes 'If you have error 1231 in winbom.log this line must BE
WinbomType="Factory"
Password="PASSWORD"
Username="USER@DOMAIN"
Reseal = Reboot
ResealFlags = -activated -nosidgen
ResealMode = Mini
Logging =Yes
Logfile = c:\windows\factory.log


[PnpDrivers]
\\RISserver\oem\drivers = PnPDrv
\\RISserver\oem\oem = oem
\\RisServer\oem\Mui = MuiRu

[PnpDriverUpdate]
TargetRoot = %WINDIR%
WaitForPnP = Yes
UpdateInstalledDrivers = No
DevicePath = PnPDrv\Ati;

[OEMLink]
OEMBrandIcon = %WINDIR%\Oem\btgSM.ico
OEMBrandLink = "http://www.btg.ru/"
OEMBrandLinkInfoTip = "Just Tip ;)"
OEMBrandLinkText = "It'll be in Start menu"

-------------
Sysprep.inf
-------------
[Display]
BitsPerPel=32
Xresolution=1024
YResolution=768
Vrefresh = 60

[GuiUnattended]
AutoLogon = Yes
AdminPassword = *
OEMSkipRegional = 1
OEMSkipWelcome = 1
TimeZone= 201

[Identification]
JoinWorkgroup=VTI

[Networking]
InstallDefaultComponents=Yes

[RegionalSettings]
Language = 0419
LanguageGroup=5,1
SystemLocale=00000419
UserLocale=00000419
UserLocale_DefaultUser = 00000419
InputLocale=0409:00000409, 0419:00000419
InputLocale_DefaultUser=0409:00000409

[Unattended]
ExtendOemPartition =0
OEMSkipEula = Yes
KeepPageFile = 0
UpdateInstalledDrivers = Yes

[UserData]
ComputerName = *
FullName = "OEM"
OrgName = "BTG-OEM"
ProductKey = "XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX"

[GuiRunOnce]
Command1="c:\windows\oem\mui.cmd"
Command2="c:\windows\oem\factory.cmd"
Command3="c:\windows\oem\all.cmd"

-------------
Txtsetup.oem
-------------
[Disks]
d1 = "SiS Raid/IDE Driver Diskette", \disk.tag, \
d2 = "SiS Raid/IDE Driver Diskette", \disk.tag, \
d3 = "VMware SCSI Controller Installation Disk", \disk.tag, \
d4 = "Intel Application Accelerator driver", \disk.tag, \

[Defaults]
scsi = SISRAID964_180
scsi = SISRAID964_181
scsi = VMSCSI
scsi = iaStor


[scsi]
SISRAID964_180 = "WinXP SiS964 Raid Controller"
SISRAID964_181 = "WinXP SiS180 Raid Controller"
VMSCSI = "VMware SCSI Controller Installation Disk"
iaStor = "Intel® 82801ER SATA RAID Controller"

;;;;;;;;;;;;;;;;;;;;;;;;;;;SiS 181;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

[Files.scsi.SISRAID964_180]
driver = d1,SiSRaid.sys, SISRAID
catalog= d1,Property.dll
inf = d1,SiSRaid.inf
catalog= d1,sisraid.cat

[HardwareIds.scsi.SISRAID964_180]
id="PCI\VEN_1039&DEV_0180", "SISRAID"

[Config.SISRAID]
value = parameters\PnpInterface,"5",REG_DWORD,1

;;;;;;;;;;;;;;;;;;;;;;;;;;;SiS 181;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

[Files.scsi.SISRAID964_181]
driver = d2,SiSRaid1.sys, SiSRaid1
catalog= d2,Property.dll
inf = d2,SiSRaid1.inf
catalog= d2,sisraid.cat

[HardwareIds.scsi.SISRAID964_181]
id="PCI\VEN_1039&DEV_0181", "SiSRaid1"

[Config.SiSRaid1]
value = parameters\PnpInterface,"5",REG_DWORD,1

;;;;;;;;;;;;;;;;;;;;;;;;; VMWARE ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

[Files.scsi.VMSCSI]
driver = d3, vmscsi.sys, VMSCSI
inf = d3, vmscsi.inf
catalog = d3, vmscsi.cat

[Config.VMSCSI]
value = "", Tag, REG_DWORD, 5
value = Parameters\PnpInterface, 5 ,REG_DWORD, 1
value = Parameters\Device, NumberOfRequests, REG_DWORD, 128

[HardwareIds.scsi.VMSCSI]
id = "PCI\VEN_104B&DEV_1040", "VMscsi"


;;;;;;;;;;;;;;;;;;;;;;;;;;; 82801ER ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

[Files.scsi.iaStor]
driver = d4, iaStor.sys, iaStor
inf = d4, iaStor.inf
catalog = d4, iaStor.cat

[Config.iaStor]
value = "", tag, REG_DWORD, 1b
value = "", ErrorControl, REG_DWORD, 1
value = "", Group, REG_SZ, "SCSI miniport"
value = "", Start, REG_DWORD, 0
value = "", Type, REG_DWORD, 1

[HardwareIds.scsi.iaStor]
id = "PCI\VEN_8086&DEV_24DF&CC_0104","iaStor"

The END.

P.S. Special thanks to Michael Waterman for RebootAfterComputerName = Yes ;)


How to remove advertisement from MSFN

#2
Michael_W

Michael_W

    Newbie

  • Member
  • 29 posts
Hi,

Thanks for the guide and specially for the credits :-)

Mike

#3
stutch

stutch
  • Member
  • 1 posts
Awesome. I have been trying for almost 2 weeks to get a Dell 4600 to RIS. Thanks for the link to Intel's site, that was exactly what I needed to get things up and running!! You are the man.

-CGS

#4
Bilou_Gateux

Bilou_Gateux

    Powered by Windows Embedded

  • Member
  • PipPipPipPipPip
  • 768 posts
Installing Windows Server 2003 on HP ProLiant Servers with RIS:

HP ProLiant Servers uses specific NICs (based on Broadcom chipsets) and MassStorage (Adaptec, LSI and COMPAQ/HP Smart Array controllers)
A good start is to download (free) the latest SmartStart CD ISO image containing all drivers for newest HP ProLiant Servers:
SmartStart

Current: HP SmartStart CD version 7.40 (9 Sep 05)

WARNING 1:
HP NC10xx/67xx/77xx/150x/320x/324x/325x/326x Gigabit Ethernet NIC Driver for Windows Server 2003
Drivers located on <HP SmartStart CD>\compaq\drivers\wnet\q57xp32
file that are to be placed in the RemoteInstall\Setup\Language\Images\WIN51IA.SP1\$OEM$\$1\drivers\net folder:
q57win32.cat
q57win32.inf
q57xp32.sys
file that are to be placed in the RemoteInstall\Setup\Language\Images\WIN51IA.SP1\I386 folder
q57xp32.sys
q57win32.inf <<<edited

Remove the [HPQ] section (see the following example):
[HPQ]
%NC320i% = NC320i.Inst, PCI\VEN_14e4&DEV_1659&SUBSYS_7032103c
.
.
%NC5750A1% = NC5750A1.Inst, PCI\VEN_14e4&DEV_1659&SUBSYS_7031103c

Remove NTx86.5.1 in two locations (see the following example):
[Manufacturer]

Original    Revised
[Manufacturer]     [Manufacturer]
%HPQ% = HPQ, NTx86.5.1     %HPQ% = HPQ

[HPQ.NTx86.5.1]     [HPQ]

edit RemoteInstall\Setup\Language\Images\WIN51IA.SP1\I386\templates\ristndrd.sif file
[Unattended]
DriverSigningPolicy = Ignore
NtUpgrade = No
Win9xUpgrade = No
OemPnPDriversPath = drivers\net;drivers\pnpdrvs
OemPreinstall = Yes
OemSkipEula = Yes
OverwriteOemFilesOnUpgrade = No
DisableVirtualOemDevices = yes
LegacyNIC = 1

WARNING 2:
HP Storage Controllers Driver for Windows Server 2003
txtsetup.oem single file located on <HP SmartStart CD>\compaq\install\wnet
*.* files for each controller listed in txtsetup.oem located on <HP SmartStart CD>\compaq\drivers\wnet\<controller> excluding txtsetup.oem file located on some <controller> subfolder and excluding NICs subfolders bxvbdx n100 n1000 q57xp32
file that is to be placed in the RemoteInstall\Setup\Language\Images\WIN51IA.SP1\$OEM$\textmode folder
edit RemoteInstall\Setup\Language\Images\WIN51IA.SP1\I386\templates\ristndrd.sif file
[OEMBootFiles]
	ADPU160M.SYS
	CPQARRY2.SYS
	CPQCISSM.SYS
	MegaIDE.sys
	Symmpi.sys
	LsiCsb6.sys
	HPCISSs2.sys
	TXTSETUP.OEM

[OEM_Ads]
	Logo=Compaq.bmp

[MassStorageDrivers]
	"Adaptec Ultra160 Family Manager Set"=OEM
	"Compaq Smart Array Controllers"=OEM
	"Smart Array 5x and 6x Controllers"=OEM
	"Integrated Ultra ATA-100 IDE RAID Controller (Windows 2000)"=OEM
	"LSI Logic Ultra320 1020/1030 Driver (Windows Server 2003)"=OEM
	"Carte h“te SCSI LSI Logic C8100 PCI"=RETAIL
	"Carte h“te SCSI LSI Logic C896 PCI"=RETAIL
	"Carte h“te SCSI LSI Logic C8xx PCI"=RETAIL
	"CD-ROM IDE (ATAPI 1.2)/Contr“leur IDE PCI"=RETAIL
	"CSB-6 Ultra ATA-100 IDE RAID Controller (Windows Server 2003)"=OEM
	"Smart Array SAS/SATA Controllers"=OEM
	"Adaptec RAID Controller"=OEM

others OEM Drivers:
HP ProLiant iLO Advanced and Enhanced System Management Controller Driver for Windows 2000/Server 2003
Drivers located on <HP SmartStart CD>\compaq\csp\nt\cp005397.exe SFX to extract
HP ProLiant Integrated Lights-Out Management Interface Driver for Windows 2000/Server 2003
Drivers located on <HP SmartStart CD>\compaq\csp\nt\cp005410.exe SFX to extract
Intel 6300ESB Chipset Support for Windows 2000/Windows Server 2003
Drivers located on <HP SmartStart CD>\compaq\csp\nt\cp004823.exe SFX to extract
file that are to be placed in the RemoteInstall\Setup\Language\Images\WIN51IA.SP1\$OEM$\$1\drivers\pnpdrvs folder

Edited by Bilou_Gateux, 19 October 2005 - 02:30 AM.

OS Version = 5.1.2600 Service Pack 3
Platform ID = 2 (NT)
Service Pack = 3.0
Suite = 0x0140
Product Type = 1
Architecture = x86

#5
Anderz

Anderz

    sensitivity?

  • Member
  • PipPip
  • 119 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Still have a few problems, but this really got me started ... well done mate! :thumbup
Anderz

I live my life - day by day...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN