Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



hasi001

Change requests - new ideas - wishlist

Recommended Posts

@hasi001:

that's actually a really cool feature - i never knew that!

so if I include cond[pn]=['FileExists("%CDROM%\Install\PA\setupPA.exe")'] (edited toward correct path, obviously) for each program, then if the prog isnt included on the CD it won't show up in WPI? Nice!

Share this post


Link to post
Share on other sites

@hasi001:

That certainly is a usefull feature! I'm only not able to get it working :(

in my config.js I have:

prog[pn]=['OpenOffice.org 1.1.4 NL']
desc[pn]=['OpenOffice.org is een opensource vervanger voor MS Office.']
cmd1[pn]=['%cdrom%\\Software\\OpenOffice\\setup.exe -alluser -r:%cdrom%\\Software\\OpenOffice\\response.txt']
cmd2[pn]=['%cdrom%\\Software\\OpenOffice\\OpenOffice.cmd']
dflt[pn]=['no']
uid[pn]=['OOO1']
excl[pn]=['O2K3F','O2K3WEP','OOO2']
cond[pn]=['FileExists(replpath("%cdrom%\\Software\\OpenOffice\\setup.exe"))']
pn++

My debug screen (level 2) shows:

Rendering of boxes started
Found CDROM as drive F:
Condition failed: FileExists(replpath("%cdrom%\Software\OpenOffice\setup.exe")) -- not rendering OpenOffice 1.1.4 NL
Rendering of boxes finished

But I am 100% sure that 'F:\Software\OpenOffice\setup.exe' exists.

Am I doing something wrong here?

Share this post


Link to post
Share on other sites

Bug fixed in Version 3.3.1

BTW - checked the function. You do not need the replpath(),

so the cond-line should be as follows

cond[pn]=['FileExists("%cdrom%\\Software\\OpenOffice\\setup.exe")']

Share this post


Link to post
Share on other sites

@hasi001

This is probably the wrong threat, but in here you mentioned the update to 3.3.1.

I think I found a bug as your plain (no modifications) 3.3.1 already gives JS errors. I no nothing about Java, but I think the following code in generate.js misses a + between fontFileName and "': "

} catch (b) {
 debug("Problem on installing theme-supplied font '" + fontFileName "': " + b.message,1);
}

With the + it runs OK.

Oh, and before I forget, thank you for the quick response on my cond question. It is working OK right now.

Share this post


Link to post
Share on other sites

Would it be possible to let the .hta autodetect the %cdrom% setting by using something like:

var WshShell = new ActiveXObject("WScript.Shell");
WshShell.RegRead("HKEY_LOCAL_MACHINE\\SOFTWARE\\Microsoft\\Windows NT\\CurrentVersion\\SourcePath").substring(0,2);

This way it would be set to the sourcedrive that was used to install Windows with.

Share this post


Link to post
Share on other sites

RTFM ! cdrom is detected automatically. Have you ever looked at the config wizard ? %cdrom% is used often in demo-config. On the Homepages FAQ, it's also explained, HOW the correct path will be detected.

Share this post


Link to post
Share on other sites

I have a wish, a group options..

Wen you select at program or a named text, it auto.. add oder programs.

So you kan select a groupname and the group selects all programs for the group

Share this post


Link to post
Share on other sites

Feature Request

Ok, so right now it seems that WPI runs the RunOnceEx stuff that it adds right after you choose Begin Install. Is there any way to have it run them at the normal time? Like if you add stuff to runonce, then install of windows itself finishes and on first bootup it runs what is in runonce and then you're done? I'd prefer this over having it install them immediately.

Share this post


Link to post
Share on other sites

runonceex runs AFTER windows install finishes...

the programs you select in WPI should install immediatly.

Share this post


Link to post
Share on other sites

That's my point, I WANT them to install afterwards because some of my vbs scripts have permissions issues if they run when WPI makes them run (I'm testing a change in them to try and fix it) but I think to have the option to change would be nice...but that's just my personal preference.

Share this post


Link to post
Share on other sites

you're not being clear.

what do you want? programs to install immediatly, or on the following reboot?

now they're set to install immediatly. if you want to change the order in which they install, see the WPI homepage and read up about the ordr function.

Share this post


Link to post
Share on other sites

poppyg:

there's a way to achieve, what you want:

1st: set applications per install window to the maximum value in options

2nd: give every prog its ordr

3rd: prog with lowest order should be a reboot (syntax can be found somewhere in this forum)

4th: DO NOT SET install by category

--> this would lead to the following:

1st: after click on install, all progs would be written to the registry runonceex-branch

2nd: the first 'installed' program would be a call of rebbot-->computer reboots

3rd: startup - runonceex as usual on login

Share this post


Link to post
Share on other sites

This is what I want to do. But I don't know how.

I wan't to use my WPI as my autorun at the same time. But I want to have another button that will exit my wpi, and opens the Window's setup.exe.

Another thing is, an option to put a greyed out option. For example, the cleanup.cmd is something that I have to install everytime. So I want to set it as default, and greyed out so no one can uncheck it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×