Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



saitoh183

silent installation

Recommended Posts

saitoh183    0

Im having problems with some appplications that i are bieng installed silently during my windows setup. I've search but have found nothing.

Here are the programs:

- Gadwin Printscreen (wise installer)

- Belarc Advisor (Wise installer)

- Fabertoys(Inno installer)

- Slimbrowser (Nullsoft installer)

- M$ Powertoys(Windows XP Crativity Fun Pack)(Installshield with MSI Installer)

Gadwin Printscreen---> It asked me to choose a language before starting the silent installation. How do i get it to not ask me?

Belarc Advisor--->After the installation, it analyzes my PC and opens an HTML pages to show the results. How do i get it to install withouot running after that?...would taskkill work?

Fabertoys---> After the installation, it shows the group menu that it created. How can i get it to not show it, but keep the group menu selection that i chose during the installation...is it possible?...or do i have to select not to create a group menu at all?

Slimbrowser---> Same problem as Fabertoys

M$ Powertoys(Windows XP Crativity Fun Pack)---> At the end of the installation it opens the readme files in HTML. How do i get it to not do that?

@all

Thx in advance! :)

Share this post


Link to post
Share on other sites

saitoh183    0

I went to your link and i've read that before on the net;)...as for my prob, it doesnt solve it.

I have been able to install all the apps above silently. The problem is at the end of the installations...Fabertoys and Slimbrowser have the startup group poping up after the silent install...Gadwin Printscreen gives me a language selection before starting the silent install and M$ powertoys after the silent instal the HTML readme pop's up...

Using cleanup.cmd and taskill/pskill wont do a thing because all these probs happen right after the programs install's...

Share this post


Link to post
Share on other sites
Astalavista    1

huh?

that is what pskill or taskill is suppose to do to kill the pop up.

the language is stored in the registry. make a copy of the reg settings

export prior to installation, and use pskill

Share this post


Link to post
Share on other sites
saitoh183    0

@Astalavista

ok can you explain how pskill/taskill would work for my prob of Fabertoys and Slimbrowser? I have PSkill so how would i use it in my runonceex.cmd(syntax)?

Example:

REG ADD %KEY%\006 /VE /D "WinISO 5.3" /f
REG ADD %KEY%\006 /V 1 /D "%cdrom%\apps\WinISO\winiso53.exe /VERYSILENT /SP-" /f

REG ADD %KEY%\007 /VE /D "WinISO Task kill" /f
REG ADD %KEY%\007 /V 1 /D "taskkill /F /IM WinISO.exe" /f

taskkill would close the start menu group windows that pop's up after the installation? and in my example, is that the right syntax?

Share this post


Link to post
Share on other sites
prathapml    0

You need to put it as the next item...

REG ADD %KEY%\006 /VE /D "WinISO 5.3" /f
REG ADD %KEY%\006 /V 1 /D "%cdrom%\apps\WinISO\winiso53.exe /VERYSILENT /SP-" /f
REG ADD %KEY%\006 /V 2 /D "taskkill /F /IM WinISO.exe" /f

Notice that now there is an incremented number after "/V" for the second item.

Now for the explanation....

Taskkill is nothing but just a task-killer. Tell it which EXE to kill and it will do it. For example, lets see the startup group popping up after install - do a Ctrl-Alt-Del, and see all running "Processes". You will see that the startup group window is being shown by the "explorer.exe" file. So just put the relevant file-name in your runonceEX.

Example:

REG ADD %KEY%\006 /V 2 /D "taskkill /F /IM explorer.exe" /f

Share this post


Link to post
Share on other sites
prathapml    0
I always thought the batch files were run before explorer was first loaded, thus this problem doesnt occur.

Right.

The start menu folders won't be opened when installing silently before the explorer shell loads.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×