Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

c_20127.nls error after sysprep.

- - - - -

  • Please log in to reply
84 replies to this topic

#76
johnhc

johnhc

    MSFN Junkie

  • Member
  • PipPipPipPipPipPipPipPipPip
  • 3,364 posts
  • Joined 02-March 08
  • OS:Windows 7 x64
  • Country: Country Flag
DMahalko, I have two suggestions. First, please see the Unattended Guide. It shows how to include text mode drivers in the CD image and, of course, has no license restrictions. Second, see this thread. It shows a txtsetup.oem file file containing code to allow a USB floppy to load F6 drivers. I had to remove the code to get nLite to accept the driver. Perhaps you could include the code. Here is another thread on this. I also agree with Sp0iLedBrAt on the bootability. I started using ImgBurn to build my ISOs and DVDs and have had no problems since. It is freeware and I think does not have the restrictions nLite does. Please let us know what you learn. Enjoy, John.


How to remove advertisement from MSFN

#77
MauMau77

MauMau77
  • Member
  • 1 posts
  • Joined 11-June 10
  • OS:none specified
  • Country: Country Flag
After using the latest XP sysprep, i have the same issue.
Guess the solution still is copying the files to the folder indicated in the .ini file right?

#78
johnhc

johnhc

    MSFN Junkie

  • Member
  • PipPipPipPipPipPipPipPipPip
  • 3,364 posts
  • Joined 02-March 08
  • OS:Windows 7 x64
  • Country: Country Flag

After using the latest XP sysprep, i have the same issue.
Guess the solution still is copying the files to the folder indicated in the .ini file right?

MauMau77, obviously, we have no idea what you are doing. To me, using sysprep means a business environment and nLite is for personal use only. If you are using nLite in a business environment, then you should stop because the license agreement does not permit it. If you are not using nLite, then you need to post in the Unattended forum for XP. Enjoy, John.

#79
dVnt

dVnt
  • Member
  • 1 posts
  • Joined 17-June 10
  • OS:none specified
  • Country: Country Flag


After using the latest XP sysprep, i have the same issue.
Guess the solution still is copying the files to the folder indicated in the .ini file right?

MauMau77, obviously, we have no idea what you are doing. To me, using sysprep means a business environment and nLite is for personal use only. If you are using nLite in a business environment, then you should stop because the license agreement does not permit it. If you are not using nLite, then you need to post in the Unattended forum for XP. Enjoy, John.

You cannot assume people are violating nlite's license just because they're using sysprep... that's ridiculous.

Can someone explain why removing the unattended parameter InstallFilesPath solves this issue?

Edited by dVnt, 18 June 2010 - 09:56 AM.


#80
MacRasta

MacRasta
  • Member
  • 1 posts
  • Joined 23-July 10
  • OS:XP Pro x86
  • Country: Country Flag
Hi everyone,

I had the same problem, that's how I stumbled upon this forum.I thought I add something here because you guys are really helpfull!

I decided to go ahead and do a clean install of a computer with XP SP3,full windows update, installed all applications we need in our company, configured all settings, etc ....
Then sysprepped it, and captured it with WDS. When deploying this image, there's no problem at all ...
As for updates, I installed a WSUS server and push the updates with that.

It's simple and there's no hasle trying to fix this problem.

just my 2 cents ...

Keep up the good work!

Mac

#81
leondas

leondas
  • Member
  • 2 posts
  • Joined 21-April 11
  • OS:XP Pro x86
  • Country: Country Flag
I am having the same problem as described by many people and have tried the solutions on here about moving the install path and copying the files into there, removing the install path etc. Can anyone advise anything more I can try?

I have been told to use BartPE with DriveImage XML, although I'm not sure this will do what I am wanting it to do.

Just clarify this is what I am doing:

I am using nLite 1.4.9.1 to create Windows XP discs with Service Pack 3 and SATA drivers injected.

The latest laptops we get do not run smoothly in compatibility mode so this seems like the best solution for keeping it in AHCI mode and loading the SATA drivers, rather than pressing F6 and using a floppy etc.

I then use Sysprep to create an image and use mini setup and reseal before uploading to the WDS server.

When creating the image it is fine but then when you try to deploy that image back out onto other machines you always get an error about missing files. If you put the nLite XP CD in and point it to D:\i386 it finds the files and continues and the image works fine but this obviously defeats the object of creating an image. The error I get is:

"the file 'c_20127.nls' on windows xp professional cd-rom is needed"

Edited by leondas, 21 April 2011 - 06:54 AM.


#82
Ponch

Ponch

    MSFN Junkie

  • Patrons
  • 3,308 posts
  • Joined 23-November 05
  • OS:none specified
  • Country: Country Flag
In case you haven't read the entire thread, may I point you to the fact nLite's EULA says it is for personal use only, so mixing it with Sysprep, WDS server, all that stuff and asking for help is a bit itchy.

Edited by Ponch, 21 April 2011 - 07:06 AM.


#83
leondas

leondas
  • Member
  • 2 posts
  • Joined 21-April 11
  • OS:XP Pro x86
  • Country: Country Flag
Yeah I had seen that, I was hoping that someone might have found a solution and would be willing to share.

Is there an alternative to nLite that can be used to create customised XP discs?

#84
coldcase

coldcase
  • Member
  • 1 posts
  • Joined 15-June 11
  • OS:Windows 7 x64
  • Country: Country Flag
XP-ISO-Builder is an alternative to nlite. You can find it at winfuture.de. I don't know if it solves the problem because I did not try. My SourceCD is already made with nlite including the XP SP3.

Edited by coldcase, 15 June 2011 - 10:05 AM.


#85
Rezzab

Rezzab
  • Member
  • 1 posts
  • Joined 24-September 12
  • OS:none specified
  • Country: Country Flag

You can get around this problem by creating a i386 folder in the sysprep folder and then put the files that are being requested in that folder. You can get the files from the "nlited" windows XP folder or from the CD that you burned.

e



Just to expand a bit on this...

1. Ready your system for imaging and make sure that you use ALL certified XP drivers otherwise after sysprep installs it will give you "driver not signed" errors - (you can simply click continue to each error, but eliminate a seemless install.)
2. Extract the contents from the deploy.cab file to the c:\sysprep directory
3. Run the Sysprep setup manager wizard NOT sysprep first (setupmgr.exe). I always use the mini-setup option in the wizard so that the user had to enter their info and the license key again. This process creates the i386 directory in the sysprep directory.
4. Copy the i386 directory on the CD to a place on the hard drive for future use (I use C:\OEM\i386\ ) AND copy this ALSO to the i386 directory in the the sysprep directory (you should already see a $i386$ directory in this i386 folder - just ignore it and copy the files to the c:\sysprep\i386\ folder)
Everything in the sysprep folder is deleted after the install so dont worry that you have the i386 folder copied in 2 places on the hard drive.
5. Run sysprep reseal




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users