mjerris

c_20127.nls error after sysprep.

85 posts in this topic

When I install from an Nlite created xp pro w/ sp2 cd and later run sysprep on that install, on first boot I get an error related to the c_20127.nls file not being found, if I browse to the system 32 directory the file is there and the install conitnues with a few more similar errors, all with files on the local machine properly, and the minisetup completes normally. This error does not occour on an install made with a normal slipstreamed xp2 CD.

Any help would be appretiated.

Thanks

Mike

0

Share this post


Link to post
Share on other sites

Has anyone else seen this issue. I continue to have this issue after minisetup is run after a sysprep from an nlite install.

Mike

0

Share this post


Link to post
Share on other sites

I am getting the same error.. has anyone found a fix yet?

0

Share this post


Link to post
Share on other sites

I never tried sysprep so it would speed things up if you explain to me how to reproduce the problem in short.

Thanks

0

Share this post


Link to post
Share on other sites

Well I slipstreamed sp2 in with XP and all the hotfixes using nlite, took out movie maker and a few other things. Then used that CD to load a laptop with XP at which point I ran sysprep using reseal option.. upon booting back up you get numerous erros .. I have talked to a few people now that have had the same problem..

0

Share this post


Link to post
Share on other sites

Hi nuhi, hi all:

sysprep is used for cloning, making a single installation usable on several different computers withput having to mess around with SIDs etc.

Myself I use sysprep in very large evnviroments using the same sysprepped image on laptops and desktops.

This is what you do:

Install Windows XP with everything needed on a desktop (laptops don't work for that), use FAT32 so you can mofify things in the image, Customize everything in the default userprofile, so you make sure that every new user get it. When this is done, create an image. This is helpful if you want a strting point later on, e.g. update software or drivers, hotfixes.

When done start up windows xp open a dos-prompt:

change into your sysprep folder

now:

sysprep -bmsd (creates the mass-storage section)

convert c: /FS:NTFS (say no, and the yes, so it will be converted after the next reboot

sysprep -clean (all drivers, etc will be unloaded)

sysprep -mini -quiet -reseal ( this will kick out the sid's, and force a mini-setup when the maschine is powered up again.

When sysprep is finished, the pc will be shutdown. Now take a new image. This image can now be cloned onto the maschine.

If you power the pc up, it converts the partition, reboots, and then after aminute or two it asks for the files needed.

If you have any questions feel free to contact me.

shortie

P.s.: In oder to use the image on laptops and desktops you must change the computer-type two Advanced configuration and the IDE controller to standard ide.

0

Share this post


Link to post
Share on other sites

Fixed it...you need to selected in Compatibility Wizard Windows Activation and I added few more files to keeping...changed the title...all in all wait next version and thank you :)

0

Share this post


Link to post
Share on other sites

camoman, have you tested it with nlite 1.0b1 ?

0

Share this post


Link to post
Share on other sites

Hi there,

as you may remember I got the same probs and with your latest version it works!!

No probs at all!

Reagrds,

shortie

P.s.: By the way nltie is not just great it is awesome!!!!

0

Share this post


Link to post
Share on other sites
Fixed it...you need to selected in Compatibility Wizard Windows Activation and I added few more files to keeping...changed the title...all in all wait next version and thank you :)

Hi nuhi! Great work!

You make my life easier! Nlite is the best thing ever happen to me.

But I still have the problem stated above. I added 39 hotfixes directly into nlite. Everything is fine if I don't sysprep my pc to make image for rest of the computers. But after I run sysprep and reboot I have c_20127.nls file missing error. When I press cancel, it went through fine. But it is a big delay for me when I deploy 100 computers coz I have to press cancel for each pc. I used RC1 through RC6 and I selected the compatilibity for windows activation and sysprep check box. Any advice for me please. Many Thanks

0

Share this post


Link to post
Share on other sites

Yup I know that sysprep bug is still there on reseal.

All you "need" to do is to point it to the CD or windows subfolders for missing files, they are there, it's just it don't see it...signature issue.

Since sysprep is mainly used in companies and other commercial branches and they never donated me anything I don't care either.

Don't get me wrong, it's not like I'm holding the fix, it is hard, I tried many times and decided it's not worth the hassle...like the dos winnt.exe bug. (winnt32 works ok)

0

Share this post


Link to post
Share on other sites
Yup I know that sysprep bug is still there on reseal.

All you "need" to do is to point it to the CD or windows subfolders for missing files, they are there, it's just it don't see it...signature issue.

Since sysprep is mainly used in companies and other commercial branches and they never donated me anything I don't care either.

Don't get me wrong, it's not like I'm holding the fix, it is hard, I tried many times and decided it's not worth the hassle...like the dos winnt.exe bug. (winnt32 works ok)

Hi,

I completely understand that! Paying lots of money for usless crap is no problem here, but donations... how how.. Anyway, I still don't use nLite at work since the sysprep problem is still there. If it is fixed, I could send a link to this thread to the boss :P

On the other hand, I don't work at a commercial company, but a university hospital.

0

Share this post


Link to post
Share on other sites

nuhi, I saw another article (something about Active Directory) you mentioned the c_20127.nls error would be fixed and we should look for 'sysprep fixed' in the changelog. I noticed it appears in the latest version (07?). My question though:

Do I need to do everything from scratch, or can I just take my existing N-Lite prepped files and run the latest version.

Thanx

Sean

Edited by sflesch
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.