Sign in to follow this  
Followers 0
kelvinloklok

Problem with ERD Commander

19 posts in this topic

i can sucessfully boot ERD Commander 2005 up with my multi-boot DVD. All functions work well except the firefox. It cannot even start! Can anybody tell me what the problem is? Thanks.

0

Share this post


Link to post
Share on other sites

erd commander does not support all programs. Also, there is a limit as to how many programs can be started at any given time (4 is the limit).

if FF is reading/writing to an unsuppoorted path it will not work

0

Share this post


Link to post
Share on other sites

but the fact is that firefox is included in erd commander 2005 and the original cd works fine. however i cannot start firefox using my multi-boot dvd

0

Share this post


Link to post
Share on other sites

i will make an assumption that you renamed the i386 folder to something like ERDC in your multiboot distro. FF has preference files that reference i386. Example =

"/I386/system32/FireFoxProfile/Application Data/Mozilla/Firefox/pluginreg.dat"

all the files hardcoded to I386 need to be changed.

(or just leave ERD Commander2005 in the I386 folder.

Also, FF needs temp space so if you are testing it w/o a HD (like VPC w/o a V-HD) it also will not work)

0

Share this post


Link to post
Share on other sites

i have to remain the folder as I386 since it cannot boot using other name

also, temp space is available

0

Share this post


Link to post
Share on other sites
Also, FF needs temp space so if you are testing it w/o a HD (like VPC w/o a V-HD) it also will not work)

Exactly!

I found out that running firefox from an ERD commander 2005 disk needs a writable C: partition. Because its normal way of working is to copy the default profile to %userprofile%.

0

Share this post


Link to post
Share on other sites
Also, FF needs temp space so if you are testing it w/o a HD (like VPC w/o a V-HD) it also will not work)

Exactly!

I found out that running firefox from an ERD commander 2005 disk needs a writable C: partition. Because its normal way of working is to copy the default profile to %userprofile%.

Yeah and it leaves the crap on your hard drive even after you exit the program. Also, this could be a danger if you were planning to recover lost files and did not want to write anything to the hard drive!

0

Share this post


Link to post
Share on other sites

I noticed that ERD 2005 booted from multiboot DVD won't allow me using EventLog and Service and Driver Manager.

When I start PC with ERD 2005 boot CD everything works perfect.

Multiboot DVD is made from http://flyakite.msfnhosting.com/ tutorial

0

Share this post


Link to post
Share on other sites

Hi all

Sorry, first post I've done and there was already a topic related.

Here is the solution to make ERD Commander 2005 work on Multiboot Environment:

http://www.msfn.org/board/index.php?showto...=FireFoxProfile

After that, you can do whatever you want, as long has you follow the rules to build the ISO. Even if you hex/ rename the I386 folder to ERDC (for ex:).

The basic is done, :)

Hope that helps, :D

0

Share this post


Link to post
Share on other sites

The most simple way:

just follow the http://flyakite.msfnhosting.com/ tutorial

then use

CDIMAGE.EXE -h -o -j1 -m -b

to make your ISO,never use whatever like UltraISO,winISO..etc.

It prove to be working after dozens of times of trying.

0

Share this post


Link to post
Share on other sites

Hi all

When I gave this solution, it was for a Multiboot CD/DVD with BartPE, or Avast! BART CD, and all kinds of boot Apps that you may add, O&O Blue Con, Disk Commander, Norton Ghost, watever).

Rico.Johnny

Well, after seeing your post, I went back and retried doing, (I was pretty sure I had tested almost every possible switchs with cdimage) the ISO for my Multiboot DVD and it doesn't work.

CDImage states that "Unicode filename \UBCD\WINSXS\X86_MICROSOFT.TOOLS.VISUALCPLUSPLUS.RUNTIME-LIBRARIES.RESOURCES_6595B64144CCF1DF_6.0.0.0_PT-PT_BB297039 is longer than 110 characters"

Why?

Because BartPE, (I've renamed my "I386" BartPE folder "UBCD") is built on an ISO9660 only with no restrictions (no Joliet File System) and when you use the "j1" switch (or the "-joliet" in mkisofs) it just stops working. (Also double-checked with Avast! BART and it uses, also, the ISO9660:1999 with no Joliet)

Mind you that this only happens with ERD Commander 2005.

In ERD Commander 2003, you can use all uppercase files and folders and still, every thing works.

Doing the way I've done will always get things working because ERD won't mind the lack of Joliet Filesystem, as long as those two folders ( "FireFox" and "FireFoxProfile") are in lowercase.

And, since Windows NT OSes (NT, 2000, XP and 2003) only need the ISO9660 directory tree, you can add, as many as you like.

My personal Multiboot DVD now has:

Avast! Bart CD

Avast! Bart CD /INRAM

Ultimate Boot CD for Windows (BartPE)

Hiren's Boot CD 6

Acronis True Image 8

Acronis Disk Director Suite 9

Acronis Privacy Expert 7

O&O XL Blue Console

Symantec Norton Ghost 9

Winternals Disk Commander 1.1.0

Winternals ERD Commander 2005

Winternals ERD Commander 2005 /INRAM

Windows 2000 Professional

Windows 2000 Server

Windows 2000 Advanced Server

Windows XP Home Edititon

Windows XP Home Edition Unnatended (Thanks to Unnatended.msfnhosting, :) )

Windows XP Professional

Windows 2003 All versions

I'm still considering in adding win 98 and ME but I'm pretty sure that it'll work if I had it to the project.

Hope this cleared some doubts.

João Oliveira

BTW: I've always followed flyakite's great website, :thumbup

0

Share this post


Link to post
Share on other sites

Maybe something should be clarified.

You must first let "ERD Commander 2005 Boot CD Wizard" create the ISO.

Then extract the content from the ISO using WinRAR..modify or add somthing to meet your need,of course, follow the flyakite's guide.

After everything is done,use CDImage to create a ISO with your modified content extracted from the ISO create by "ERD Commander 2005 Boot CD Wizard" ,dont use UltraISO,WinISO and the like.

here's my switches

CDIMAGE.EXE -lWXPVOL_EN -t2/12/2005,12:00:00 -h -o -j1 -m -bF:\WinXP_Pro_En_Vol\Boot.BIN F:\WinXP_Pro_En_Vol D:\xp.iso

i use this to make my multi-boot DVD containing winxp,ERD commander 2005, PartitionMagic....everything works like a charm,and some issues such as Fire Fox ,"..check winbom.ini..." also have been resolved

Sorry for my poor English,hope you can understand what i mean.

0

Share this post


Link to post
Share on other sites

Hi,

i got the "check winbom" error message on my original erd 2005 cd. i've added intel and realtek (and some raid ) drivers. but it doesn't work. testet on several systems. any hints?

thanks

sorry for my poor english too

0

Share this post


Link to post
Share on other sites

are you using the correct drivers for 2005? (erd 2005 is based on windows 2003 system set). are they the exact same drivers you are using on your current system or did you just grab a file from the driver install package?

0

Share this post


Link to post
Share on other sites

I'm using the intel nic drivers (extract from pro2kxp.exe) version 9.2. same driver for w2k,xp,w2k3.

e100b325.inf, e1000325 and so on added in "Additional Network Controller Drivers" window-

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.