Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Sign in to follow this  
Followers 0
janc

$OEM$ files not getting copied

17 posts in this topic

I have created an $OEM$ directory under FILESCD. Inside $OEM$ I have the directories $1 and $$. It is my understanding that anything inside the $1 directory will get copied to the root of the installation drive during installation and that anything inside the $$ directory gets copied to the Windows folder.

I have created the structure and added the files I want included. When I create the cd the $OEM$ directory is copied to the cd. But when I perform an installation the files inside the $OEM$ directory do not get copied to the hard drive.

What am I doing wrong?

0

Share this post


Link to post
Share on other sites

The $OEM$ folder is NOT created in the new partition, only "Program Files" & "Windows".

0

Share this post


Link to post
Share on other sites

Thanks for the reply. I realized after your post that I didn't phrase the question accurately. What I meant is that the files within $OEM$ are not being copied. For instance there is a $OEM$\$1\drivers directory. After installation there should be a C:\drivers directory, but it didn't get copied.

0

Share this post


Link to post
Share on other sites

Very strange! Is $OEM$ at the root of your CD? (i.e. at the same level of I386)

0

Share this post


Link to post
Share on other sites

Yes, $OEM$ seems to get copied to the CD correctly (at the CD root) . I can even install the drivers from the CD after the install. They just don't get copied to the HD.

0

Share this post


Link to post
Share on other sites

Check that you have the following line in Winnt.sif

OemPreinstall=Yes

0

Share this post


Link to post
Share on other sites

Don't you enter a space before $OEM$?

Sorry for this question, but there is no stupid question ;)

When there is a such problem, all questions are allowed :P

0

Share this post


Link to post
Share on other sites

@Gagorian: I'm sure you found the solution :)

0

Share this post


Link to post
Share on other sites

Jeeez, you guys are fast!

Welcome to MSFN, janc!

0

Share this post


Link to post
Share on other sites

I'm kind of having the same problem,

My folders aren't copied too. OemPreinstall=Yes is inside my winnt.sif

I'm trying to install via XPlode, but it doesn't seem to work because of my folders aren't being copied.

Anybody thinks he knows the problem ?

thx in advance! :)

jeroen.

EDIT: Believe it or not, but it does work now :-S, I didn't change anything, only retried in VMWare. No need for searching anymore ;-)

thx :-)

Edited by Jeroeneke
0

Share this post


Link to post
Share on other sites

Well this fixed my problem. I was doing everything I could think of (iso settings, double checking filenames, etc). This did it (setting the option to "Yes")

:)

0

Share this post


Link to post
Share on other sites

I have this exact same problem, however, I have everything set correctly, it just will not work no matter what i do, please tell me someone has the solution?!?!?!!

0

Share this post


Link to post
Share on other sites

Same problem here!

I did all of the tips and advices but the result is "nothing copies from "$OEM$"

I'm using nLite and i set the OEM Preinstall to Enabled, checked the Winnt.sif the OemPreinstall set as Yes.

I made the $OEM$ folder at the root of the CD including $$ and...

$OEM$\$$\Web\Wallpaper

$OEM$\$$\system32

$OEM$\$$\Resources\Themes

I did nuhi's advice:

"After nlite is finished make folder on the ISO root directory before making ISO"

Nothing copies :(

Am i missing something!? any advices will be helpfull.

0

Share this post


Link to post
Share on other sites

it seems no 1 replies here,too bad. I think in theory,setting OEM preinstall to yes and making the $OEM$ folder and adding the files should work for u. I've yet to test my installation and I may also encounter such a problem,so any gud reply will be extremely helpful to my friend and me as well.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.