keytotime

How to make a 7-Zip Switchless Installer

288 posts in this topic

DigitalAZ

it u are hving problems with keytotime guide

i have a video! yes a video on how to 7zip office 2003

check the link on my sig

keytotime

u are welcome to link or use my video as a ref to making 7zip.

:)

I cant find your video !

0

Share this post


Link to post
Share on other sites

I act according to your instructions and I made a file setup with 7Zip

But the program only compressed mode is removed and the file runs the installation program should I install it myself. While the installation program should automatically be done. Please guide me. :hello:

This my Config File :

config:

;!@Install@!UTF-8!

GUIMode="2"

RunProgram="Setup.exe"

;!@InstallEnd@!

And use this command :

copy /b 7zsD.sfx + config.txt + (Setup.exe).7z (Setup.exe).exe

0

Share this post


Link to post
Share on other sites

@keytotime

Thanks for this tutorial!

Could you please give the new links, because there are "broken"!?

Regards

0

Share this post


Link to post
Share on other sites

Many Thanks keytotime! :rolleyes:

Links work now correctly!

Regards

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

How can add extract progress bar in 7z switch-less installer? any that version 7z.sfx is available?

0

Share this post


Link to post
Share on other sites

haiiiiiiiiiiiiiiiiii

I need to copy some files to c:\

i used this code but not working :

--------------------------------------------

;!@Install@!UTF-8!

GUIMode="2"

RunProgram="cmd /c xcopy *.* \"%SystemDrive%" /y /h"

;!@InstallEnd@!

---------------------------------------------

What the true code i used to copy????????????

0

Share this post


Link to post
Share on other sites

haiiiiiiiiiiiiiiiiii

I need to copy some files to c:\

i used this code but not working :

--------------------------------------------

;!@Install@!UTF-8!

GUIMode="2"

RunProgram="cmd /c xcopy *.* \"%SystemDrive%" /y /h"

;!@InstallEnd@!

---------------------------------------------

What the true code i used to copy????????????

Happy to see that the problem is solved! :)

http://www.msfn.org/board/topic/101552-7z-sfx-modified-module-and-tools/page__pid__968970__st__240#entry968970

0

Share this post


Link to post
Share on other sites

about nod32 v4 silant instal with config.xml

What code I used from this:

RunProgram="setup.msi /qn /norestart /cfg=\"%%T\\config.xml"

RunProgram="setup.msi /qn /norestart /cfg=config.xml"

RunProgram="setup.msi /qn /norestart="ReallySuppress" ADMINCFG="%config.xml

%"

RunProgram="setup.msi /qn /config .\STANDARDR.WW\config.xml

and

I need to replace file prodect in program files with another

i need alike this code

rename %WinDir%\explorer.exe explorer.exe.1

copy explorer.exe %WinDir% /y

What code I use??????????

0

Share this post


Link to post
Share on other sites

@ = eltunisie

Please FIX your keyboard!

Also you really should stop asking for help with your warez installer of nod32 you are trying to make...

0

Share this post


Link to post
Share on other sites

@ = eltunisie

Please FIX your keyboard!

Also you really should stop asking for help with your warez installer of nod32 you are trying to make...

I'm very very very sorry

I will not ask about any thing

:hello: :hello: :( :( :( :(

Edited by eltunisie
0

Share this post


Link to post
Share on other sites

It is my error, inverted commas in line are obligatory!!! Should be so:

RunProgram="setup.exe /s /f2c:\\test\\mylog.log /z[-rpC:\\RHDSetup.log]"

About syntax of the command

setup.exe /s /f2c:\mylog.log /z[-rpC:\RHDSetup.log]

I do not know, but if it works in bath a file in such kind and in a file of a configuration of the modified module will work. Check up its work at first in bath a file, and then already working variant transfer to a configuration file considering inverted commas and double slashes.

Hello!

I tested with Realtek.

First, I create a new setup.iss file on my computer and change this one on my distribution folder for Realtek.

And config.txt is like this:


;!@Install@!UTF-8!
GUIMode="2"
RunProgram="Setup.exe -s"
ExecuteParameters="-f1setup.iss"
;!@InstallEnd@!

Works fine for me!

But, perhaps is there a better way to write the script ?

Regards

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.